copeman

Registered Users
  • Content count

    105
  • Joined

  • Last visited

Everything posted by copeman

  1. I went ahead and got the new (used) pc. The video card was dead so I installed an older one I had laying around. I then played this game on the very highest settings, everything maxed out, and was getting a good at the least 15+ increase in frames. That's significant, considering in large battles on my older machine I was getting like 15-20 fps on just performance settings. And this was with the older video card. The guy I bought this from is going to give me a card of comparable value and performance, so I will see how much more that helps too. The kicker? For whatever reason, there was a program on behind the scenes that was recording my game play. After I turned the game off I was able to watch what I just did. Didn't even notice it. So if I turn that off, I am certain to get even better performance, right?
  2. I currently have this one, which play the game just ok: Window 7 home premium AMD Athlon II x 4 635 processor 2.90 ghz 6.0 gb ram 64 bit os AMD Radeon HD 6600 series I can buy one for about $400 to $450 with: ASUS Windows 10 Professional Premium 64 Bit InstalledIntel Core i7-3770 Quad Core@3,40Ghz CPU16GB RAM, 1TB Hard DriveNvidia GeForce GTX 560 Graphics Card Which one would be better? I could also swap things out if need be.
  3. Man, that was one of the best battles I've been a part of. One of those memorable gaming experiences that will last with me for a while.
  4. He sounds identical to actor/comedian TJ Miller.
  5. I was able to download that file from elsewhere and it worked. Not sure why the first one didn't work. Oh well. I'm back on!
  6. Oh well, guess I lose the time for the welcome back soldier thing too......
  7. That didn't do anything. I love(d) this game, but I'm just not about to dump a ton of problem fixing on my pc (that I use to play many games) on it. Just don't have the time/patience anymore. If it's an easy fix, so be it. If not, oh well. Thanks a lot so far Merlin, it is appreciated.
  8. I've reinstalled, downloaded this new file, reinstalled again,and I still can't get into settings. Same report as before.
  9. Oh wait, the pc is showing its there but again, still no settings.
  10. hmmm, I donwnoaded it succesfully but its not showing up in my add/remove programs with the others, and i still can't access settings.
  11. I don't have that. It has a few 2005's, some 2008's and a 2010. ?
  12. I was able to play fine last week. Nothing has been changed on my pc. Now when I go to enter the game world, a window comes up saying "Installation/registry error: Installation may be corrupted. Please try reinstalling". What happened, and aside from reinstalling, what can I do? Thank you. As a side note, I can play off line fine, but for some reason there is no sound.
  13. Looks like (hopefully) my issue is resolved. After about the 4th time installing the game, it seems fine now. Crossing my fingers. Still not sure what happened, and why it's working now. Guess it could "break" at any time going forward again. Hope not.
  14. Well, for some reason it's not showing up in my add/remove programs. I can play now, but in order to so I must install the game each and every time. Not fun. If I can't fix this, I will have to just cancel. I'm not going through all this again. A shame too, I am really enjoying the game again.
  15. If I do the repair option, will that delete all of my saved information in the keymapper etc..? I know the uninstall-reinstall would. Thanks for the reply. If I can't get this to work, I am dropping the game, again. Day 1 player, just resubbed after quite a few years off. I remember the all of the hoops I had to go through early on to get this game to play/stay stable. I'm not about to do that again, after all these years.