Sign in to follow this  
Followers 0
AHWULF

CMD-TAB

25 posts in this topic

Apparently the rats can't replicate cmd-tab crashes on their macs. Can everyone who

(1) SOMETIMES or ALWAYS gets crashes when doing cmd-tab

(2) NEVER gets crashes doing cmd-tab

please reply to this message with their mac model/ram/video card and some indication of frequency, and if cmd-f every fails. Maybe we can figure out a pattern.

me:

NEVER, CMD-F always works

dual g5/2.5GB/ATI x-800

Share this post


Link to post
Share on other sites

Macbook Pro

Core 2

2.33 Ghz

2gb ram

ATY,RadeonX1600

Can't CMD-TAB when I am in the field. Causes the game to crash.

Can CMD-Tab when at brigade or persona but is a hit and miss. Sometimes it works other times I have to do it 10 times before I tab out. Other times it will freeze up the game.

CMD-F works fine

Hope that helps

S!

Share this post


Link to post
Share on other sites

I know for me everytime that with TeamSpeeX running if I cmd-tab out of the game and back then my whole machine locks up. I have to reboot to recover. This is a very nasty bug, indeed. I usually try to avoid any circumstance where I "might" have to cmd-Tab out of the game.

G5 2x2GHz 10.4.9 3+GB RAM, X800

Share this post


Link to post
Share on other sites
Macbook Pro

Core 2

2.33 Ghz

2gb ram

ATY,RadeonX1600

Can't CMD-TAB when I am in the field. Causes the game to crash.

Can CMD-Tab when at brigade or persona but is a hit and miss. Sometimes it works other times I have to do it 10 times before I tab out. Other times it will freeze up the game.

CMD-F works fine

Hope that helps

S!

Same here, thing is when I do CMD Tab while in the brigade screen I get some weird affect where anything I open or (TS) and scroll down the window itself gets some sort of color scramble on the screen but all I have to do is highlight it to correct the issue.

Share this post


Link to post
Share on other sites

So far:

CMD-TAB always works (though it can take a while); only issue is that when returning to game I get a persistent cursor on screen.

CMD-F Always works, though when going to window mode from in-game (not from UI) I get a strange color-shift that returns to normal after returning to full screen

G5 Dual 2 GHz, 1GB RAM, 10.4.9, ATI Radeon X800 XT

Share this post


Link to post
Share on other sites

The strange colors you get from cmd-f is a separate problem. It's the crash that we're trying to figure out.

Share this post


Link to post
Share on other sites

for me its the same as cadce and viruses:

CMD-TAB while in the field causes game to crash everytime. It seems to almost work but when finder is supposed to come up game crashes and my screen goes all black. I have to move a window around for it to clear.

CMD-TAB at brigade or persona normally works.

iMac G5 2.0GHz

1.5GB RAM

ATI 9600

Share this post


Link to post
Share on other sites

GOPHUR reported this may be fixed in the (closed) beta 3. Check it out if you are on the closed list. I will also but of course it always worked for me.

Share this post


Link to post
Share on other sites

I do crash on cmd-tab about 50% of the time or I get screen corruption that forces me to soft boot the screen off and back on.

Share this post


Link to post
Share on other sites

I`ve been away from home for quite a while now but I`ll try to remember exactly how it was.

CMD-Tabbing :

Consistantly crash ever single time I try to when I am spawned in. Never crash when at the map/brigade screen.

When doing it from the map/brigade screen AND at native resolution I may have to do it 10 times or 1 time to see the desktop. The key word is SEE. Every time I do it I do indeed switch to the desktop, but I may or may not see it (ie the video does not refresh). I can click on things, start programs from the dock, move files and folders, but nothing is displayed except the wwiiol screen. If I can manage to navigate to the menu bar and change the resolution, I will be able to see the desktop.

When doing it from the map/brigade screen AND I am at any resolution other than native (ie the display has to change resolutions to return to the desk top) it will show me the desktop every single time. One thing to note however is every time I press CMD-Tab once, I cannot get to the dock or see the menu bar. If I press it a second time or if I click anywhere on the screen I will now be at the desktop FOR REAL. It`s like it swiches out if wwiiol but it`s still there just not being displayed.

When doing it during the initial loading, it works fine but some letters in text do not display when I return and no amount of switching corrects the issue other than relaunching the game. This goes for the menu as well as in chat. I will refer you to my previous post. http://forums.battlegroundeurope.com/showthread.php?t=167118

CMD-F (playing in windowed mode):

This one I haven`t done for a while and cannot test it now.

While loading if I do it I can play the game in windowed mode but I get wired effects like either a thick fog where I can only see to about 3 feet but can see further at some angles, or a thick black fog with similar results.

At map screen I can but I forget what the effects are or if it works.

In-game if I do it it always results in a crash in the same way as CMD-Tabbing.

Thats as much as I can remember right now. My system is a dual 1.8G5 (2004), 3 gigs of RAM, 80 and 300GB HDs (wwiiol is on the 300GB), an X800XT with 256MB of video RAM updated to ROM version 109 IIRC and OSX 10.4.9 (or whatever the latest is).

Share this post


Link to post
Share on other sites

Well, I've used cmd tab more and more and the problem that keeps arising is the game screen freezes up. I'm unable to force quit the program or do anything else. But I do hear like people pm'ing me in the back ground. So its like the game is still running but the screen is frozen. In the end I usually have to force shut down the computer and restart it.

Share this post


Link to post
Share on other sites

Yeah the game is still in control of the screen, but the crash reporter is up in the background which keeps the os from grabbing the video back so you can click on the buttons. There is fix in the latest beta, but since I never got the crash I can't tell if it's fixed or not.

Share this post


Link to post
Share on other sites
Well' date=' I've used cmd tab more and more and the problem that keeps arising is the game screen freezes up. I'm unable to force quit the program or do anything else. But I do hear like people pm'ing me in the back ground. So its like the game is still running but the screen is frozen. In the end I usually have to force shut down the computer and restart it.[/quote']

I`m pretty sure your game isn`t freezing up. If you hit CMD-Tab 2 more times (release all buttons between each CMD-Tab) at that point you should end up back in the game. If you keep doing it over and over eventually you should see the desktop. Try running the game at any resolution other than what your desktop is set to and see what happens when you CMD-Tab.

Also, to force quit when you think it is frozen do cmd-opt-esc and then hit enter. The window is poping up like it should but you just can`t see where it is. By default wwiiol will be selected and the "force quit" button will be highlighted.

I would be VERY supprized if your computer was freezing when cmd-tabing. OSX just doesn`t do that anymore. I have had a genuine freeze across every single application I have ever used combined on my 3+ year old computer less than a dozen times. I have had many apps freeze or crash, but force quitting is never a problem, and wwiiol is no different.

Share this post


Link to post
Share on other sites

I'm getting a 75% success rate with it. I have two monitors so I generally try to just click into the finder and click back into wwii, some sort of combo with that and cmd-tab seems to always work. But it does take a long time to respond.

Mac Pro 2.66 Quad, 5gig's Ram

Share this post


Link to post
Share on other sites

It always crashes here. Attaching crash report I just created via alt-tab.

Quad G5/2.5 GB RAM/NV6600 card.

Share this post


Link to post
Share on other sites

CMD-TAB works good for me (for the first time) in the current beta (v1.27.0.8).

Share this post


Link to post
Share on other sites

Was there a recent fix for command-tab? If so, ignore my response.

I stopped playing the game for awhile - but last I played (2 weeks ago) Command Tab GUARANTEES that I will get kicked out of the game and end up looking at my desktop - but ONLY if I am actually SPAWNED IN the game. If I have the game loaded and Im just looking at the map, or at the brigade selction screen, I can Command-Tab just fine. If I am spawned in = 100% easily duplicated, game immediately quits.

iMac

1.8 Ghz PowerPC G5

10.4.10

2gigs Ram

nVidia GeForce FX5200

64MB VRAM

Share this post


Link to post
Share on other sites

Run the beta, it may already be fixed. Report as bug if it still doesn't work in the bug forum.

Share this post


Link to post
Share on other sites

Ran 1.27.16 and I can now switch apps while spawned in. I can also run in windowed mode but it looks like it is midnight in a horror movie with thick fog. Switching back to full screen though sends everything back to normal, so no big deal. Thumbs up to the rats. Just fix those damn FPS hogging buildings. I had 100FPS when I first ran the beta, but still only 19 looking at towns.

Share this post


Link to post
Share on other sites

Cmd-Tab works well with the beta v1.27.0b.19 when Online.

However, Cmd-Tab doesn't work Off-line. I can't even force quit. I need to press the powerbutton on the backside of my iMac (screen goes black). If a press it again a few seconds later will it come back as if Cmd-Tab worked with WWIIOL. All program is running and I can Cmd-Tab back to WWIIOL or force quit the program.

Using the newest iMac here.

OS X 10.4.10

Share this post


Link to post
Share on other sites

The Cmd-Tab issue is back for me. :(

I can not Cmd-Tab if I haven't spawned in. If I do will the game freeze and I have to reboot.

When I have spawned-in can I sometimes Cmd-Tab back-and-forth, other times does the game freeze and the sound starts looping. Howeverm, if I press the powerbutton so the game/iMac shut down and then within a few seconds press the powerbutton again will the game comeback without losing connection.

To run TS is therefore almost impossible, since TS will lose connection.

Share this post


Link to post
Share on other sites
The Cmd-Tab issue is back for me. :(

I can not Cmd-Tab if I haven't spawned in. If I do will the game freeze and I have to reboot.

When I have spawned-in can I sometimes Cmd-Tab back-and-forth, other times does the game freeze and the sound starts looping. Howeverm, if I press the powerbutton so the game/iMac shut down and then within a few seconds press the powerbutton again will the game comeback without losing connection.

To run TS is therefore almost impossible, since TS will lose connection.

Have you tried playing at non-native resolution? That may help.

Share this post


Link to post
Share on other sites

Well, what is really odd is that everything works well when I don't run TeamSpeex at the same time. And I hardly believe TeamSpeex could be the source here. Or could it?

Share this post


Link to post
Share on other sites

Ok, played yesterday with nothing but WWIIOL running.

The Cmd-Tab worked sometimes, but mostly not (I only tried to Cmd-Tab when I was spawned-in).

Most occasions was like this: Was spawned-in, pressed Cmd-Tab. Nothing happend but the curse comes up and can move around the curser. Game is now freezed.

Pressed Cmd-Tab again, and the little white hand comes up (like you are in another application) and you can move it around. Game is still freezed.

Pressed Cmd-Tab a third time, and the game is now activated again. During this process was the screen showing the game all the time.

At some rare occasions when I pressed Cmd-Tab did I actually move over to the Desktop, and could then move back to the game by choosing the game. I couldn't find a reason for why it worked sometimes and didn't at other times.

Very odd.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.