• Announcements

    • CHIMM

      RAT Chat Sunday 12/8 3pm server time!!!!   12/07/2019

      CRS is working overtime preparing and setting up the NEW SERVERS at the Portland colocation. This Sunday, December 8th, at 3:00 pm CST/9:00 pm GMT (Greenwich Mean Time). XOOM and the RATs are hosting a live chat discussing the move, and what services will be temporarily impacted in the process. Live chat link will be provided in discord channels when available. We look forward to chatting with you!
Sign in to follow this  
Followers 0
inchfan

Exception code: 0xc0000005 STATUS_ACCESS_VIOLATION

70 posts in this topic

Getting this constantly on spawning in with hard ctd. Read thru ever post, cannot find reason or cure, however it seems like hundreds of other folks have reported it also, is there any way to fix this? The game is completely unplayable.

File version: 1, 19, 7, 255

Program compile time: Sep 19 2005 09:23:44

Date and time: 10/23/2005 0:46:43

Exception code: 0xc0000005

Exception: STATUS_ACCESS_VIOLATION

Exception: continuable

Exception address: 0x01df4977

Exception tried to: read at address 0x25a40000

Exception Registers:

DS: 0x00000023, ES: 0x00000023, FS: 0x0000003b, GS: 0x00000000

EBP: 0x00000000, ESP: 0x0013f690, SS: 0x00000023, EIP: 0x01df4977

ESI: 0x25a3c018, EDI: 0x0022d6e0

EAX: 0x25a3fff8, EBX: 0x0013f770, ECX: 0x2230a9b0, EDX: 0x25a3ffd8

__________________

Share this post


Link to post
Share on other sites

Need your specs.

Also, i get hard ctd at spawn when 'video' ram is checked in setting --guess it don't like my card.

Ratszo

Share this post


Link to post
Share on other sites

Okay, after goofing with many settings etc, I've finally closed in on what this is. It's a "Data Execution Protection" (DEP) memory overlap.

In xp 2nd edition, MS put in a mandatory always on, memory manager that is supposed to keep malicious code from executing in memory. This "enhancement" is always on either protecting all system processes or all running processes. problem is, WW2 OL does execute commands in memory, so you ctd, mostly upon entering world after you select a player/vehicle.

In Control Panel, System, Performance, Advanced, (where you set your virtual memory) you'll see a tab for DEP, however your options are only "All system" or "all system minus these selected apps" then you select the apps you want excluded. Problem is, it doesn't work. Even though they're clicked for exclusion, they're still included for protection to a degree.

So, you have to completely disable DEP. Here's how.

Run MSCONFIG from your start/run box. When it comes up select the boot.ini tab. You'll have a line in there with

/NoExecute=OptIn or /NoExecute=OptOut These are the two options you can see from the DEP tab, but there are 2 more you cant see. "always on and always off. You need to set to allways off, thus disabling the MS protection that keeps WW2.EXE from executing commands in memory.

So using notepad, open the file c:\boot.ini, you won't see it in the selection list because it's hidden, just type it in and click OPEN, it;ll come up.

So change the line with /NoExecute to say

/NoExecute=AlwaysOff

Save, exit and reboot. The system will now allow WW2.EXE to make it's own calls within memory and stop the Exception code: 0xc0000005 STATUS_ACCESS_VIOLATION error.

Share this post


Link to post
Share on other sites

going to sticky this, and also look up why the exceptions are not working.

one note though, doing this may leave a slight possibility for wwiiol to give you a BSOD then.

Not guaranteed, but if suddenly the game gives you them after doing this

dont freak out, just undo it.

Share this post


Link to post
Share on other sites
going to sticky this, and also look up why the exceptions are not working.

one note though, doing this may leave a slight possibility for wwiiol to give you a BSOD then.

Not guaranteed, but if suddenly the game gives you them after doing this

dont freak out, just undo it.

found a relationship to overclocking and this error as well. Make sure you have latest drivers for your vid card and also if you overclock too much and have in setings (under trees tab) System memory, the problem happens more frequently, even with protection set to off.

Share this post


Link to post
Share on other sites

Heh - I went from an '03 nvidia detonator driver (with which I had not such problem) to the latest, greatest Omega and Wham.

Inchfan - you rock.

Here's hoping this werks...

It werks! Thanks again.

Share this post


Link to post
Share on other sites

1 additonal note. the 83 Nvidia drivers for US seem to do this with frequency, i've switched to the 83 international drivers and no exception codes in all my tests.

The older 40 series drivers that some folks recommended will not work with my card so I can't test them.

Share this post


Link to post
Share on other sites

I have tried this and unfortunately I am still getting CTD at de-spawn (4 out of every 5). Doesn't seem to be a pattern to it.

Latest error.log:

File version: 1, 20, 0, 255

Program compile time: Oct 24 2005 11:45:15

Date and time: 11/1/2005 9:00:50

Exception code: 0xc0000005

Exception: STATUS_ACCESS_VIOLATION

Exception: continuable

Exception address: 0x0b076dde

Exception tried to: read at address 0x00000404

Exception Registers:

DS: 0x00000023, ES: 0x00000023, FS: 0x0000003b, GS: 0x00000000

EBP: 0x0012f920, ESP: 0x0012f8ec, SS: 0x00000023, EIP: 0x0b076dde

ESI: 0x00000004, EDI: 0x000003fd

EAX: 0x00000400, EBX: 0x00000028, ECX: 0x00000000, EDX: 0x0b2d3f38

All help apreciated. Problem never experienced before 1.20. I have the latest Intel 82852 driver for the video card. I'm running the game at 1024x768x24bit. I run the settings at highest performance.

Share this post


Link to post
Share on other sites

Everytime i try to save the file it sais, ''This file exists with Read Only Attributes

Please use a different file name''. And i cant save.

Share this post


Link to post
Share on other sites

I'm in the same boat as mike. I just installed the game, and I'm achin to play. I tried the fix, it worked the first time after reboot. I thought all was well, then at de-spawn, it ctd-ed. Now, it won't even start up again. The sadness is overwhelming.

Share this post


Link to post
Share on other sites

No progress with this issue? I really hate to reply again, but it's killing me, I haven't been able to play since I've bought the game. Is there anywhere I can get an older version, just so I can at least play offline for a while to get a feel for it, while a solution is (hopefully) found?

Share this post


Link to post
Share on other sites

I have a suggestion if you people would like to try; try disabling N.T. 4.0 as compability mode before playing the game. I'm had this exception code problem when I try to run the game at N.T. 4.0 and I end up CTD'ing everytime. After I left it at its original settings (unchecked) I can play very well on the ground and it some times sutters at the air.

Share this post


Link to post
Share on other sites

I keep getting this problem too, I haven't even been able to get into the game. I run it, the screen goes black then goes straight back to the desktop every time.

All my drivers are up to date, and i've tried the suggestions above but nothing is working.

I used the free weekend play a couple of months back and that worked fine with no problems.

I had the game since Friday and haven't been able to play it once :(

Any more ideas?

Share this post


Link to post
Share on other sites

File version: 1, 20, 1, 255

Program compile time: Nov 9 2005 13:53:39

Date and time: 11/13/2005 1:18:24

Exception code: 0xc0000005

Exception: STATUS_ACCESS_VIOLATION

Exception: continuable

Exception address: 0x695e5760

Exception tried to: read at address 0xff12f1d4

Exception Registers:

DS: 0x0000002b, ES: 0x0000002b, FS: 0x00000053, GS: 0x0000002b

EBP: 0x0012f3b4, ESP: 0x0012f188, SS: 0x0000002b, EIP: 0x695e5760

ESI: 0x00000000, EDI: 0xffc00000

EAX: 0x00350000, EBX: 0x0000ffff, ECX: 0x5f350000, EDX: 0x5f350000

Is what i get.

I cannot do the boot.ini thing you suggest because im running winxp64pro and the option to disable this is not even there :(

Share this post


Link to post
Share on other sites

Actually I got it to change my boot.ini to alwaysoff as you typed above.

Restarted PC, checked ms config, showed boot.ini as having the new alwaysoff command on (I replaced /NoExecute=OptIn with /NoExecute=AlwaysOff) ...

started game...

launched infantry...

spawned...

crouched..

and 2 seconds later I was staring at my desktop again.

:(

Share this post


Link to post
Share on other sites

Still no solution... what vidocard do you have Skyfair? I have Intel and another user reported the same problem with the same card. Is the game not fully compatible with Intel cards?

Share this post


Link to post
Share on other sites

Here is my error...and it is new. I used to run stably...and now, almost every half hour, I get this...sometimes sooner, sometimes later. I inherited it when I tried to put i new vid card. I since have backed away from the new card to an older card, and still have the same effect. It came on suddently, and now wont go away. I reinstalled the game, drivers, everything I can think of....

File version: 1, 20, 2, 255

Program compile time: Nov 15 2005 10:44:07

Date and time: 11/20/2005 18:16:05

Exception code: 0xc0000005

Exception: STATUS_ACCESS_VIOLATION

Exception: continuable

Exception address: 0x048f2ae5

Exception tried to: write at address 0xc1bc056e

Exception Registers:

DS: 0x00000023, ES: 0x00000023, FS: 0x0000003b, GS: 0x00000000

EBP: 0x3cb417c6, ESP: 0x0012f8cc, SS: 0x00000023, EIP: 0x048f2ae5

ESI: 0x2929bdcc, EDI: 0xbbf2ed7e

EAX: 0xc1bc0562, EBX: 0x03ae1e40, ECX: 0x000000c3, EDX: 0x06a18b40

Share this post


Link to post
Share on other sites

No news on this? I have tried everything I know...various drivers, reinstall windows, reinstall game, etc. What I dont get is that I was running clean, and then it came out of nowhere. I installed a new vid card, a 6600, and this error came up. So I backtracked to my 5900, and it makes no difference. Something changed, and I have no idea what. I will try to reinstall DX9c, and will do the unenable sound thing to try to isolate...but the game in unplayable this way, with constant CTD.

Share this post


Link to post
Share on other sites

For those that cannot edit the boot.ini.

You have change settings in explorer. If you cant see the file, then likely you wont be able to edit it as your settings arent right. Inside windows explorer, click the tools tab and go to folder options. Go to the view tab. Find the Hidden Files and Folders option, and set it 'show hidden files and folder'. Secondly, UNCHECK the option for 'hide protected operating system files'. With this done, in the c: directory (or drive you installed windows on, your boot drive), you will now see the boot.ini. Right click on it, and select properties, and uncheck the the Read only box.

I have not tested this yet, but it will allow more of us to test.

Share this post


Link to post
Share on other sites

Full windows reinstall, from format...only OS and updates and WWIIOL running...and still get this Status Access Violation, even with the Always off setting.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.