Sign in to follow this  
Followers 0
TMAN

Joystick not recognized

25 posts in this topic

I have the saitek X52 which was never recognized in settings - controllers - joystick.

I purchased the Logitech X30 and I'm still having the same problem. I have tried booting PC - starting game - plugging it in hot and no luck.

Any suggestions?

Share this post


Link to post
Share on other sites

This belongs in the Windows help forum, I'm sure some mod will move it there soon. Does the JS get recognized by Windows in control panel/game controllers? Do you see all the axes move and buttons activate? If so then the problem is with the game.

The game has notorious conflicts with joysticks combined with Logitech products (especially mice and keyboards), which are somewhat surmountable, but annoying. The great SgtSpoon has spent years trying to figure out what the bug is and how to fix it. Here's a thread to start with if you do indeed have other Logitech products, like the G15 or G5 or similar devices.

http://discussions.playnet.com/showthread.php?t=139588

I did a search for logitech / stgspoon, and there are dozens of threads to look through if you want more info.

If this isn't your problem, well, then I'm temporarily stumped without further info.

Share this post


Link to post
Share on other sites

I have just purchased a Saitek Aviator joystick and the game does not recognize it either. I do not have a usb keyboard and I have only 3 HID files in my device manager and 2 of them are for the joystick. I disabled the third one and my mouse stopped working.

Is there something else I can check or do???

Share this post


Link to post
Share on other sites
I have just purchased a Saitek Aviator joystick and the game does not recognize it either. I do not have a usb keyboard and I have only 3 HID files in my device manager and 2 of them are for the joystick. I disabled the third one and my mouse stopped working.

Is there something else I can check or do???

Is the joystick recognized and working in control panel/Game Controllers? If not then it may not be properly installed in Windows. It doesn't sound like you should be having the HID bug with so few items.

Share this post


Link to post
Share on other sites

Nope it works fine in windows, it's only the game that causes the problems. The joystick is not recognized at all.

Share this post


Link to post
Share on other sites

I'm not familiar with the Aviator in particular, but have you installed specialized Saitek software that allows you to do keymappings and such? Just to make sure it's not actually the HID bug, could you uninstall the software and use the JS as just a regular JS? If you use the software I think it installs more HID drivers to control the keymapping. I don't know of any common bug in which a JS working in Windows doesn't work in the game, except the HID bug.

Share this post


Link to post
Share on other sites

I did not install the software.

The two files in the HID directory are: Saitek Aviator stick(HID)

Saitek Aviator stick(USB)

Do I need to disable one of these?

While I currently do not have any other usb items plugged in I have had some in the past. Could one of these have installed a HID file thats not showing in Device Manager thats affecting my joystick?

Share this post


Link to post
Share on other sites
I did not install the software.

The two files in the HID directory are: Saitek Aviator stick(HID)

Saitek Aviator stick(USB)

Do I need to disable one of these?

While I currently do not have any other usb items plugged in I have had some in the past. Could one of these have installed a HID file thats not showing in Device Manager thats affecting my joystick?

It would be interesting to try disabling one of the JS profiles. At least one will make your JS not work, but maybe one of them can be disabled. I don't think the problem is caused by HIDs you can't see. This doesn't sound exactly like the usual HID problem, but it would be good to check by disabling them.

Share this post


Link to post
Share on other sites

Do you have any on the back? I know some motherboards only contain support for USB 2.0 on some of the ports, and if that's the case it's sometimes the ones on the front that are underpowered. I kind of doubt this is the problem since Windows seems to recognize the JS, but it's worth a try. I know my X52 refuses to work through a hub due to low power.

Share this post


Link to post
Share on other sites

I do ... hadnt thought to try them. I know the ones in front work as I've used them before ... hmmm have to try the back ones after work tonight, thanks for the suggestions Dover.

Share this post


Link to post
Share on other sites

Sometimes when you say sgt.spoon, he comes and solves all of our wwiiol binding and keymapping issues.

Lemme see if i can hollar at him hope hes doing okay.

Share this post


Link to post
Share on other sites
I have just purchased a Saitek Aviator joystick and the game does not recognize it either. I do not have a usb keyboard and I have only 3 HID files in my device manager and 2 of them are for the joystick. I disabled the third one and my mouse stopped working.

Is there something else I can check or do???

Sorry that made me lol.

and if the computer was made in the past 5 years all ports are usb 2.0

Share this post


Link to post
Share on other sites

Well so much for the usb ports on the back of my computer ... no luck. This is great ... stuck with a $70 joystck that wont work with the game that I bought it for:mad:

Share this post


Link to post
Share on other sites

It is an issue w/ WW2OL, Vista , and having a USB Joystick, and Keyboard. I have the smae prob. It works fine in all other games in Vista, Just ww2ol does not support it(yet)

Share this post


Link to post
Share on other sites
It is an issue w/ WW2OL' date=' Vista , and having a USB Joystick, and Keyboard. I have the smae prob. It works fine in all other games in Vista, Just ww2ol does not support it(yet)[/quote'] yes im aware of it, doesnt hurt to check it.

Plus mcgib never said it worked on anything/anywhere else.

Share this post


Link to post
Share on other sites

The joystick works outside of the game. My keyboard is a ps2 not usb and I'm running winxp. The only suggestion I have gotten and havent tried yet is to delete the game and reinstall it.

Share this post


Link to post
Share on other sites

The joystick works outside of the game. My keyboard is a ps2 not usb and I'm running winxp. The only suggestion I have gotten and havent tried yet is to delete the game and reinstall it.
do that while leaving it plugged in.

Share this post


Link to post
Share on other sites

just a note, the hid problem isn't always specifically with a usb keyboard, plantronics headsets and a few other usb devices can install hid drivers that cause the specific conflict of joystick non-detection in ww2ol (but show fine in windows and works in other games).

if you are only showing three hid devices and they are all for the joystick and the mouse only, it's definitely not the hid problem.

tho if this is on Vista, I can't really give any advice since I haven't installed it yet myself.

have you tried simply keymapping it to see if the keymapper reads it?

sometimes people forget that the game doesn't automagically detect your joystick and set it up for the game, they jump in and it's not working but never check the keymapper to see if it reads it. the defaults are simply a chosen mapping by the developers that should work with most controllers but sometimes it doesn't and parts or the whole mapping needs to be redone by the player.

Share this post


Link to post
Share on other sites

When you say it doesnt recognize it..are you referring to the throttle not working when you try to fly? It specifically has to be mapped in the keymapper. Did you buy a usb keyboard and couple it with a ps2 adapter. It stillmay have installed HIDS. Check mouse keyboard and JS under Systems.

Share this post


Link to post
Share on other sites

as I said, if he's only showing THREE hids as he's stated above and ALL of them are related to the joystick and mouse... it's NOT the HID problem...

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.