Sign in to follow this  
Followers 0
bloo

Joystick issues fixed for version 1.29!

42 posts in this topic

Are you guys connecting the usb devices directly to the Pc or thru the other devices Like the G15). As that had me going a bit trying to make my x52 to work properly. I found out that some of the 3rd party hids dont supply a powertab so they arent fully functional USB drivers imho. And most of them are actually 1.1 USB thingies. Stuff like the X52 (nifty blue display ;) )needs proper power to function correctly.

Share this post


Link to post
Share on other sites

What if I don't have a tab in System for HID? My joystick checks out fine in Windows but isn't working in-game. Keymapper is still set up. I tried the unplugging routine, but that didn't help. I have a USB mouse, but it's plugged into the old mouse port with a converter do-hicky.

It was working AFTER 1.29, and since I moved and re-setup computer, it hasn't been working (in-game)

Share this post


Link to post
Share on other sites

OKay I have the HID tab (whoops!) First one says "HID-compliant game controller" and the other says "USB Human Interface Deivce" When I disable "USB HID" it ges a red X and the other vanishes.

And the joystick still doesn't work

My USB mouse is connected via a plug that converts it to the old-style round plug making the joystick the only USB thing plugged-in (same as it ever was)

HELP please

Share this post


Link to post
Share on other sites

I'm not sure if this is the same problem. I got a new computer with Vista Ultimate 64 bit a few weeks ago during 1.28, re-installed WWIIOL and everything worked fine - no glitches whatsoever.

The 1.29 patch messed up the joystick; not completely, as the joystick functions and keymap work fine for trucks and ATG's but not so for tanks. For tanks, the keymapped views, positions, etc. on the joystick are OK, but I can't steer (but can use js buttons 1 and 2 to shift gears up and down) from the driver position or operate the turret or gun in gunner postion. Same for commander, cannot use joystick to rotate but buttons work for views - the turret/gun/commander control has transferred to the mouse in tanks. Just to underline the difference - all the joystick functions for steering and gun/commander work fine in atgs and trucks where applicable but not in tanks.

I also noticed a significant drop in FPS.

Any ideas?

ATI Radeon HD 4870 X2 Catalyst Version 08.10

Vista Ultimate 64bit

Asus Rampage Formula Intel Core2 Duo E8500 8GB RAM

MS PP2 FFB joystick USB

Logitech G5 mouse

CHB throttle

Share this post


Link to post
Share on other sites

Reinstalled game....uh let's see, tried every USB port, nope. Mmmm...keymapper okay. Checks out in windows. Tried the HID crud. Nothing. Worked a week ago before I moved...same things plugged in.

Anyone? No?

Haven't gotten a single reply and I starting to get pissed off

Share this post


Link to post
Share on other sites

Klaus, what was the problem with your keymapping? I'm sure that is not my problem but it never hurts to check again.

Share this post


Link to post
Share on other sites

I'm having absolutely no luck. Disabled all HIDs aside from my joystick, rudder pedals, and mouse, and nothing. After each thing I disabled I loaded up the game, reread controllers, and still nothing.

I fail to see how this problem should still be in existence taking in to account just how many other programs are able to successfully detect the joystick et al.

Share this post


Link to post
Share on other sites

Hey All.. Everything Works on my mac.. But wanted to Try the game on my PC for possible latency Improvement.. But In-game CH Pedals / Joystick & Throttle not recognized .Computer Sees them fine,.... Tried disabling all those HID's one by one.& booting without a keyboard. but no Luck.... Running Current XP on a P4/3.6ghz With USB headphones & all 3 controllers through a D-Link USB Hub....

Any thoughts ? Me & a few pals considering getting UBER PC's to rock out on the game, but if we can't fly, not much point.... will stick to our macs that we suspect run the game a bit slower, but at least work....

No Solution in sight ?:confused:

Share this post


Link to post
Share on other sites
I'm not sure if this is the same problem. I got a new computer with Vista Ultimate 64 bit a few weeks ago during 1.28, re-installed WWIIOL and everything worked fine - no glitches whatsoever.

The 1.29 patch messed up the joystick; not completely, as the joystick functions and keymap work fine for trucks and ATG's but not so for tanks. For tanks, the keymapped views, positions, etc. on the joystick are OK, but I can't steer (but can use js buttons 1 and 2 to shift gears up and down) from the driver position or operate the turret or gun in gunner postion. Same for commander, cannot use joystick to rotate but buttons work for views - the turret/gun/commander control has transferred to the mouse in tanks. Just to underline the difference - all the joystick functions for steering and gun/commander work fine in atgs and trucks where applicable but not in tanks.

I have EXACTLY the same problem. Except I have XP. In addition the problem seems to be firing the guns in planes also.

What makes things work is, go to keymapper, open the tanks selection so you can see the key commands on right, then go back and spawn. No changes needed in keymapper, not even saving the settings. Strange.

Share this post


Link to post
Share on other sites

Having talked to people ingame, joystick issues seem to still be rearing their head. I have an Acer laptop with an AV8R saitek joystick. It worked fine, then stopped one fine day. It still works fine in Warbirds, and I have no problems in the diagnostics. But when I have the stick in the USB, BGE won't load. Just loads forever. Unless I touch something. Then it crashes.

I disabled a random driver, and it worked. Once. Next time, it didn't work. I reactivated and re-deactivated the driver. Nothing. Tried others. Nothing.

So... why does this game dislike joysticks? Is any of this being addressed in 1.30? I can't fly. I'm missing 1/3 of the game.

Share this post


Link to post
Share on other sites

I just bought an X52 pro and I'm having a problem with in game mapping of the joystick POV. When I try setting up my forward+right, forward+left, back+right and back+left views the game mapper is not recognizing my nw, ne, sw, se positions, it does recognize n, e, s, w. I have tried many different ways i.e. quick movement, slowly and precisely, holding it in position and letting go, and nothing seems to work. There is no problem with the hat as it is recognized in the Saitek calibration software. Has anyone else come across this issue with an X52, and is there a solution?

Shmonkey

Share this post


Link to post
Share on other sites

Since the most recent patch my macro facility on my X52 has stopped completely. I can associate any key with any button but now the macro does not work. I have emailed Saitek and they have offered as much assistance as they can but it is not a stick or driver problem.

The joystick and macro function works correctly out of game but will not work in wwiiol.

Guys can we get this fixed please?

Does anyone else have problems with the macro on the X52?

Share this post


Link to post
Share on other sites
Since the most recent patch my macro facility on my X52 has stopped completely. I can associate any key with any button but now the macro does not work. I have emailed Saitek and they have offered as much assistance as they can but it is not a stick or driver problem.

The joystick and macro function works correctly out of game but will not work in wwiiol.

Guys can we get this fixed please?

Does anyone else have problems with the macro on the X52?

well i dont have a x52 or anything like that but i have a x45 and my problem is, my y axis doesent work in game but i constantly calibrate it and it all works fine. but in game y axis just doesent want to work.

Share this post


Link to post
Share on other sites

Had this reply from the support guys regarding my Cyborg Evo joystick doing absolutely bog all in game...........................

Please open up your \Battleground Europe\ folder, then select each of the files below in turn, right click to bring up the Properties, go to the compatibility tab and Uncheck the box that says "Run in Compatibility Mode."

- C:\Program Files\CRS\Battleground Europe\ww2.exe

- C:\Program Files\CRS\Battleground Europe\ww2_x86.exe

- C:\Program Files\CRS\Battleground Europe\ww2_SSE2.exe

He says that has a good chance to fix the problem - not tried it yet though as I am at work, will do it when i get home.

Dem.

Share this post


Link to post
Share on other sites
Had this reply from the support guys regarding my Cyborg Evo joystick doing absolutely bog all in game...........................

Please open up your \Battleground Europe\ folder, then select each of the files below in turn, right click to bring up the Properties, go to the compatibility tab and Uncheck the box that says "Run in Compatibility Mode."

- C:\Program Files\CRS\Battleground Europe\ww2.exe

- C:\Program Files\CRS\Battleground Europe\ww2_x86.exe

- C:\Program Files\CRS\Battleground Europe\ww2_SSE2.exe

He says that has a good chance to fix the problem - not tried it yet though as I am at work, will do it when i get home.

Dem.

*******UPDATE*******

That didn't work - mainly because none of those boxes were ticked in the first place :/

Waiting to see where we go from here!

Dem.

Share this post


Link to post
Share on other sites

*****UPDATE*****

I have found a fix for my joystick not working in game using vista. You have to download the d3drm.dll file from HERE and paste it into the windows/system32 folder.

Apparently this fixes many peripheral issues with many makes of device.

I'm off to fly - hope it helps some of you guys.

Dem.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.