Sign in to follow this  
Followers 0
AHWULF

129 bugs

135 posts in this topic

129.01 read me : http://www.battlegroundeurope.com/index.php/component/content/article/10-production-notes/931-129-release-read-me

Note there could be NEW bugs in this version. Please report here and/or the testing forum.

Sound on Leopard has NOT been fixed. Yet. I need the live game for testing this as beta was too deserted. The client should still work on Tiger but I sure couldn't try it.

Clicking on the "reserve weapon" button the first time doesn't seem to work. You must select a vehicle by double-clicking the first time.

Client should be available once the game world is finished updating. You can use auto-update or checkout ftp://downloads.wwiionline.com/.

Note that the keymaps have been slightly changed, please see them in the readme and check them in the keymapper before reporting them as not working.

There may still be glitches in training (but you don't have to do it either) and map rendering for some folks. Both intel and ppc should be working as usually. My performance hasn't changed much from 128 on my dual G5.

Share this post


Link to post
Share on other sites

My full instal is total fubar. All the UI labels everywhere are missing, and the keyboard didn't work at all. Not sure if its just me though...

Just me apparently (I hope). I deleted all copies and reinstalled and all is fine now.

Share this post


Link to post
Share on other sites

Playing offline seems messed up. I ran the upgrade from 1287-1290 update patch and it seems like the game can't find the properties file that has the labels for everything. Then when I enter the game world, I can't move, the only key that works is enter to chat, so the only way out is to hit apple-q.

Playing online seems to work fine though.

Share this post


Link to post
Share on other sites

Got this silly bug today after playing without any problems 129 since its release. Its strange since I did not do any changes to the game. I've tried the reinstall trick but it does not work for me... :confused:

Share this post


Link to post
Share on other sites

It appears to happen randomly I got it once, restarted, then it was fine and hasn't happened since. I will check into it this weekend, maybe it will jump out at me.

Share this post


Link to post
Share on other sites

I have a strange bug. It seems when Im in cities or Towns im getting like 5fps all of a sudden when before the update I was averaging around 40fps in city battles.

Its making the game unplayable I hope CRS can do something to sort it out.

Share this post


Link to post
Share on other sites

The ?text? bug happens sporadically when I load the game

My avatar loses textures and lighting from time to time leaving just ambient colours. I can repeatedly do this offline by spawning into the AB - where my textures are fine, and then walking outside where they disappear.

Walls disappear on some buildings, most noticeably for me FBs

Mac OS X v10.5 Leopard

3.06GHz Intel Core 2 Duo

2GB memory

500GB hard drive1

8x double-layer SuperDrive

NVIDIA GeForce 8800 GS with 512MB memory

Share this post


Link to post
Share on other sites

Another one: on a C-47 as a paratrooper I only saw the first letter of the names of the other players on the plane

Share this post


Link to post
Share on other sites

1st 1.29 CTD - as a rifleman in busy Arras.

Process: World War ][ Online [433]

Path: /Applications/World War ][ Online.app/Contents/MacOS/World War ][ Online

Identifier: com.playnet.ww2ol

Version: 1.29.0 (release) (???)

Code Type: X86 (Native)

Parent Process: launchd [127]

Date/Time: 2008-11-30 14:29:44.999 +1100

OS Version: Mac OS X 10.5.5 (9F33)

Report Version: 6

Exception Type: EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x00000000b3b8a074

Crashed Thread: 0

Thread 0 Crashed:

0 com.playnet.ww2ol 0x0021bacc EFFECT::EFFECT() + 666

1 com.playnet.ww2ol 0x0021e0e9 void std::__unguarded_linear_insert<__gnu_cxx::__normal_iterator > >, Particle*, int (*)(Particle*, Particle*)>(__gnu_cxx::__normal_iterator > >, Particle*, int (*)(Particle*, Particle*)) + 43

2 com.playnet.ww2ol 0x0021e129 void std::__unguarded_insertion_sort<__gnu_cxx::__normal_iterator > >, int (*)(Particle*, Particle*)>(__gnu_cxx::__normal_iterator > >, __gnu_cxx::__normal_iterator > >, int (*)(Particle*, Particle*)) + 47

3 com.playnet.ww2ol 0x0021ee94 void std::__final_insertion_sort<__gnu_cxx::__normal_iterator > >, int (*)(Particle*, Particle*)>(__gnu_cxx::__normal_iterator > >, __gnu_cxx::__normal_iterator > >, int (*)(Particle*, Particle*)) + 80

4 com.playnet.ww2ol 0x0021ef23 void std::sort<__gnu_cxx::__normal_iterator > >, int (*)(Particle*, Particle*)>(__gnu_cxx::__normal_iterator > >, __gnu_cxx::__normal_iterator > >, int (*)(Particle*, Particle*)) + 113

5 com.playnet.ww2ol 0x0021cddc EFFECT::EFFECT() + 5546

6 com.playnet.ww2ol 0x002166bf std::map, std::allocator >, bool (*)(XMLLoader*, _xmlNode*, bool, void*), std::less, std::allocator > >, std::allocator, std::allocator > const, bool (*)(XMLLoader*, _xmlNode*, bool, void*)> > >::operator[](std::basic_string, std::allocator > const&) + 1621

7 com.playnet.ww2ol 0x00044c8f std::vector >::clear() + 6811

8 com.playnet.ww2ol 0x00043243 std::vector >::clear() + 79

9 com.playnet.ww2ol 0x0005879f tagMATERIALPROP::~tagMATERIALPROP() + 4847

10 com.playnet.ww2ol 0x00058e92 tagMATERIALPROP::~tagMATERIALPROP() + 6626

11 com.playnet.ww2ol 0x002625bc std::vector >::resize(unsigned long) + 38066

12 com.playnet.ww2ol 0x002626dc std::vector >::resize(unsigned long) + 38354

13 com.playnet.ww2ol 0x001ae82c std::vector >::push_back(void (* const&)(weapWeapon*)) + 732

14 com.playnet.ww2ol 0x0025b4fb std::vector >::resize(unsigned long) + 9201

15 com.apple.Foundation 0x96708267 __NSFireTimer + 279

16 com.apple.CoreFoundation 0x946aeb45 CFRunLoopRunSpecific + 4469

17 com.apple.CoreFoundation 0x946aecf8 CFRunLoopRunInMode + 88

18 com.apple.HIToolbox 0x927c9480 RunCurrentEventLoopInMode + 283

19 com.apple.HIToolbox 0x927c9299 ReceiveNextEventCommon + 374

20 com.apple.HIToolbox 0x927c910d BlockUntilNextEventMatchingListInMode + 106

21 com.apple.AppKit 0x91b743ed _DPSNextEvent + 657

22 com.apple.AppKit 0x91b73ca0 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128

23 com.apple.AppKit 0x91b6ccdb -[NSApplication run] + 795

24 com.apple.AppKit 0x91b39f14 NSApplicationMain + 574

25 com.playnet.ww2ol 0x00002b62 0x1000 + 7010

26 com.playnet.ww2ol 0x00002a89 0x1000 + 6793

Share this post


Link to post
Share on other sites
Another one: on a C-47 as a paratrooper I only saw the first letter of the names of the other players on the plane

The player list seems universally broken.

Share this post


Link to post
Share on other sites
1st 1.29 CTD - as a rifleman in busy Arras.

Process: World War ][ Online [433]

Path: /Applications/World War ][ Online.app/Contents/MacOS/World War ][ Online

Identifier: com.playnet.ww2ol

Version: 1.29.0 (release) (???)

Code Type: X86 (Native)

Parent Process: launchd [127]

Date/Time: 2008-11-30 14:29:44.999 +1100

OS Version: Mac OS X 10.5.5 (9F33)

Report Version: 6

Exception Type: EXC_BAD_ACCESS (SIGSEGV)

Exception Codes: KERN_INVALID_ADDRESS at 0x00000000b3b8a074

Crashed Thread: 0

Thread 0 Crashed:

0 com.playnet.ww2ol 0x0021bacc EFFECT::EFFECT() + 666

The "666" bug has already been entered into the bug list.

Share this post


Link to post
Share on other sites
Heres a screenshot of the building texture problem and the weapon texture.

Did you turn off normal maps? Did it fix it?

Share this post


Link to post
Share on other sites

Yer Im still getting massive lag in cities. Framerates right down to 2fps. Have turned graphics right down etc, doesnt make much difference.

Im running macbook/2gHz Intel core duo/2GB RAM/GMA 950 graphics/leopard

Im guessing this system is too slow now to run the game anymore?

Share this post


Link to post
Share on other sites
Yer Im still getting massive lag in cities. Framerates right down to 2fps. Have turned graphics right down etc, doesnt make much difference.

Im running macbook/2gHz Intel core duo/2GB RAM/GMA 950 graphics/leopard

Im guessing this system is too slow now to run the game anymore?

It's not the cpu, but the Intel graphics card is not supported by CRS, as it contains so many bugs for which there are no workarounds. That it worked at all in the past was mostly luck, with the updated Unity2 engine features they added in 129 obviously have made it worse.

My MacBookPro (1.67 Core) has an crummy ATI card but plays about the same as my Dual G5. The real frame rate benefits only come to the Core2Duo later models, ie just about everything current.

Share this post


Link to post
Share on other sites
It's not the cpu, but the Intel graphics card is not supported by CRS, as it contains so many bugs for which there are no workarounds. That it worked at all in the past was mostly luck, with the updated Unity2 engine features they added in 129 obviously have made it worse.

My MacBookPro (1.67 Core) has an crummy ATI card but plays about the same as my Dual G5. The real frame rate benefits only come to the Core2Duo later models, ie just about everything current.

Games way more simpler than WW2 online doesn't support Intel integrated stuff too. Just a note. In fact it broke my Mac Mini Intel plans (It has a GMA which doesn't even have hardware T/L)

Did Intel victims test the game on Windows? It (Windows) has better support for Intel GMA stuff (no promises).

Share this post


Link to post
Share on other sites

SO does this mean it is unfixable? I had to get a mac for school, and i got one this good just for this game, now i cant play it is SOO laggy should i just find a new game or what? I mean my MacBookPro 2 ghz cant get much newer. I love this game and seven or eight of my dorm mates were going to sub too, we all have macs though and since 1.29 I can't convince them, the online play is crap now does CRS have a plan or just gonna abandon mac users since we are a small piece. My monthly bill is due and if i cant get a straight answer I would rather not resub, which really sucks during the best time of the year for me to play..holidays. And i feel like i got suckered into this month with the switch happening.

It's not the cpu, but the Intel graphics card is not supported by CRS, as it contains so many bugs for which there are no workarounds. That it worked at all in the past was mostly luck, with the updated Unity2 engine features they added in 129 obviously have made it worse.

My MacBookPro (1.67 Core) has an crummy ATI card but plays about the same as my Dual G5. The real frame rate benefits only come to the Core2Duo later models, ie just about everything current.

Share this post


Link to post
Share on other sites

If it has an Intel GMA video card there is nothing anyone can do, the card is unsupported due to its buginess. If it has ATI or Nvidia video then post the model/ram/video card and we can figure out what's wrong.

Note that the beta worked for intel cpus for a long time with few reports of any performance issues. Most people aren't having any troubles but with any new version there will always be a few problems to shake out. There were a ton of code changes in this version (more than normal) so the chances of some people have major troubles while the majority have none is always going to be likely. Same is true of Windows version (they actually have more odd problems).

Although there is no dedicated mac programmer, KFS1 is handling most of the issues and I have access to the source code and have made a few fixes during beta.

My crummy G5 system hasn't seen much slowdown at all, although 10-13fps in town sucks I still play. Note that laptops are generally worse than desktops in general, but current iMacs on OSX get 100fps easy and have the same performance as the windows version. That's the same code everyone is running, its just the video+cpu+drivers+opengl are way better.

Have you tried running the windows version under bootcamp?

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.