Sign in to follow this  
Followers 0
c47

So I played wwiiol on a ramdisk

107 posts in this topic

i managed to get it to work by installing ww2 fresh on the ramdisk and updating it but when i launched it it just ctd as soon as i spawn and said virtiual memory to low? i have no page file selected do i need to install it fresh on ramdisk or just copy it over from c drive ? i went into registry and changed all playgate and playnet stuff from c: to F: which is my ramdisk but i think the path's are different i have no idea what im doing btw.

pc specs

amd64 3500+ venice

msi k8n diamond mobo

2 gig dual channel mushkin 2-3-2-6

msi 7800GTX

wd 74g 10000rpm hdd

How big is the ramdisk..., 750mb. or less the better.

How big is the game folder?

The idea is to keep a master copy on the C: drive and copy over to the disk.

Or, the deluxe ramdisk can copy an image of the game and auto-load it to disk at boot.

Keep the game folder lean. Keep old patches somewhere else or delete'em.

Also, the less backround apps running the better.

The game is leaking memory right now which could force a ctd after extended play.

Ratszo

Ratszo

Share this post


Link to post
Share on other sites

How do you defrag a ramdisk? When i open up diskeeper it shows it as severly fragged.

Share this post


Link to post
Share on other sites
O.k. I have it working but I keep running out of virtual memoy and game ctds every once in a whle after playing for some time. WW2ol is using wayyyyy too much memory now. It can go as far a 900 megs.

My system specs:

AMD 3700 64 (clocked at 2.869)

7900 gt

2 gigs OCZ Platinum 500

ww2wtf.JPG

P.S. Badas you have to make sure the icon to launch ww2ol on your desktop is pointing to the right place too. I had the same problem till I right clicked on it, checked properties and changed the location to it.

You have way too much stuff running in background. 33 processes are eating up all your Ram, no wonder you got problems. Im running with only 18 processes. Looks like you got Norton Antivirus (notorius for eating Ram). You might want to shut some things down.

Share this post


Link to post
Share on other sites
You have way too much stuff running in background. 33 processes are eating up all your Ram' date=' no wonder you got problems. Im running with only 18 processes. Looks like you got Norton Antivirus (notorius for eating Ram). You might want to shut some things down.[/quote']

Who cares how many processes (I dont have that many any more anyways its down to 22) I have running. WW2ol is eating up to 1 gig opf frikken ram. That's just silly.

Share this post


Link to post
Share on other sites

I finally found the time to try this myself.

Here is what i did:

I use RamDisk Plus from SuperSpeed (Evaluation version available on their website).

Setup:

- I installed RamDisk Plus and created a 650MB Ramdisk as drive R:

- I copied the folder "Battleground Europe" from within "C:\Program Files\CRS\"

(Make sure you move/delete all screenshots first to save space)

- I created the 2 text files containing the registry keys as described above

- I saved a copy of both and edited the path to point to "R:\\BATTLE~1\\"

- I copied all 4 .REG files to the root of the Ramdisk (R:)

- I saved the whole Ramdisk to my HD using the config tool that comes with it

- I created 2 batch files to quickly load/unload my RamDisk when needed (you can have windows load the ramdisk automatically during boot - as i also do other things with my computer besides WWIIOL i don't want a third of my RAM to be occupied all the time by an idle Ramdisk though...)

The batch files are:

Ramdisk init.cmd

@echo off <- cosmetics

rdcfg -load C:\SsRd0001.cif -dl R: <- loads the saved image of my ramdisk as drive R:

R: <- change to the Ramdisk

regedit /S RAM1.reg <- Paste modified keys to the registry without asking silly questions

regedit /S RAM2.reg <- Paste modified keys to the registry without asking silly questions

Ramdisk remove.cmd

@echo off <- cosmetics

R: <- change to the Ramdisk

regedit /S 1.reg <- Paste original keys to the registry without asking silly questions

regedit /S 2.reg <- Paste original keys to the registry without asking silly questions

C: <- change to drive C: (HD)

rdcfg -rem -q R: <- remove the ramdisk from RAM

Play:

All i have to do now is launch "Ramdisk init.cmd" (takes 5 seconds) and i can play from ramdisk. All the original game links are working as Playgate stays were it was (on C: ) and WWIIOL is launched from the ramdisk via the changed paths in the registry.

Cleaning up:

When i am done playing i just launch "Ramdisk remove.cmd" and my RAM is free again...

Important: When using the "rdcfg -rem" command to remove the ramdisk as in my batch file you have to make sure you set the ramdisk image file to write protected first - otherwise the image is removed as well as the command tries to delete the file!!!

DISCLAIMER: When fiddling with the registry exercise caution and make sure you have appropriate backups - especially when copying info into the registry without warning or confirmation dialogues like in the batch file!!!

Notes:

- Patches are easily applied: I launch the game from the ramdisk and patch it. Before removing the ramdisk i just need to save it again and remember to set it to write protected again!

- If the patch is too big to fit on the ramdisk you can easily patch the HD version and copy the game folder over to the ramdisk again and save it.

- Remember to turn off all page files as stated before - if you don't you won't gain anything from the excercise.

Results:

If you have a fairly decent system (especially a fast HD subsystem) you won't notice that much of a difference in load times - especially the initial loading of the game is not much faster for me.

Spawn time is reduced (sometimes significantly).

What makes it worth though is that it removes the occassional stutter i experienced ingame before - that is what makes it HIGHLY RECOMENDED for me!

It is a smooth ride now without any hickups and that is definitly worth the (small) hassle.

Hope this helps anyone out there - feel free to ask if help is needed or my germenglish looks like gibberish to you ;-)

Vader666

Share this post


Link to post
Share on other sites
How do you defrag a ramdisk? When i open up diskeeper it shows it as severly fragged.

A fragged RAMDISK shouldn't really perform worse than an non-fragged one - in theory.

The problem with a fragged hard-drive is that the heads have to physically move to the different fragments, which takes time, but this doesn't happen with electronic memory.

I assume ramdisks emulate an IDE device? If so, the 100/133 MB/s limit of that bus should give the memory controller ample time to get fragmented memory.

I could be wrong though...

PS: I would assume you defrag it using the same methods as any other disk...

EDIT: If I had a big enough RAMDISK, I would partition it into 2 disks. On one, I would but my swap file, on the other, I would put WWIIOL.

Share this post


Link to post
Share on other sites
Who cares how many processes (I dont have that many any more anyways its down to 22) I have running. WW2ol is eating up to 1 gig opf frikken ram. That's just silly.

Guess you believe Biil Gates when he said:

“640K ought to be enough for anybody.”

Share this post


Link to post
Share on other sites
Guess you believe Biil Gates when he said:

“640K ought to be enough for anybody.”

Do you ever think when you post?

Share this post


Link to post
Share on other sites

Lots of games use a gb of ram, normally windows keeps a lot of it swapped out to your page file. If you disable the swap files it'll be close to a GB in memory.

That's just how much memory all the terrain, bushes, trees, 80+ 3d models for vehicles (one for each instance you can see too) and all their textures and sounds takes up.

O.k. I have it working but I keep running out of virtual memoy and game ctds every once in a whle after playing for some time. WW2ol is using wayyyyy too much memory now. It can go as far a 900 megs.

My system specs:

AMD 3700 64 (clocked at 2.869)

7900 gt

2 gigs OCZ Platinum 500

ww2wtf.JPG

P.S. Badas you have to make sure the icon to launch ww2ol on your desktop is pointing to the right place too. I had the same problem till I right clicked on it, checked properties and changed the location to it.

Share this post


Link to post
Share on other sites

Stutters in 1.24 are not related to harddrive access. The Ramdisk eliminates stutters related to harddrive access. This is easy to see on your system as your harddrive light flashes every time the game stutters. In 1.24.0 (and only 1.24.0) stutters are being caused by something else.

Share this post


Link to post
Share on other sites
Stutters in 1.24 are not related to harddrive access. The Ramdisk eliminates stutters related to harddrive access. This is easy to see on your system as your harddrive light flashes every time the game stutters. In 1.24.0 (and only 1.24.0) stutters are being caused by something else.

Yeah, seems like server instability..., after-patch jumpyness.

HD isn't accessing, cpu isn't spiking.

Not too bad overall..., but i'm grounded 'cause of fog.

Ratszo

Share this post


Link to post
Share on other sites

It's not server related. It happens in offline mode, too. I've done a lot of testing, provided a lot of specifics, and hopefully it's enough for them to have a fix by Friday.

Share this post


Link to post
Share on other sites
It's not server related. It happens in offline mode' date=' too. I've done a lot of testing, provided a lot of specifics, and hopefully it's enough for them to have a fix by Friday.[/quote']

Offline? Not for me, just went back in to recheck..., steady, smooth as silk flying.

I should note that i'm not getting bad performance on the live server either, just a pause here and there, not often.

Ratszo

Share this post


Link to post
Share on other sites

Oh, one caveat. It happens over cities/towns. It won't happen over the training grounds. Select your unit, go to the theater tab and select a spawnable location (not a depot) at Antwerp or other big city. Test there and you'll see. It happens less at smaller towns.

Share this post


Link to post
Share on other sites
Oh' date=' one caveat. It happens over cities/towns. It won't happen over the training grounds. Select your unit, go to the theater tab and select a spawnable location (not a depot) at Antwerp or other big city. Test there and you'll see. It happens less at smaller towns.[/quote']

Ahh, yeah, it is skipping in offline mode on the main map.

No hd accessing tho.

Ratszo

Share this post


Link to post
Share on other sites

I posted this on another threadaa but think it probably bere here too:

Here is the latest from my end: After trying every recommended or suggested fix including, but not limited to, the SS2.exe, PRF off, latest ATI drivers, defrag with DISKEEPER ($49), registry cleaner with AMUST($39 I think), Spyware cleaning by EWIDO (more$), new DDR500 (4GIGsCorsair 4000PT-dont dare let the little woman know what this cost),etc,etc, ......I THEN downloaded RAMDISK from Super Speed Software and installed the game on it. Tried it today with dismal results. I even disabled the game on C: drive to make sure the RamDisk was operating....it was.

What have ALL these efforts amounted to you ask? NOT A BLOODY BIT OF IMPROVEMENT. In 1.23 without all those goodies my framerates were a reliable 40-75 everywhere.

Now they are 65 or so when I am ALONE in the sky and drop into the range of 2-16 with even a small crowd (yes, that is TWO-16fps).

Flying is completely out for me. I could neither drop my bombs or fire mg/cannon the framerate and stutters were so bad today.

ASUS P4P800E-Deluxe

P4-3.0GHz

4 Gigs DDR500 Corsair gaming ram

ATI X850XT with 256 megs memory

Multisync LCD 18" monitor

If this PC wont do it then what will? Lots of faster machines out there but......

Reply With Quote

Share this post


Link to post
Share on other sites

Casey, did you try a fresh install? I haven't 'cause i'm on dialup.

Ramdisk isn't fixing this problem, but it's still a great way to fly.

With 4gig ram you got the room for it.

Ratszo

Share this post


Link to post
Share on other sites
I've got 1 gig of ram in 2 slots now. I have 1 empty slot. If I get 512mb more will ram disk work right in that configuration?

Bump...,

You need atleast 2gig ram.

Ratszo

Share this post


Link to post
Share on other sites

I tried a ram disk ( 768M ) on 2 Gbs of ram. After about 6-7 spawns I would ctd from running out of memory. ( page file disbabled ).

Although My current performance is identical whether I'm on a ram disk, or running off a HD.

Share this post


Link to post
Share on other sites

I have a problem with the latest patch and RAM disk with regard to the Playgate APP.

I launch Playgate and it does not detect the latest patch. It goes to the Patch update screen and tries to dl the update etc.

However, when I launch the playgate using my regular c: drive install, it works fine.

Anyone else see this?

Thanks.

Share this post


Link to post
Share on other sites

You may have checked your Ramdisk files as "READ ONLY". I did because I want to make any changes to it AFTER getting everything on my "C" drive.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.