• Announcements

    • SNIPER62

      64-bit is LIVE   03/27/2020

      CHIMM: 64-bit client is now LIVE and Campaign 172 continues!  
Sign in to follow this  
Followers 0
rarekind

Game Wont Launch

36 posts in this topic

After not playing the game for a long while, I decided to delve in again. I had an old version of the game installed, which I patched up and tried to play. The screen went blue for the resolution adjustment, and then just quit.

I then deleted the game and reinstalled it from a fresh download, and the same problem.

I am an absolute novice when using Mac's, does anybody know what could be causing this? Ive tried all available resolution to no avail, as I at first assumed it was a display issue.

Share this post


Link to post
Share on other sites

Its not actually mine, Im back home at my parents for Christmas so it is my mothers.. So I dont know its model name.

However, its one of the newer iMac's and according to System Profiler its an Intel Core 2 Duo 2.4Ghz with 1 GB of RAM, which it says is a Model 7.1.

I have had WW2OL working on here before just to try it out about a year ago with no issues.

Share this post


Link to post
Share on other sites

Huh.... I don't know much about the newer intel macs because the only intel mac I own is a laptop that can't run this game because of lower specs.

Anyway you should probably download the full installation here. http://www.battlegroundeurope.com/index.php/getting-started/download-the-game

instead of loading it off your CD or using the older version.

Also it could help if you could give me a little bit more background information like, does a crash report pop up after it backs out? Also does the problem happen everytime you load the game? (Like you've tried 2 or 3 times on the same download)

Anyway, I'll try and help you out hopefully we can get this solved

Share this post


Link to post
Share on other sites

Thanks for your reply.

I have tried the downloaded version only, and have tried re downloading it three times and reinstalling with no joy. However, I think this might partially be due to me not actually uninstalling the game correctly - As when I load up the game again after the re installation, it still has my username and password saved. To uninstall it I am simply dragging the application icon from my Applications folder to the trash, and then emptying it - Is that correct?

No error pops up on either install or launch. The application simply doesnt launch, upon clicking Play Online/Offline/Training, the screen resizes itself to the appropriate resolution and then tries to launch the game, then just quits back to desktop without ever seeing a loading bar, splash screen, error or anything at all. It happens every time I load the game, I have not got it successfully to load once. However, on my first try I did get the Battleground Europe splash screen with the loading bar before it quit back to desktop, but not since.

Share this post


Link to post
Share on other sites

Have you tried changing the resolution size to the one you have currently. I believe if you have it set at it's maximum. (Don't really remember what the highest is currently) The Game won't function. Try matching your resolution screen setting in your preferences. See if that works.

Also if that doesn't work, you need to download a application called appzapper. What the appzapper does locates all of the files inside you mac HD, which should give you clean slate when you reinstall it.

But right now try the first one.

Share this post


Link to post
Share on other sites

I'm having the same problem as rarekind, only on a macbook pro. Leopard 10.5.

viruses, I have tried both of your recommendations, sadly neither worked for me.

Share this post


Link to post
Share on other sites

I have already tried all the resolutions, including the native 1680x1050 that the OS itself is running at. I will try AppZapper shortly when I have a moment.

Share this post


Link to post
Share on other sites

My son has a 24" imac that is about a year old and it runs fine.

The only thing that I can suggest is

1) save/move the prefs folder located in ~/Library/Preferences/ww2ol to some place safe like ~/Documents

2) delete the remnants of the non-working version,

3) redownload and do a clean install

4) if everything ok, restore the cfml files from the old preferences folder.

Good luck and remember it should work. :)

s!

Share this post


Link to post
Share on other sites

OK, 1.29.3 Mac version doesn't load on my 10.5.6 PPC system. Whatever I choose, no matter how many reloads, it crashes to desktop right after launching and changing screen resolutions (when I have it set to another resolution other than the desktop size), or even when set to desktop resolution. I seem to remember 1.28.x I had to leave it at 32-bit color or it crashed outright just like this, but 32 or 16 bit doesn't make a difference this time.

Here's what the console logged for 32-bit color:

12/26/08 8:59:09 PM mdworker[7718] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary.

12/26/08 8:59:16 PM [0x0-0x490490].com.playnet.ww2ol[7729] WW2OL Started

12/26/08 8:59:16 PM [0x0-0x490490].com.playnet.ww2ol[7729] Exited Program: file: /playnet/builds/ww2src/branches/1.29.0.255/src/ui/uiMain.cpp, line: 238, App Version: 1, 29, 3, 255

12/26/08 8:59:16 PM [0x0-0x490490].com.playnet.ww2ol[7729] Message string: default font not found!

And for 16-bit color:

12/26/08 8:58:06 PM World War ][ Online[7726] invalid drawable

12/26/08 8:58:05 PM [0x0-0x48e48e].com.playnet.ww2ol[7726] WW2OL Started

12/26/08 8:58:06 PM [0x0-0x48e48e].com.playnet.ww2ol[7726] Exited Program: file: /playnet/builds/ww2src/branches/1.29.0.255/src/ui/uiMain.cpp, line: 238, App Version: 1, 29, 3, 255

12/26/08 8:58:06 PM [0x0-0x48e48e].com.playnet.ww2ol[7726] Message string: default font not found!

I am not sure why a metadata worker thread is finding something wrong for the 32-bit launch and not for the 16-bit, but it pops up every time I launch WWIIOL into a 32-bit color game.

As to the default font, I went digging into the plists for 1.29.3, which CRS has disguised in binary form... clever little devils. Anyhow, there is only one place that even mentioned a font, and that was 'LucidaGrande'. I have Lucida Grande on my 10.5.6 load. It did not say anything in the plist file about it being a 'default font'.

The string 'default font not found!' shows up in the WWIIOL binary, along with one other font, 'verdana'. I also have the Verdana font on my system, but one thing that puzzles me is that in the binary it was listed with a path that had back slashes (like '\app\font\verdana'), like a Windows path. Could it be that someone used the wrong include in one of the headers? Hmmm? Cross-compiling without caffine? Or is it the directory listed above wrong - the 1.29.0 build dir for a 1.29.3 release? Someone forget to update their build environment?

1.28.x worked on my system 6 months ago, but that was when I had 10.5.4. Has something changed in 10.5.6?

Will I ever get back into my beloved game?

Share this post


Link to post
Share on other sites
OK, 1.29.3 Mac version doesn't load on my 10.5.6 PPC system. Whatever I choose, no matter how many reloads, it crashes to desktop right after launching and changing screen resolutions (when I have it set to another resolution other than the desktop size), or even when set to desktop resolution. I seem to remember 1.28.x I had to leave it at 32-bit color or it crashed outright just like this, but 32 or 16 bit doesn't make a difference this time.

Here's what the console logged for 32-bit color:

12/26/08 8:59:09 PM mdworker[7718] CFPropertyListCreateFromXMLData(): Old-style plist parser: missing semicolon in dictionary.

12/26/08 8:59:16 PM [0x0-0x490490].com.playnet.ww2ol[7729] WW2OL Started

12/26/08 8:59:16 PM [0x0-0x490490].com.playnet.ww2ol[7729] Exited Program: file: /playnet/builds/ww2src/branches/1.29.0.255/src/ui/uiMain.cpp, line: 238, App Version: 1, 29, 3, 255

12/26/08 8:59:16 PM [0x0-0x490490].com.playnet.ww2ol[7729] Message string: default font not found!

And for 16-bit color:

12/26/08 8:58:06 PM World War ][ Online[7726] invalid drawable

12/26/08 8:58:05 PM [0x0-0x48e48e].com.playnet.ww2ol[7726] WW2OL Started

12/26/08 8:58:06 PM [0x0-0x48e48e].com.playnet.ww2ol[7726] Exited Program: file: /playnet/builds/ww2src/branches/1.29.0.255/src/ui/uiMain.cpp, line: 238, App Version: 1, 29, 3, 255

12/26/08 8:58:06 PM [0x0-0x48e48e].com.playnet.ww2ol[7726] Message string: default font not found!

I am not sure why a metadata worker thread is finding something wrong for the 32-bit launch and not for the 16-bit, but it pops up every time I launch WWIIOL into a 32-bit color game.

As to the default font, I went digging into the plists for 1.29.3, which CRS has disguised in binary form... clever little devils. Anyhow, there is only one place that even mentioned a font, and that was 'LucidaGrande'. I have Lucida Grande on my 10.5.6 load. It did not say anything in the plist file about it being a 'default font'.

The string 'default font not found!' shows up in the WWIIOL binary, along with one other font, 'verdana'. I also have the Verdana font on my system, but one thing that puzzles me is that in the binary it was listed with a path that had back slashes (like '\app\font\verdana'), like a Windows path. Could it be that someone used the wrong include in one of the headers? Hmmm? Cross-compiling without caffine? Or is it the directory listed above wrong - the 1.29.0 build dir for a 1.29.3 release? Someone forget to update their build environment?

1.28.x worked on my system 6 months ago, but that was when I had 10.5.4. Has something changed in 10.5.6?

Will I ever get back into my beloved game?

I'm glad someone knows what's going on! Hopefully they see your post sooner or later, this is a big bummer.

Share this post


Link to post
Share on other sites

im having the same problem...i was having CTD issues with new patch so i reinstalled the game...now the game wont launch...CRS please help us out here...the ongoing problems with this new patch are a real issue, sooo many mac players havent been able to play the game for long periods of time because of serious bugs...i truely love this game and dont want to go back to playstation or play WoW....please dont go make me be an elf, i dont like elves

Share this post


Link to post
Share on other sites

Hmm, I'm using the game on a 2x2 G5/10.5.6. I haven't played, I don't think, since new patch but the game does run. When I get a chance I'll see what happens when I do a full reinstall. Sounds like they may have posted a bad build.

With the holidays you may have to be a little patient with the Rats and rat helpers, I've heard that they have families too.

s!

Share this post


Link to post
Share on other sites

Ok, I just downloaded and tried to install the 1.29.3 full install and can confirm that it is FUBAR, at least on PPC.

There is good news though. I backed up one step and downloaded the 1.29.2 full install and started from there, went through patching process to 1.29.3 and it ran. Woohoo!

Give it a try. It worked for me.

s!

Share this post


Link to post
Share on other sites
Ok, I just downloaded and tried to install the 1.29.3 full install and can confirm that it is FUBAR, at least on PPC.

There is good news though. I backed up one step and downloaded the 1.29.2 full install and started from there, went through patching process to 1.29.3 and it ran. Woohoo!

Give it a try. It worked for me.

s!

YAYYYYY this works! Everyone just download that patch linked above in dog3's post, and then start the game. It will update itself and it WILL work!

dog3 for president! s!

Share this post


Link to post
Share on other sites
Ok, I just downloaded and tried to install the 1.29.3 full install and can confirm that it is FUBAR, at least on PPC.

There is good news though. I backed up one step and downloaded the 1.29.2 full install and started from there, went through patching process to 1.29.3 and it ran. Woohoo!

Give it a try. It worked for me.

s!

Thanks, Dog. Looks like it worked for marcinek, so I'll give that a try. To tell the truth I was a bit focused on getting 1.29.3 full working last night and forgot this trick. Ah, the memories.

Bigstig, don't give up my good man. I have been playing this game (off and on...) since early 2002. Whenever you see a game that integrates Mac and PC users into the same battlefield, at the same time (unlike almost every other MMORPG that segregate Mac and PC users to separate servers), you get hiccups. When I had money to burn I was in this game every day, testing things to make sure they worked, providing reports back to CRS (when they would listen - busy guys those Rats...;)). Anyhow, I feel that if they are making the effort to provide a dual-platform binary, and now a triple-platform with PPC & Intel Mac Universal binaries, then I give them a pass.

Usually.

Right ahwulf? :)

Share this post


Link to post
Share on other sites

Have the same problem, was about to make my own thread on it... Giving the aforementioned fix a go. I'll report on it in a few.

Share this post


Link to post
Share on other sites

Ok I've attempted to install the 1.29.2 version but I need to uninstall the 1.29.3 version first.

I've deleted the Application from the "Applications" folder, ran the "defaults delete com.playnet.ww2ol" command but I still cannot install the 1.29.2 version. Are there any other commands I need to run ?

I'm still hanging in there ! I'm used to response times of months when it comes to mac related issues so thanks for the quick replies.

Share this post


Link to post
Share on other sites

Bigstig,

1) You don't need to run "defaults". You should not need to run anything from the terminal. Remember this is a Mac so it "just works." :) You shouldn't have to delete the old app but sometimes paranoia rules.

2) When you run the installer, it should ask you for permission.

Do you have "admin" privileges on your machine? I have heard of install problems if you don't admin access.

If you do NOT have "admin" access, then try installing in a new folder in your home directory/folder. Make a new folder "Playnet", for example, and when the installer asks which on which disk to install the app, select your new folder. Hit the "install" button again and it SHOULD install. Launch the app in your "Playnet" folder and you SHOULD be good to go.

Good luck. Hang in there. Folks around here will try help.

s!

Share this post


Link to post
Share on other sites

thanks dog3, sorry I should have mentioned the error message I am getting.

I get the following message when I'm at the Select a destination stage installing version 1.29.2

"You cannot install World War ][ Online on this volume. A newer version of this software already exists on this volume."

Restarted the computer, done a search for all file containing ww2 and wwii but apart from the install dmg's I can't find anything remaining.

Share this post


Link to post
Share on other sites

Ok, I have never seen this particular message, myself, while installing but I have heard rumors of the installer being a little wonky at times so we will try and figure this out.

1) The installed application is called 'World War ][ Online' so that's the file name that you should be searching for.

2) Out of curiosity, have you tried creating a folder in your home folder and installing the app there? If you are able to create a new folder then you should be able to install the app in the same folder.

I've got family things going on so there might be some delay if you post again but I will check on this thread from time to time. Post how you are progressing and other folks may have suggestions or have seen this particular problem before.

Good luck.

S!

Share this post


Link to post
Share on other sites

Sorry guys I have been out of the country and out of touch so couldn't help (just got home this evening). We will figure out what happened (its the stupid Apple installer going bonkers). TO reinstall an older version, go to [Main Drive]/Library/Receipts and delete the appropriate .pkg file. I THINK this will allow it. This is how the installer knows what's already been done.

Always install the game with admin privs (the default) and in the main App folder to avoid the installer's other insanities.

Hopefully we can figure the core issue. Clearly the installer builder script didn't do the right thing.

Share this post


Link to post
Share on other sites

Welcome back, ahwulf. I should have mentioned I got it working with a downgrade to 1.29.2 full install and following the update path. I did not have the issue that bigstig is having - but just like ahwulf says it may be a problem with the package receipts. I simply dragged the .app file to the trash - EMPTIED IT - and then reinstalled. It even let me keep my old prefs and cfml files from the 1.28.x version (last I played 6 months ago), so there were no problems with old prefs files lying around.

bigstig, I'm just checking basic Mac troubleshooting here, but you did empty the trash after deleting the .app file, right? The installer might be seeing it still there...

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.