Sign in to follow this  
Followers 0
leparc

ATi Catalyst Driver Problems...This Needs a sticky

298 posts in this topic

i still crash every 15-20 minuts..iv about given up..iv been playing this game on and off for 8 years..only reason it says 2007 was that this was a 2 account..iv played this game on so many video cards never had a problem till now..funny i poped in my old gtx 260 and it out preformed my hd 5870 by a very large margine

Share this post


Link to post
Share on other sites

I tried 10.1 last week, and get every 15-20 minutes CTD, not CTHL (friends telling it must be internet connection, but i think 'i' can differ between ctd's and cthl's ;)). After reinstalling 9.12 its again working fine. So i am a bit carefull with now new driver versions for my ATI 4870, its not 5xxx series; especially if 9.12 is still working fine.

Share this post


Link to post
Share on other sites
Catalyst 10.2 is out.

All Ati are doing is firefighting. Its a complete joke. I am seriously thinking about going back to nvidia for my next card.

Share this post


Link to post
Share on other sites

After doing a search on the internet in various forums, it's seems there are a couple of related issues. A certain percentage of people are having problems with the grey lines and crashing, while others have weird flickering in 2D (especially with dual screens or more).

One explanation seems to be that the DDR5 RAM in these cards are having issues with state changing (when stepping from one voltage to another), hence adjusting the memory clock or RMA-ing for new cards with a different batch of RAM fixes the issues.

Second one that makes sense for some of the issues, is that the card can't compensate for the timing for a second monitor properly. Locking the memory clock at a fixed frequency fixes the issue.

I was having some odd screen flicker on my second monitor whenever I allowed the card to step down its speed with ATI Overdrive. So I fixed it by keeping the minimum memory clock at the stock speed. No flicker, works great.

Share this post


Link to post
Share on other sites

In a rage formatted the whole comp, installed this lattest fix and i played for a few hours last night, without problems.

Carefully happy :)

Share this post


Link to post
Share on other sites

Still good, only the normal CTD once in a while. No more posts in this topic so i assume that the problem is solved?

Share this post


Link to post
Share on other sites
Still good' date=' only the normal CTD once in a while. No more posts in this topic so i assume that the problem is solved?[/quote']

No.

1.31 doesn't display Speedtrees for me. The current build is supposed to have fixed this, but it hasn't for me.

Vista Home Premium, SP1

AMD Trion 64 X 2 TL60 2.00 GHz

4.0 GB RAM

ATI Radeon X1270

I tried to install the new 10.1 drivers, but they aren't installing. The install process seems to work, but this is what Catalyst (ver. 2009.0721.1107.18080, copyright 2002-2009) Information Center > Graphics Software is showing:

Driver Packaging Version 8.47-080219a-060346C-Gateway

Catalyst™ Version 09.3

Provider ATI Technologies Inc.

2D Driver Version 7.01.01.747

2D Driver File Path /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0000

Direct3D Version 7.14.10.0567

OpenGL Version 6.14.10.7410

Catalyst™ Control Center Version 2009.0721.1107.18080

It occurs to me that maybe the problem might be associated with the fact that I only have NetFramework 2.0. For some reason, 3.5 won't install on my machine either. Anybody have any suggestions?

------

Oh, wait, now I see this earlier in this thread:

That's because ATI forgot to update the version number that is displayed on the driver printout from the CCC - according to Catalyst forums and twitter feed' date=' that is a mistake on their part and you do indeed have the 10.1 Cats installed.[/quote']

So does this mean my drivers are really up-to-date?

Edited by blulight

Share this post


Link to post
Share on other sites

]ATI Radeon X1270

This might be your problem.

Didn't I read somewhere about new hardware requirements with 1.31? I know the x800-series and below lack SM3.0 but what if the same is with this mobile gfx your using does to, then that is probably the reason so it isn't the driver and it isn't the game, it's just to old hardware.

Share this post


Link to post
Share on other sites
This might be your problem.

Didn't I read somewhere about new hardware requirements with 1.31? I know the x800-series and below lack SM3.0 but what if the same is with this mobile gfx your using does to, then that is probably the reason so it isn't the driver and it isn't the game, it's just to old hardware.

I finally figured out how to load the new drivers. Turns out I should have removed the old ones first. Getting speedtrees now.

Share this post


Link to post
Share on other sites

Just a quick update. I have played for weeks without a ctd or gamecrash.

I havent got ATI Catalyst installed anymore and i dont use that FPS (NumLock) box anymore.

The driver version i have installed is 8.700.0.0 (dont know with wich catalyst version that corresponds).

Im glad i can play the game with no worrys, even running two accounts on one machine is no problem. It looks like, Catalyst was the problem for me.

Share this post


Link to post
Share on other sites
10.2 drivers appear to have fixed the problem for me in ver 1.30

Have you tried it on Beta?

Share this post


Link to post
Share on other sites

Could anyone tell me why I should install Catalyst on my machine? The game works just fine forme without it. (<10.1). So what does catalyst do exactly?

Share this post


Link to post
Share on other sites
Could anyone tell me why I should install Catalyst on my machine? The game works just fine forme without it. (<10.1). So what does catalyst do exactly?

If you're not doing anything other than gaming and web browsing then I guess you won't need CCC. You can use other tools to finetune settings if you want to. However, it's a simple interface to change 3D settings, handle multiple displays and controlling fan speed, core and memory frequencies and so on.

But I'd still recommend that you update the driver. You can download only the driver if you want to and don't feel the need to use CCC.

Share this post


Link to post
Share on other sites
If you're not doing anything other than gaming and web browsing then I guess you won't need CCC. You can use other tools to finetune settings if you want to. However, it's a simple interface to change 3D settings, handle multiple displays and controlling fan speed, core and memory frequencies and so on.

But I'd still recommend that you update the driver. You can download only the driver if you want to and don't feel the need to use CCC.

Thanks for the reply. I have the latest driver from ati, but just not the catalystcc. If that one is installed (till 10.1) it messes the game up, even with bad 3d settings. The way i have it now, i have good quality ingame grafs and no crashes at all. Anyways ive got my eye on a GTX480 from Nvidia, soon to be purchased :)

Share this post


Link to post
Share on other sites

There's even a leaked 10.5 out....

Also, I posted a thread with a link to an updated OpenGL driver for ATI cards that I found to improve performance a bit.

Share this post


Link to post
Share on other sites
got my eye on a GTX480 from Nvidia' date=' soon to be purchased :)[/quote']

opening up a breakfast grille soon i see?

cook me up two sticks of bacon and a side of eggs please.

you'll sh@# your pants when you read

"please let run for a minimum of 2 minutes for cooling before system shut down, graphics card removal"

on the back of the packaging when you get that card.

I'd still buy one... hahahaha

Share this post


Link to post
Share on other sites

My display driver keeps crashing on me while in game. This is the only game it does it on. I'm running ati hd5850.

Its the only game it happens on and I run stuff maxed out just fine in other games. Running the latest ATI driver as well. Any ideas?

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.