Sign in to follow this  
Followers 0
leparc

ATi Catalyst Driver Problems...This Needs a sticky

298 posts in this topic

Think I'm getting ATi problems as well. I've got a 9550/X1050 series with the 9.3 drivers. I've switched off anti-aliasing and almost everything else I can but still no luck.

I can pratice offline which is odd. When loading the full game it loads fully but then CTDs to a black screen and then back to desktop just before the persona page. Any ideas what more I can try?

Thanks

Share this post


Link to post
Share on other sites
Think I'm getting ATi problems as well. I've got a 9550/X1050 series with the 9.3 drivers. I've switched off anti-aliasing and almost everything else I can but still no luck.

I can pratice offline which is odd. When loading the full game it loads fully but then CTDs to a black screen and then back to desktop just before the persona page. Any ideas what more I can try?

Thanks

Open up your ati catalyst control center and click on the "defaults" tab to take everything back to where it started. Worked for me.

Share this post


Link to post
Share on other sites

The 9.4 drivers on a 4000 series card work fine for us (and by "us" I mean "martini"). He did get a crash with 9.5, but fixed that. There might be a different crash going on with the 9.5 drivers.

Share this post


Link to post
Share on other sites

Tried setting everything to default and still did not work.

Tried upgrading my drivers to 9.5 but got the error message "setup did not find a driver compatible with your current hardware or operating system. I think my card is maybe too old to accept 9.5 so 9.3 is the newest I can get.

Playnet suggests that you roll back to the 8.1 drivers, I have tried this and again no joy :confused:

Will there be a patch soon to solve these ATi issues or is it unsub time till I can afford a better computer?

Edit: Also I was wondering why it works when i practice offline but doesn't work online. Doesn't this suggest that its not a graphics issue??

Share this post


Link to post
Share on other sites

We'll have to be able to replicate the problem before we can find a solution.

The 9500 line of ATIs are getting long in the tooth, ATI is now calling it "Legacy" which is a nice way of saying they don't actively support it anymore.

Share this post


Link to post
Share on other sites

So why does the game work offline but not online? Surely graphincs wise it can't be much different?

Share this post


Link to post
Share on other sites

I use the 9.1 drivers i have a 9550 .I have all the crap turned off though i get low fps it still works fine. Im not game to use the 9.4 yet!

Share this post


Link to post
Share on other sites
I use the 9.1 drivers i have a 9550 .I have all the crap turned off though i get low fps it still works fine. Im not game to use the 9.4 yet!

Thanks, I'll try the 9.1 drivers.

Tried the 9.1 drivers and still no luck :(

Share this post


Link to post
Share on other sites

When i was playing on trial in march i had to roll back to 8.4 drivers and this fixed it for me.

When i did that today(new account/subscription) it showed my mouse but no gamescreen.

Installed 8.12 and its not working.

Ati Radeon 9600.

Edit: It just jumps back to desktop without an error, when i was using latest drivers it did error.

Share this post


Link to post
Share on other sites
Are you sure you're getting the ATI Drivers for the old cards?

Heard there's a set for old cards and another for 29xx series and up.

http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx?type=2.4.1&product=2.4.1.3.25〈=English

That's the latest drivers for old ATI cards,hope it helps a lot of people. :)

Ill try that now, see if it works.

8.11 drivers also cause a CTD without any errors

Edit: Installed legacy drivers, error popping up

"The game was unable to initialize the video display: [unknown error].

Please check your video card configuration and try again.

Thats the same error as when i was using the latest(9.4) drivers.

Share this post


Link to post
Share on other sites

I've tried every driver I can get my hands on, even omega drivers etc.. and still no luck.

Seems lots of people can play offline but not online, must be something specific to the online game that is causing the problem but I have no idea what :confused::confused::confused::confused:

Share this post


Link to post
Share on other sites
I've tried every driver I can get my hands on, even omega drivers etc.. and still no luck.

Seems lots of people can play offline but not online, must be something specific to the online game that is causing the problem but I have no idea what :confused::confused::confused::confused:

Have u tried turning off AA i& the Catalyst AI in the CCC?

Share this post


Link to post
Share on other sites

The game is working fine with 9.6,I seem to have much better framerates in all applications (Including BGE.). ;)

Share this post


Link to post
Share on other sites

Ok I've encountered a graphicsbug in BGE with 9.6.

Smoke looks like lines (Smoke behind vehicles for example.).

I'm on Windows 7 RC Build 7100,with a Q6600,4Gb Ram,Radeon 4870x2.

Share this post


Link to post
Share on other sites

I have an ATI HD3600

Going into game i have a fatal blue screen crash sending me out of te game with the following report

Driver_IRQL_Not_Less_or_equal

Any ideas guys to help?:mad:

Share this post


Link to post
Share on other sites

I am running dual HD 4850s on Vista64 and had the AA bug, but it is gone with the 9.6 drivers.

It has only been two days since I upgraded to 9.6, but I haven't noticed any graphical anomalies/problems.

Share this post


Link to post
Share on other sites

Im not really sure if it is ATi's problem, but after saturdays update to 1.30.2 it crashes to desktop when loading is finished (even after full reinstall)

Does anyone know how to fix it??

S!

Share this post


Link to post
Share on other sites

Just wondering how everything is going with peoples drivers. I have a ATI Radeon 512mb 4850 card coming as part of a computer I ordered. I'm wondering which drivers offer the best FPS rates.

Regards...

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.