Sign in to follow this  
Followers 0
leparc

ATi Catalyst Driver Problems...This Needs a sticky

298 posts in this topic

A possible fix would be to increase the timeout detection and recover of the GPU, but i'm little bit scared of adding new entries to the registry (an not sure of how to remove it if not working)...

Or maybe should i save the entire registry, or try on my vista partition.

The explanation on microsoft website :

http://www.microsoft.com/whdc/device/display/wddm_timeout.mspx

The tweak that a guy did for another game (Win 7 & ATI card) :

http://www.vertical-visions.de/2009/09/05/windows-7-ati-vpu-recover-problem-anno-1404/

Or if a guy is comfortable with editing registry, he is welcome to try it ;)

Share this post


Link to post
Share on other sites

Forget about it....

I just tried on my Vista drive, and game still crashing. Just take little bit longer for GPU to recover.

Need to find other fixes...

Share this post


Link to post
Share on other sites
A possible fix would be to increase the timeout detection and recover of the GPU, but i'm little bit scared of adding new entries to the registry (an not sure of how to remove it if not working)...

Or maybe should i save the entire registry, or try on my vista partition.

The explanation on microsoft website :

http://www.microsoft.com/whdc/device/display/wddm_timeout.mspx

The tweak that a guy did for another game (Win 7 & ATI card) :

http://www.vertical-visions.de/2009/09/05/windows-7-ati-vpu-recover-problem-anno-1404/

Or if a guy is comfortable with editing registry, he is welcome to try it ;)

Tried it. Did not help. Tried also disabling it (allthough found only vista instructions and I have 7). There isnt any vpu recover anymore unlike xp. This could very well be the problem somehow though thats why I tried it.

Share this post


Link to post
Share on other sites
Post on AMD/ATI forums

I started a post at the AMD/ATI forums above, please all go and put your comments if your having trouble with the 5000 series cards.

From forums the told to me that need to do a ticket by feedback form but havent done it yet and dont know how. So posting in forums wont help much.

Share this post


Link to post
Share on other sites

accaunt closed today,

impossible play the game with CTD every 5-15mins.

and there seems not to be game support from devs.

i ll miss BE, hope in a miracle in 1.31 patch

Share this post


Link to post
Share on other sites

Errah,

Sorry to see you go, I am probably not far behind you. There are a LOT of games that don't have issues with ATI video cards, and unforunately the FPS on my old machine in BE was one of the reasons I build a new rig. Now I can't play at all.

Rats, can someone please tell me you are working with ATI to fix this? We need some love.

S!

VTCC93

Share this post


Link to post
Share on other sites

Just to throw my hat in the ring. I run dual ATI 3800's and had no troubles. I let my account run out for a couple months, just reuped my subscription and downloaded the 2 patches I had missed. and now I get the same issue. 10-15 minutes then instant CTD.

Tried uninstalling the game and then full re install... no help.

updated the drivers to 9.10 ...no help.

I re subbed for 3 months. I hope I don't have to wait until february to get a chance to play. One thing for sure, if I can't play by feb, I won't throw my money away again.

Share this post


Link to post
Share on other sites

Update, After no luck with version 9.10, I saw several in this thread had good luck with version 9.7. I loaded the 9.7 drivers and it seems to have worked. I played for a little more then an hour last night with no problems.

Share this post


Link to post
Share on other sites

Redtex,

Unfortunately, I don't think 9.7 supports the new 5000 series cards, so we are all still stuck, I am glad that you are up and running.

VT

Share this post


Link to post
Share on other sites

New beta 9.11 is out on 6.11.2009. I tested it and it works differently. Now it let me play for 5 mins or so and crashed the hole computer! Did not ctd.

Possibly still same problem but differently. Maybe someone else could test this too because it might work for someone else. After it had crashed it gave me an error when booting to windows that some ati drivers are missing. Tried it 2 times and it happened.

http://www.ngohq.com/home.php?page=Files&go=cat&dwn_cat_id=18

And this is NEW 9.11 beta. Not that october one.

Edited by krhkmies

Share this post


Link to post
Share on other sites

I tried it, but still have same kind of crash.

First time i could play 2 minutes, second time it crashed on main screen...

Share this post


Link to post
Share on other sites

Long time player here-running on a intel p4/1.5gram/ati9600-for a while now.

Ever since 1.28 came out, i have had many stutter issues on that rig.

So, i just renewed for another month, a couple of weeks ago. Now, i got myself a new rig.

The hardware: amdx2 550, 790xnb, 4gpc1600, and ati hd5750 with catalyst 9.10 drivers(only one that works.)

I am also running on windows 7 x64.

Please help us guys, who just wanted a system that would do away with the constant stutters that we suffered so greatly from; Only to find that we got NO game functionality at all!

Share this post


Link to post
Share on other sites

From CRS twitter:

Bloo is installing a Radeon 5770 on his Windows 7 box. Woot.

Finally! Thank you CRS. We need a fix asap!

Share this post


Link to post
Share on other sites

So . . . . .

I reproduced the ctd and fail to load problems with the live game online using the 5770 with latest drivers on a Win 7 64 machine. (I haven't tried older drivers - not sure that would be fruitful based on all of your reports.)

However, in the the closed beta build Gophur built late yesterday . . . no problems so far. I let it run overnight and it's still fine.

Of course, that is just a preliminary testing result, and there is more work to be done (verification, testing with populations and combat, etc.) but it is a very good sign.

Share this post


Link to post
Share on other sites

As based upon this reply, would I be correct in assuming that any quick fix or patch to the existing build we are playing online at the moment is not going to happen, and that those of us with 5000 series ATI cards are going to have to wait for the new beta in order to have a playable platform?

Share this post


Link to post
Share on other sites
As based upon this reply' date=' would I be correct in assuming that any quick fix or patch to the existing build we are playing online at the moment is not going to happen, and that those of us with 5000 series ATI cards are going to have to wait for the new beta in order to have a playable platform?[/quote']

I'm not a rat, but just based on my guesstimate of how much the underlying engine has changed, no, I don't think a quick fix is on the horizon. Even if they could isolate a segment of code and attempt to back port it to the 1.30 code base I seriously doubt they could guarantee a surefire fix.

Share this post


Link to post
Share on other sites
As based upon this reply' date=' would I be correct in assuming that any quick fix or patch to the existing build we are playing online at the moment is not going to happen, and that those of us with 5000 series ATI cards are going to have to wait for the new beta in order to have a playable platform?[/quote']

ATI 5xxx useres = no ww2online.

see u with 1.31

:(

Share this post


Link to post
Share on other sites

Unfortunately, dkamerad is essentially correct.

We have no plans to patch 1.30, all efforts are going into 1.31.

Share this post


Link to post
Share on other sites
Unfortunately, dkamerad is essentially correct.

We have no plans to patch 1.30, all efforts are going into 1.31.

Well thats kinda good news so that when my sub runs out and I am sure as will many others we can dare to be brave and risk trying to pay for a game that might play for us, But for my self I dont think I will feel like giving any more money since I havent been able to play since Oct and since they wont be bold enough to say when 1.31 will be coming out. I wonder how many subscriptions this little action and even more lack of replies will cost in member numbers. Sorry if I sound bitter (but I dont enjoy paying for a game where I get no support )since CRS couldnt reproduce this issue and months go by before they even address the player base concerns. So many be if that ratz fix this and they will refund my unplayable time I will come back to this game in 2011 or when ever the patch comes out. I have had several people I talked into trying this game but when I found out they ran ATI cards I told them to forget it and save their time and money.

But I have learned to never pay in advance for this game. No mater what discount you get by getting a year at time your will loose money as oppose to playing by the month

Edited by buckly

Share this post


Link to post
Share on other sites
Unfortunately, dkamerad is essentially correct.

We have no plans to patch 1.30, all efforts are going into 1.31.

I can certainly understand this decision, but unless 1.31 is coming out live on the game server in the next few days (which it obviously is not since the open beta has not even launched yet), someone should immediately note this deficiency on the system requirements page. The ATI Radeon 5XXX cards are the hot cards to get right now, and the majority of people ordering new systems or parts are going to be getting them. Therefore, you are only going to have more upset folks if this is not adequately publicized. I certainly never knew there was any problem until after I bought the card, as I have a 4XXX series card that works perfectly with no issues. This is particularly true if it is going to be several weeks or even months (which seems likely) before a final build of 1.31 is released for actual campaign play. There is no use signing up new players, or having existing players upgrade, only to find that their latest and greatest computer with the hottest card on the market cannot even play the game, and that such a fact is not documented.

Having said this, I hope development of the new beta goes well, and that we will all be playing again shortly on our fast video cards.

Share this post


Link to post
Share on other sites
So . . . . .

I reproduced the ctd and fail to load problems with the live game online using the 5770 with latest drivers on a Win 7 64 machine. (I haven't tried older drivers - not sure that would be fruitful based on all of your reports.)

However, in the the closed beta build Gophur built late yesterday . . . no problems so far. I let it run overnight and it's still fine.

Of course, that is just a preliminary testing result, and there is more work to be done (verification, testing with populations and combat, etc.) but it is a very good sign.

Great to hear!

Thanks for keeping us up to date rats. Keep up the good work.

For now we just wait, we just wait...

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.