Sign in to follow this  
Followers 0
tbomber

anyone getting issues with directional sound?

36 posts in this topic

Its hard to explain but it seems like sounds arent coming from the directions they should be. Planes fly by overhead and it sounds like theyre coming from the left, even if i'm looking straight at them.

when a rifleman is shooting at me i cant figure out where hes coming from because no matter where i face it's as though he's changed spots entirely.

before i could pinpoint an enemy's exact location just from hearing their engine/gun fire. now it's hard as sh1t.

Share this post


Link to post
Share on other sites

I was also getting the feeling that the sounds were coming from the wrong direction, but where I was playing there was so much going on that I couldn't really decifer what was wrong. I'll be testing more later on today.

ibad

Share this post


Link to post
Share on other sites

I am also having sound problems associated direction and volume. It almost seems like the sound is inverted so that distant objects sound near (loud) and then the sound decreases as it moves closer. I haven't done any experimenting yet.

Current sound settings are: "enable sounds" checked, "force stereo" checked, "convert sounds on load" checked, "max sounds" 32, and "3D quality" low.

Config: X 10.4.1, 2x2GHz, 3.5GB, 1.19.1

Share this post


Link to post
Share on other sites
Its hard to explain but it seems like sounds arent coming from the directions they should be. Planes fly by overhead and it sounds like theyre coming from the left, even if i'm looking straight at them.

when a rifleman is shooting at me i cant figure out where hes coming from because no matter where i face it's as though he's changed spots entirely.

before i could pinpoint an enemy's exact location just from hearing their engine/gun fire. now it's hard as sh1t.

100% agree Tbomber. Sounds like you and I have the same probs.

before with headphones I would just quickly look to the left, then look to the right and I would be able to very accurately pinpoint sound locations, now it is a crapshoot. My Situational Awareness has dropped enormously.

Share this post


Link to post
Share on other sites

Make sure you turn OF force stereo and keep quality HIGH, the openal library is rather picky. For some reason it works fine for me, I tested it all weekend with the new doppler setting. Direction and doppler all sounded fine (I use reference monitors). I'm beginning to hate openal....

More later 2nite...

Share this post


Link to post
Share on other sites

yeah my sounds are on high and all that - i just did a test and there is definitely something wrong:

i had an infantry in front of me start moving around in a small circle, and it sounded like he was right next to me, to my left.

Share this post


Link to post
Share on other sites

OK, let's see if openal can account for this one:

I spawned at the Dordrecht AB in an A13. Drove away from the veh spawn and the engine sound slowly went away, behind me! By the time I was 400m from the veh spawn I couldn't hear the engine anymore from any of the 3 positions (even CDR ouside). I could hear the tracks just fine, squeakin away.

I have the same problems others have: planes have idle when in a dive, high revs when at the top of a climb; sound of Camle rounds exploding on the ground are 90 to 180 degrees to the right or left, depending on where I spawn; footsteps are doubled everywhre but grass and dirt; etc., etc., etc.

I loved this game for the positional and directional sounds, graphics be damned - this sound problem is making me want to rethink playing. After all I can't tell where anything is happening anymore, and the other guy has a definate advantage over me now.

Share this post


Link to post
Share on other sites

Yeah its still not working. Oddly enough it works sometimes just fine. I hear planes flying and the doppler moves perfectly across my speakers. Just now I started up a 232 and it sounded 100 meters away. Gag this is annoying...

Share this post


Link to post
Share on other sites

It's messed up for sure. I get in a plane and the engine sounds like it's a mile away, I bearly hear it, yet the guns and all other sounds are very loud and close sounding.

Share this post


Link to post
Share on other sites

Lets keep this thread alive. This should be priority ONE right now.

The sound issue is a MAJOR prob. My PC squad mates must have thought I was a born-again Noob last night. I couldnt call out targets, or when I did, I got the direction so messed up it cost one of my squaddies his tank. Im happy they fixed the grainy texture (THANK YOU!!) but Id have to say, besides extremely low FPS, the sound issue is the worse thing 119 has against it right now.

Actually, it could be Number ONE on the worse list, cause for now I can work around low fps to a point, there is no workaround for not having a clue where things are around you.

Share this post


Link to post
Share on other sites

I had no idea that multi-textureing was fixed - really improves the looks!

In the sound config - does the convert sounds on load help or hurt?

Share this post


Link to post
Share on other sites

Here's the scoop on OpenAL for those with curios minds and developer brains:

http://opensource.creative.com/pipermail/openal/2005-April/002850.html

http://opensource.creative.com/pipermail/openal/2005-April/002856.html

Gag, apparently doppler is seriously screwed up in current openal...

re doppler in future openal code:

"It is the most major point of departure from the 1.0

spec, and for good reason -- as you have observed it is such a mess in

1.0 that it's essentially unusable."

Methinks the best plan is to *delete* the doppler settings completely

I will test this tonite... the doppler might not work but hopefully the game sound will at least be playable again...

Remember that openal is open source and that Apple's version is just a good faith attempt to fix it for the Mac. Unfortunately it sucks...

-- Andrew

Share this post


Link to post
Share on other sites
Just tried it and that is even worse...

Any hope to "downgrade" to a lower version of OpenAL on Mac? I work sysadmin for tons of Linux, UN*X and Windblows boxes, and have compiled (and tried to mod) more kernels, modules, and apps than I can count. I have trudged thru OSX's structure, but I don't *really* know what is where. I never got a handle on *BSD either, being bred on Linux flavors since 1995. I don't know if a downgrade is even possible, but if it looks like an option, I am all for hacking my box. Just send the locations and filenames to mod/replace. One warning: I am not a C coder (yet); shell scripting and a bit of PERL, awk, and PHP are about as far as I have gone.

Share this post


Link to post
Share on other sites

Yea, the sound right now our a major douche. I also have a hell of a time find tanks and other enemies. For me it sounds like just as I spawn, my sounds stays there and when I move futher and further away it sounds like I'm still in that AB or FB.

Share this post


Link to post
Share on other sites

That's precisely what I get, viruses. In addition to other directional problems as well.

The game is now unplayable.

It's unbelievable how much you depend on sound to play this game. I can't find any enemy (or friendly) tanks by sound; planes have gone the other way - litterally - by the time I have looked up; explosions from HE are hundreds of meters off from where they actually hit; and forget trying to find a rifle shooting at you - unless you know the 90 or 180 degree 'trick' to TRY and locate them, then have fun trying to get distance on them.

I sympathise with whoever it was that said they can deal with the FPS thing to a point, but we now cannot play the game on a basic level! This is untennable. I just hope a RAT sees this thread sooner than later.

BTW, Happy Fourth all. Guess I'll be doing yard work rather than kicking Jerry's a&& across Europe like I wanted to.

Share this post


Link to post
Share on other sites
That's precisely what I get, viruses. In addition to other directional problems as well.

The game is now unplayable.

It's unbelievable how much you depend on sound to play this game. I can't find any enemy (or friendly) tanks by sound; planes have gone the other way - litterally - by the time I have looked up; explosions from HE are hundreds of meters off from where they actually hit; and forget trying to find a rifle shooting at you - unless you know the 90 or 180 degree 'trick' to TRY and locate them, then have fun trying to get distance on them.

I sympathise with whoever it was that said they can deal with the FPS thing to a point, but we now cannot play the game on a basic level! This is untennable. I just hope a RAT sees this thread sooner than later.

BTW, Happy Fourth all. Guess I'll be doing yard work rather than kicking Jerry's a&& across Europe like I wanted to.

haha thats exactly what ive been doing: gotta hit E then Q to look right and left just in order to figure out where an enemy is...it ends up sending me in circles though...

Share this post


Link to post
Share on other sites

What's really odd is that the main problem is *engine* noises. For me gunshots, feet, bombs, etc work perfectly but tank engines for example seem to come from somewhere other than the tank. I have heard some PC folks complain as well. It isn't the doppler setting as no matter what I set it to the same problem occurs... I think it is a program bug now not just the sucky openal.

Share this post


Link to post
Share on other sites

Yeah, I'm having the same problem as everyone else.

Frustration led me to cntrl + click the ww2.app, select "show package contents", click open "contents", then "frameworks", and finally, remove the openal folder (to desktop). I ran 3 missions in liege, over about 30 mins time, and the sound was much bettter. I don't use additional speakers or headphones, so as far as sound quality is concerned your mileage might vary, but the directional issues appear to be significantly improved. I seem to remember this was a solution for another openal problem about a year ago. S!

Share this post


Link to post
Share on other sites

I just posted in this (original?) thread:

http://discussions.playnet.com/viewtopic.php?p=2910755#2910755

Short version: Offline testing: airplane engine sound problems persist; DOPPLER SOUND PROBLEMS GO AWAY. Yep, I got what I consider to be normal distance and directional sounds from my testing. Yes, I cannot test third-person, but this is an eye-opener in my book.

Share this post


Link to post
Share on other sites
What's really odd is that the main problem is *engine* noises. For me gunshots' date=' feet, bombs, etc work perfectly but tank engines for example seem to come from somewhere other than the tank. I have heard some PC folks complain as well. It isn't the doppler setting as no matter what I set it to the same problem occurs... I think it is a program bug now not just the sucky openal.[/quote']

Ok. I agree with you.

I did a quick test by linking in CRS's OpenAl framework to Apple's 'OpenALExample' code. The example code still runs fine. => So I don't think the problem is in the openal framework.

Hope that this helps. s!

Share this post


Link to post
Share on other sites

Concur.

The sound is profoundly screwed up. Direction and volume are fubared.

Engine sounds in tanks are wacked. You can barely hear tank engines.

Aircraft engines are barely audible and "spin down" cyclicly.

I can hear some vehicles that are out of visual sight, but cannot hear others which are next to me.

Variations in sound prefrences do not seem to affect performance.

This makes it very difficult to play.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.