Sign in to follow this  
Followers 0
AHWULF

Smartheap errors and the like

132 posts in this topic

I am starting work soon on tackling the ugly stuff in the windows version (yes windows, normally I do mac support and fix mac bugs) so if anyone has answers to these questions please post. Since I play on the mac version I don't know the cruelties of the windows version that well.

(1) What version did you start seeing the "Smartheap error" in?

(2) How often does it happen?

(3) What percentage of CTD's is it?

(4) Any other details about when it seems to happen most?

Report your specs as usual - CPu type / memory / OS version / video card

The more info I get the easier it will be to find a fix :-)

Share this post


Link to post
Share on other sites

Hi there

I just got the smartheap error, first time for me, have not played mutch, and havent CTD in many months, never had this before

system specs:

Win 7 64 bit

i7 920 CPU (no overclock)

12 gig ram

GTX 295 (182.06)

OCZ SSD raid 0 120 gig disk

Xonar DX sound card

fresh install of game.

Hope that helps, and i got it while in air, as paratrooper, from gilze to breda.

Edited by andyboy

Share this post


Link to post
Share on other sites

ah well, 1 more smartheap error, took max 4 min in game to get it.

sound, starts to chopp up, and screen locks up, and the CTD comes, with smartheap error.

something is REALLY bugged here, thats for sure.

PS: tried to uninstall and delete folder after uninstall, and reinstall, still crap, and with another download/install file as well, som it aint a bugged download.

Share this post


Link to post
Share on other sites

Always in heavy battle

Almost always when respawning several times (quickly) in succession (almost as though memory isn't cleared from the previous time ... Though respawn OOM isn't always the case)

Windows Vista 32-bit Ultimate (SP2)

Intel Core-2 Extreme X9650 at 3Ghz (not clocked)

4GB of ram - 2.556gb useable (having deducted what Vista steels) as reported by dxdiag

2x 9800GT (in SLi mode) 190.38 drivers

Stupidly large pagefile.

Creative SB X-Fi Sound Card (selected in game settings)

I have upgraded through 3 sets of Nvdia gfx drivers, with no change.

I did wonder if it was related to the "freezes" induced by the "System Capture Message" (Enermy forces have captured xxx depot etc), but although disabling the messages has (almost) got rid of the freeze, the SmartHeap error persists.

I am now trying NT (SP5) Compatibility Mode ... Just to see if regressing that far makes any difference.

(Best of luck)

Share this post


Link to post
Share on other sites
Anyone try windows7?

hi there, if you see my post, i use win7:)

64 bit

and to not get mouse lockup, game has to be run in vista compability for Win 7

Edited by andyboy

Share this post


Link to post
Share on other sites

(1) What version did you start seeing the "Smartheap error" in? 1.30

(2) How often does it happen? only in large battles. well it was only in large battles when i posted this, but now its every time even in offline mode. something with the WW2_x86.exe file it runs. I went to try the just ww2.exe and i never got the out of memory error.

(3) What percentage of CTD's is it? actually like 100% of the time now, i havent got a ctd, till this started up.

(4) Any other details about when it seems to happen most? tells me im out of memory

Report your specs as usual - CPu type / memory / OS version / video card

AMD Athlon x2 Dual 5200

3 gig ddr2

Windows xp Home

Nvidia geforce 8800gt (with latest drivers)

Edited by death

Share this post


Link to post
Share on other sites

Bootcamped mac pro dual-quad 3.2, plenty of memory > 6Gb, first system using Vista 64 bit ultimate, new updated to Windows 7, GeForce 8800, PCI-E sound card from Creative

(1) What version did you start seeing the "Smartheap error" in? 1.29

(2) How often does it happen? With high resolution (2560/1600) on every spawn, then when you lower the resolution, you get longer and longer gametime, with 1600/1200 about an hour.

(3) What percentage of CTD's is it? Always smartheap, never just CTD

(4) Any other details about when it seems to happen most? The better the resolutoin the faster.

UPGRADING TO WINDOWS 7 HAS CURED THIS PROBLEM FOR ME!!!

Share this post


Link to post
Share on other sites

I got this error a few times, updated to the latest Nvidia video driver and haven't seen it since March.

(1) 1.29

(2) once

(3) one

(4) no?

Report your specs as usual - CPu type / memory / OS version / video card

Intel Core2Duo E8400 @ 3Ghz, OCZ Lowvoltage 2x2GB 1066Mhz ram, Vista Home-Premium 64-bit, BFG 9800 GTX OC.

Edited by whiran

Share this post


Link to post
Share on other sites

Intel Core2Duo E8400 @ 3Ghz, OCZ Lowvoltage 2x2GB 1066Mhz ram, Vista Home-Premium 64-bit, BFG 9800 GTX OC.

if you dont know what that means... it says i have 4GB of ram.

Share this post


Link to post
Share on other sites

One of the problems with this error is that it doesn't happen to everyone. It never happens to me on my Mac under Bootcamp/XP. What I really need is to watch it happening in a window (or second monitor) with the task viewer up showing physical and virtual memory. My "guess" is that it's video driver dependent. THere is a default behavior of Smartheap (it allocates virtual memory in 64K chunks) that is not recommended for certain video card drivers (generically, there is no list). I want to increase this magic value to 1MB. However I can't duplicate the problem so I am hoping that one of the Rat PC's has it happen a lot so I can watch it get the error, and then try changing this value. On my "PC" the physical memory maxes out at 1.25GB, and even the VM doesn't go much beyond that either.

Whatever it is it isn't an error everyone gets. Something either in the game (like a texture or building or something) causes a memory blowup, or something in your computer does (like the video driver). So far there isn't enough detail to distinguish which one.

Share this post


Link to post
Share on other sites
if you dont know what that means... it says i have 4GB of ram.

TOo much lunch, I'm sleepy and missed it lol.

Share this post


Link to post
Share on other sites

well it could be a video driver, BUT if people have been getting this issue since 1.29 then its not just the latest drivers.

Share this post


Link to post
Share on other sites

I remember some of the details that lead upto the event of "smartheap error"

just installed a new Nvidia driver, some 182.xx series before 186.xx

started up the game spawned into a town under HEAVY attack fps was down less than 10, I deployed my Pak36 even though Tier 4-6 was around was going to sniper the EI in the building that was in the AB from 800 meters.

apon switching to my gunner i seen no numbers and in place of those numbers were these solid like blocks same color and size as the text/number but was a filled in block where it should of said the amount of ammo, I post a .report undeploy and move closer then redeploy, fire 2-3 rounds at the building not killing anything and the game goes black I alt-tab to end task and theres the smartheap error window.

btw at the time I ran about 768-2048MB pagefile, I've been running 200MB pagefile for 4 months now without issue, and a different driver, looking for the driver right now that i was using.

182.06

182.08

182.50

one of the above drivers was the cause.

Edited by whiran

Share this post


Link to post
Share on other sites

The reason I suspect drivers is that in the smartheap manual, it mentions that some drivers don't like the way memory is given to them with the default setting of this one parameter. If I can get a PC to die I can try changing this to a bigger value and see if it changes.

Share this post


Link to post
Share on other sites

Ive had it as well.

(1) 1.30.2

(2) once

(3) one

(4) sound went weird

Specs are

Core 2 Quad Q9550

ATI 4850

4Gb Mem

Windows 7 64bit with the game in Vista compatibility mode to fix the mouse lockup

Share this post


Link to post
Share on other sites

Prior to 1.30 I woul dget "Driver Display Errors" and the game would CTD.

The error message would appear by my Windows Clock as a small icon which - after the game had CTD - would say "The driver XXXXXXX had encountered an error and successfully recovered". (I cannot remember what XXXXXXX actually was).

The last error of the "old type" occurred on 29/05 - You would have to work out if that was 1.29, as I cannot remember.

However, I can produce a dump file from one of those "old" events - But I cannot see how to attach one to this post? Let me know if it will help (as in, hope the Smartheap error is a child of the old "graphics card stopped working" error)?

Cheers.

Share this post


Link to post
Share on other sites

any information on the status of the solution? this error is becoming more persistant the longer i play and honestly the 2nd most frustrating thing i've seen out of this game.

Share this post


Link to post
Share on other sites

It appears to be an interaction between video drivers, opengl (which is part of the driver) and smartheap. One thing I hope to try is to make the video driver not use smartheap which might avoid the issue. Another option we are trying (so far no working) is to use an alternative to smartheap for fast memory allocation. Smartheap is a commercial memory library which has made stutters far less and overall created better performance. However it may have an interaction with various video drivers that doesn't work (and in fact both NVidia and Ati keep trying to fix this). Do you absolutely have the latest video driver for your video card?

I can't get the error on my computer, I may need some volunteers to try a "fixed" version; none of the rat computers get this error on 1.30 either.

1.31 alpha BTW actually uses less memory than 1.30 as of today (may change).

Share this post


Link to post
Share on other sites

well it keeps happening to me, and i didn't change anything between the patches. i've updated all my drivers just now but it happens more frequently, my playability is crap right now i dont even feel like taking the time to figure it out, for a rig that has 4 gigs of memory to run out in 3 spawns, in a busy town, not very playable,

Share this post


Link to post
Share on other sites

It's not running out of memory, its a bogus generic error message. I have 3Gigs of memory and never get the error. So I have to collect all the data I can to figure out what combo of features triggers the problem. The quicker I see the pattern the quicker it can get fixed. Most people don't get this error, but for the ones that do its all the time.

Share this post


Link to post
Share on other sites

i aint had time the last month to even bother, but i should in a week or so be back to normal and then i'll focus abit on trying to give you the info.

i only get this during high pop battles so for me to get this problem i'll need to get on a sat-sun when it's heavy fighting so when i do i'll mark all the details.

i don't mind trying a newer version either to see if it works, it can only be as unplayable as this one is at moment, although i aint sure on my comp stats and need to check it's not a perfect comp so you may want to try someone else.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.