• Announcements

    • XOOM

      Volunteer PHP Developer wanted to revive the Gazette!   07/24/2019

      We're looking to properly revive the World@War Gazette and need a solid PHP developer to help take some work forward. If you have some skills with PHP and are looking for some experience and to bring important home page news / recognition for individual players back to WWII Online, I'd like to hear from you! Submit an inquiry to jobs@corneredrats.com with some details about your experience. You will need at least 10+ hours per week to contribute to the team. The Gazette's current status can be found here: https://www.wwiionline.com/resources#gazette
Sign in to follow this  
Followers 0
AHWULF

Snow Leopard

40 posts in this topic

Note we won't even have snow leopard (10.6) until I get a copy, so there is no guarantee the 1.30.x client will run on it. Then again it might work just fine. No way to know for now.

Share this post


Link to post
Share on other sites
Note we won't even have snow leopard (10.6) until I get a copy' date=' so there is no guarantee the 1.30.x client will run on it. Then again it might work just fine. No way to know for now.[/quote']

it worked for me on a pre-release build of snow :)

Share this post


Link to post
Share on other sites

Yeah I woul dbe pretty confident of it working from what I have read about it.

Not sure about performance etc but even with all the re-write changes and "new tech" it's just a faster streamlined version of 10.5 :)

Will have a copy of server and client soon so may give it a go.

Share this post


Link to post
Share on other sites

I just got the email that says I can get snow leopard for $29 or something. How could I pass that up?

Share this post


Link to post
Share on other sites
I just got the email that says I can get snow leopard for $29 or something. How could I pass that up?

You can't :)

Also it is just a big patch. You have to upgrade from 10.5

As far as I can judge there is no full install but won't know until we get the disks/. I didn't see any develpoer versions etc. Anyone know if there is a full clean install option - must be ??. That means you can just buy it and install it.

Certainly not an option for clients to buy the box set bit if a waste. I have one client with about 20+ users still on 10.4 (rest onb 10.5) and will put them all to 10.6 by next year.

The upgrade path from 10.4 is odd. So far only thing I have seen is the "box Set" with ilife, iworks and 10.6

Edited by badger77

Share this post


Link to post
Share on other sites

Geez, i wouldn't upgrade to 10.6 until they have done at least 4 patches. Much as I love apple it need a few patches before I'm going near it, both at home and the office Macs.

Share this post


Link to post
Share on other sites

Ok, I installed the new cat on a 2.4 GHz 24" iMac. (32-bit kernel)

No apparent problems but it still early. Game seems to run fine.

So far so good.

s!

Share this post


Link to post
Share on other sites

Just tried it out for a minute, looks to work fine on my MacPro with ATI4870, although it seems there are some OpenGL issues with Maya (shaded mode not displaying colors correctly) incase anyone else is using that app.

Share this post


Link to post
Share on other sites

I haven't noticed a significant change either way. Anecdotally, the FPS seems the same as well the same old bugs. I did crash once yesterday but I haven't looked at the crashreport yet.

Share this post


Link to post
Share on other sites

So BIGMAC, are you going to help the RATS adopt GCD? It will be nice to see if we can get the usage up on multicores now.

s!

Share this post


Link to post
Share on other sites

Can't, this engine is not multi-threadable at all. We'd have to build a new one. In any case cross-platform means no GCD.

On a sort of related note, I am building a new OSX app to sell that uses OpenCL :-) So nice to be able to use all the new stuff and not care about the old.

Share this post


Link to post
Share on other sites

It works but I still get invisible buildings on my 2009 Macbook Pro with a GeForce 9600

Also installing patches requires Rosetta to be installed.

Share this post


Link to post
Share on other sites

You have to turn off the normal maps shader with nvidia cards. This *should* be fixed in 1.31 as it has new shaders.

Don't know where the Rosetta requirement comes from, I haven't seen that on my MacPro. Anyone else see this?

Share this post


Link to post
Share on other sites
You have to turn off the normal maps shader with nvidia cards. This *should* be fixed in 1.31 as it has new shaders.

Don't know where the Rosetta requirement comes from, I haven't seen that on my MacPro. Anyone else see this?

Halfway through the patch install a dialog came up saying Rosetta must be installed for [an app called something like diff] to run. So I clicked OK to download Rosetta and the patch failed. The patch worked fine the second time round, after Rosetta was setup.

Also disabling normal maps fixed the invisible buildings, thanks.

Edited by blazted

Share this post


Link to post
Share on other sites

Especially strange since diff only comes in intel versions under 10.6:

$ file /usr/bin/diff

/usr/bin/diff: Mach-O universal binary with 2 architectures

/usr/bin/diff (for architecture x86_64): Mach-O 64-bit executable x86_64

/usr/bin/diff (for architecture i386): Mach-O executable i386

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.