Sign in to follow this  
Followers 0
pakoon

External Display problem

20 posts in this topic

I recently got a new Samsung 25,5 inch monitor with 1980x1200 resolution and the game won't let me use the full resolution on the "big screen" I don't have mirroring on and the monitor is working just fine in any other application and in bootcamp too but not on OSX Leopard.

Here's my system specs:

Model Name: MacBook Pro

Model Identifier: MacBookPro5,1

Processor Name: Intel Core 2 Duo

Processor Speed: 2.8 GHz

Number Of Processors: 1

Total Number Of Cores: 2

L2 Cache: 6 MB

Memory: 4 GB

Bus Speed: 1.07 GHz

Boot ROM Version: MBP51.0074.B01

SMC Version (system): 1.33f8

NVIDIA GeForce 9600M GT:

Chipset Model: NVIDIA GeForce 9600M GT

Type: Display

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 512 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0647

Revision ID: 0x00a1

ROM Revision: 3343

gMux Version: 1.7.3

Displays:

Color LCD:

Resolution: 1440 x 900

Depth: 32-Bit Color

Core Image: Hardware Accelerated

Mirror: Off

Online: Yes

Quartz Extreme: Supported

Built-In: Yes

SyncMaster:

Resolution: 1920 x 1200 @ 60 Hz

Depth: 32-Bit Color

Core Image: Hardware Accelerated

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Supported

Rotation: Supported

Television: Yes

Some screenies of the problem.

These are the settings for the external display:

0017ad32d9.png

and these are the settings for the laptop display:

6e73b38173.png

I can't change the resolution on external display and if I open settings on that and just click ok the resolution what I get is 640 x 480 or something like that but if I check the laptop's display prefs first and check the maximum resolution which is 1440 x 900 and then return to external displays' settings I get to play the game on the bigger screen with that 1440 x 900 but that's it. The resolution button on the bigger screen's prefs is totally unresponsive -like there's no button at all. Is there anyway to tweak the settings manually or something??? I've tried everything imaginable with system and display preferences but nothing helps.

Share this post


Link to post
Share on other sites

Thanks mate It worked:) I just have to remember not to open settings at launch because that messes up the resolution again. Cheers!

Edited by pakoon

Share this post


Link to post
Share on other sites

It is the main display, as you see in the screenies I posted. :) Weird thing though that the settings doesn't let me change the resolution...but luckily that .xml-tweaking worked fine.

Share this post


Link to post
Share on other sites

Isn't that one of those MBP that actually have two video cards onboard? It's possible the settings code can't handle that oddity.

Share this post


Link to post
Share on other sites

Yup.

9400M and 9600M GT.

NVIDIA GeForce 9400M:

Chipset Model: NVIDIA GeForce 9400M

Type: Display

Bus: PCI

VRAM (Total): 256 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0863

Revision ID: 0x00b1

ROM Revision: 3343

gMux Version: 1.7.3

Displays:

Display Connector:

Status: No Display Connected

Display Connector:

Status: No Display Connected

Chipset Model: NVIDIA GeForce 9600M GT

Type: Display

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 512 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x0647

Revision ID: 0x00a1

ROM Revision: 3343

gMux Version: 1.7.3

Displays:

Color LCD:

Resolution: 1440 x 900

Depth: 32-Bit Color

Core Image: Hardware Accelerated

Mirror: Off

Online: Yes

Quartz Extreme: Supported

Built-In: Yes

SyncMaster:

Resolution: 1920 x 1200 @ 60 Hz

Depth: 32-Bit Color

Core Image: Hardware Accelerated

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Supported

Rotation: Supported

Television: Yes

Share this post


Link to post
Share on other sites
I believe the settings are kept in:

~/Library/Preferences/ww2ol/wwiiol.xml

You can try to edit the line:

Where do i paste it in??

Share this post


Link to post
Share on other sites

Go to root then /Library/Preferences/ww2ol/wwiiol.xml

You'll need an xml editor and the "library" folders visible. The line

Furthermore, you should be aware this write up was from 2009 and the game (AND OSX) has changed versions several times since then. I do not believe this to be an issue anymore.. I just attached my external Samsung monitor with no problems. Before you modify these settings I would double check your setup. The "settings" menu prior to entering the game should be sufficient to do what you want.

Edited by Thrance

Share this post


Link to post
Share on other sites

Well it seems the common fix is no longer compatible with OSX 10.9.3

I've tried a few dozen times to get this to work correctly, but every time I open the BE launcher, it overwrites the existing xml file and creates a new one from scratch - losing all of my settings and reverting back to 640x480 screen resolution. Freaking annoying. Anyone have any ideas?

Share this post


Link to post
Share on other sites
Well it seems the common fix is no longer compatible with OSX 10.9.3

I've tried a few dozen times to get this to work correctly, but every time I open the BE launcher, it overwrites the existing xml file and creates a new one from scratch - losing all of my settings and reverting back to 640x480 screen resolution. Freaking annoying. Anyone have any ideas?

Maybe edit the file then set it to read only?

Share this post


Link to post
Share on other sites
Maybe edit the file then set it to read only?

I'll try the read only trick. I tried locking the file and selecting "prevent editing" within the text edit. Thanks Zeke, good to see you again dude

Share this post


Link to post
Share on other sites

Did you have the game installed and then reinstall it?

No idea on a mac but it sounds kinda like it's actualy reading

a old ww2.xml from a prior install.

EDIT:

Hummm can you disable the 9400? I really got no clue as to macs.

Edited by OldZeke

Share this post


Link to post
Share on other sites
Lower refresh rate?

The only thing that has changed since I last played is I added another 4GB of ram to the computer and I updated the OS. I'm using a 24" Samsung flatscreen set to 1080p @ 60hz

Here's the xml I'm using:

<?xml version="1.0" encoding="UTF-8"?>

Share this post


Link to post
Share on other sites

value name="app.resolution" type="string" value="1920x1080x32x60”/

Cut out the x60, I think all you need is "1920x1080x32"

Share this post


Link to post
Share on other sites
value name="app.resolution" type="string" value="1920x1080x32x60”/

Cut out the x60, I think all you need is "1920x1080x32"

Just tried it... no luck either. Its like the game is reverting to straight default settings every time I load it. If I leave the xml file unlocked and read/write, it over-writes the file with a BRAND new xml from scratch, each time I open and close the game. Its like it's not even looking at the prefs file when its starting up and going in fresh with each instance of the game. Very weird

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.