Sign in to follow this  
Followers 0
buckly

ATI issues

70 posts in this topic

OK I just got a new card. Saved up got a 5850 and tracker IR5. First night the game ran great I even got an ace mission. But as others have said my ATI drivers dont respond only with this game. I have played many others but with in one minute in world of BE they stop responding. The game closes and they recover.

So does any one have any ideas, tech support has none. I saved up and bought the best I could afford so I could get better game play and now I cant play this game.

Edited by SOLOJE

Share this post


Link to post
Share on other sites
OK I just got a new card. Saved up got a 5850 and tracker IR5. First night the game ran great I even got an ace mission. But as others have said my ATI drivers dont respond only with this game. I have played many others but with in one minute in world of BE they stop responding. The game closes and they recover.

So does any one have any ideas, tech support has none. I saved up and bought the best I could afford so I could get better game play and now I cant play this game.

Might be a power supply problem or a over heating problem or just the bad ATI drivers.

Share this post


Link to post
Share on other sites

I was having the same problem but I could play for about 5-10 min then crash to desktop. I rolled back to the 9.7 drivers & no problems since.

Share this post


Link to post
Share on other sites

Same problem with my 2 PC equipped with ATI Radeon 5850.

Tested with 8.651 and 8.66RC Beta drivers. Doesn't change anything.

Sometimes I crash on spawn, sometimes few minutes later. Doesn't happen in offline mode (tested 3-4 times..)

Edited by messer1

Share this post


Link to post
Share on other sites
Might be a power supply problem or a over heating problem or just the bad ATI drivers.

Not over heating I checked my temps. Power supply brand new and more then enough. Not the card over heating this thing runs cold.

Seems it is the drivers. But the other games I play run better on the new drivers. Will try a few things in that link for the sticky. If not oh well, seems this problem has been around for a while and the rats just havent gotten to it yet.

Have sent ticket in to ATI and waiting to hear back from them

Share this post


Link to post
Share on other sites
Not over heating I checked my temps. Power supply brand new and more then enough. Not the card over heating this thing runs cold.

Same thing.

Corsair TX 650W power supply, and the card is very well cooled

Share this post


Link to post
Share on other sites

Seems it is the drivers. But the other games I play run better on the new drivers. Will try a few things in that link for the sticky. If not oh well, seems this problem has been around for a while and the rats just havent gotten to it yet.

Have sent ticket in to ATI and waiting to hear back from them

Good luck with the ticket for ATI. ATI's driver support both to consumers and game developers is rather horrible. Don't expect to hear anything back from them other than a scripted response.

ATI is just horrible for this game because of their drivers. For whatever reason their drivers just do not work with this game. I think the Rats have tried to address this issue but the support on the other end (ATI) is not that helpful.

Share this post


Link to post
Share on other sites

Buckly - I tried this - it cured my crashing problems, hope it helps.

Just downgraded ATI drivers.

Went from Catalyst 9.9 to Catalyst 9.0 and now have 0 issues.

Before change, was CTD'ing every 10 to 30 minites.

System Specs

Windows VISTA 64bit Ultimate (SP-2)

Intel Core i7 920 2.66ghz

ATI Radeon™ HD 4850 with 512MB memory

9 gig 1600 mhz ddr3 ram

Share this post


Link to post
Share on other sites

The 9.8 and 9.9 drivers make the game crash,9.8 is the worst of them.

I have no idea what driver that started to support the HD58XX series,I'm pretty sure it was either 9.9 or 9.8,so you're out of luck for the moment,I'm sorry.

I think the way CRS is handling this issue is real bad,2 months worth of drivers and only crashes and crashes,atleast the people with older ATI cards can roll back to 9.7.

Share this post


Link to post
Share on other sites

Radeon 58xx are supported with Catalyst 9.8 and 9.9 only (Drivers v. 8.651 or 8.66RC beta).

Tried with Catalyst 9.7 and the card isn't detected.

Buckly, ATI released new drivers for 57xx & 58xx yesterday. Try it, I'll do the same right now (8.660.6)

EDIT> Still having crash with new drivers :/

Edited by messer1

Share this post


Link to post
Share on other sites

The latest drivers were released yesterday (10/13).

http://support.amd.com/us/kbarticles/Pages/ATIRadeonHD5800seriesrecommendedgraphicsdriver.aspx

We don't have one of these graphics cards so we can't test it ourselves. We don't know what the problem is. It is having some problems with some other games.

If you can get a reproduceable crash offline using the non-SSE2 version, the crash logs (WW2_Log.txt in your \Documents\Battleground Europe\ folder), might help us.

Share this post


Link to post
Share on other sites
The latest drivers were released yesterday (10/13).

http://support.amd.com/us/kbarticles/Pages/ATIRadeonHD5800seriesrecommendedgraphicsdriver.aspx

We don't have one of these graphics cards so we can't test it ourselves. We don't know what the problem is. It is having some problems with some other games.

If you can get a reproduceable crash offline using the non-SSE2 version, the crash logs (WW2_Log.txt in your \Documents\Battleground Europe\ folder), might help us.

well get one of the cards...

ATI 5000 series is ONLY going to BE the VIDEO CARDS that ALL GAMERS are going to strive to get being the FASTEST video cards out there....like the 5870

the 5850 is like only what maybe $250? don't any of you rats need to upgrade your systems yet? seems to me getting a 5870 would be an obvious upgrade path.

btw...I need a new computer. So obviously I'm thinking of going ATI since it seems that NV is going out of the high end video card bus by all reports so far.

Edited by Vampress

Share this post


Link to post
Share on other sites
The latest drivers were released yesterday (10/13).

http://support.amd.com/us/kbarticles/Pages/ATIRadeonHD5800seriesrecommendedgraphicsdriver.aspx

We don't have one of these graphics cards so we can't test it ourselves. We don't know what the problem is. It is having some problems with some other games.

If you can get a reproduceable crash offline using the non-SSE2 version, the crash logs (WW2_Log.txt in your \Documents\Battleground Europe\ folder), might help us.

I will see if it will crash off line, but it hasn't yet. But that could just be my "luck". Every other game I play the card just rocks them and with my system I can play all at high setting if not very high and it rips them up.

Oh I sent a ticket to gigabyte who makes the card not to ATI, and I am still waiting to hear back from them. Looked for a place to send a ticket to ATI and couldn't find a link.

This just stinks though. After 1yr and 9mnths of flying I get a Ace mission the 1st night with this card. Next night it won't play, I upgrade the driver and it still wouldn't play.

Oh well I guess maybe I will get to see how sweet 1.32 is. Hopefully it will work by then.

Buckly signing out

Share this post


Link to post
Share on other sites
I will see if it will crash off line, but it hasn't yet. But that could just be my "luck". Every other game I play the card just rocks them and with my system I can play all at high setting if not very high and it rips them up.

Oh I sent a ticket to gigabyte who makes the card not to ATI, and I am still waiting to hear back from them. Looked for a place to send a ticket to ATI and couldn't find a link.

This just stinks though. After 1yr and 9mnths of flying I get a Ace mission the 1st night with this card. Next night it won't play, I upgrade the driver and it still wouldn't play.

Oh well I guess maybe I will get to see how sweet 1.32 is. Hopefully it will work by then.

Buckly signing out

Brand new video cards and brand new Operating Systems is a recipe for problems and delays. The 5800 cards are having some problems with other games, such as the huge mouse cursor issue for many in WoW.

Share this post


Link to post
Share on other sites
Brand new video cards and brand new Operating Systems is a recipe for problems and delays. The 5800 cards are having some problems with other games' date=' such as the huge mouse cursor issue for many in WoW.[/quote']

WoW has no issues for me, nor Dawn of War 2, EVE Online, Aion, or Left 4 Dead. WW2OL is the only game to have trouble with 5800 atm.

Hope this will be fixed soon.

Share this post


Link to post
Share on other sites
WoW has no issues for me, nor Dawn of War 2, EVE Online, Aion, or Left 4 Dead. WW2OL is the only game to have trouble with 5800 atm.

Hope this will be fixed soon.

I'm sure ATI will issue a patch right away.

Share this post


Link to post
Share on other sites

I'm having several problems with CTDs and other bugs using windows 7 :\

and yeah, only on ww2online.... other games go flawless

my system is

amd phenom II x3 720 black edition @OC 3.2ghz

4gb ddr3

ati 4870

i will try to downgrade the driver to see if it fixs

Share this post


Link to post
Share on other sites
Good luck with the ticket for ATI. ATI's driver support both to consumers and game developers is rather horrible. Don't expect to hear anything back from them other than a scripted response.

ATI is just horrible for this game because of their drivers. For whatever reason their drivers just do not work with this game. I think the Rats have tried to address this issue but the support on the other end (ATI) is not that helpful.

Running 2 ATI Powercolor HD4850 512mb cards in Crossfire mode. I was

having a problem with the earlier drivers and running anti-aliasing in game so I rolled back to 8.10 version; had no problems after rollback. I

recently remove the old drivers and CC and installed 9.7 version and am

having no problems atm.

For me certain drivers are working when I use anti-aliasing and most ATI

drivers are working when I don't use anti-aliasing.

I do like the ATI HD 4850 512mb cards and the driver problems arn't an

issue for me now.

I'd like to update to the 4870's but money is tight and bigger monitor

is more of a priority.

GL

Share this post


Link to post
Share on other sites

I hope that issue will be fixed soon, i'm planning to get a 5850 too (as many ppls i think, coz it's a very good card for price/performance)...

Share this post


Link to post
Share on other sites
Brand new video cards and brand new Operating Systems is a recipe for problems and delays. The 5800 cards are having some problems with other games' date=' such as the huge mouse cursor issue for many in WoW.[/quote']

Didnt know Vista 64 was new.

Yeah I play all the games listed except WOW, and none of them have any issues with my card, lol. But I know it is the cards fault and/ or the drivers. Funny it worked the first night and then hasn't worked since. Even rolled back the drivers and still didn't work.

But thanks to all those of you who tried to help, and even to those of you who blamed the card/drivers *cough, cough, rats, cough*

Always good to hear people blame others because of faults with their products. Cause when the search works you can find posts about ATI cards and this game for a long time. Like I said maybe I will get to play 1.32 or if the rats want to make a list of cards and drivers that work with their software maybe I can save up and play.

I know the rats are under staffed but I am not feeling the love any more. It's like when you have been dating for a while and she doesn't want to do things and has excuses why it's not her fault.

Share this post


Link to post
Share on other sites
WoW has no issues for me, nor Dawn of War 2, EVE Online, Aion, or Left 4 Dead. WW2OL is the only game to have trouble with 5800 atm.

Hope this will be fixed soon.

I have tested about 20 games. ww2 online only game with problems.

5870 card with 9.10 drivers. Dow2, wolfenstein, nfs shift, fallout3, crysis for example worked fine. Weird thing is that 9.10 drivers worked just fine with 4870.

http://forums.battlegroundeurope.com/showthread.php?t=297391

Share this post


Link to post
Share on other sites
Brand new video cards and brand new Operating Systems is a recipe for problems and delays. The 5800 cards are having some problems with other games' date=' such as the huge mouse cursor issue for many in WoW.[/quote']

go buy an old 4870 and test it with Catalyst 9.10 pls

same problems with O L D 4870

CTD after 5-15mins with Catalyst 9.8 Catalyst 9.9 Catalyst 9.10

nothing new, since months...

but now new ati cards works only with 9.10

Edited by errah

Share this post


Link to post
Share on other sites
go buy an old 4870 and test it with Catalyst 9.10 pls

same problems with O L D 4870

CTD after 5-15mins with Catalyst 9.8 Catalyst 9.9 Catalyst 9.10

nothing new, since months...

but now new ati cards works only with 9.10

4870 and 9.10 worked just fine for me. This 5000 series problem seems to be for everyone!

Share this post


Link to post
Share on other sites

The 4870 issue is causing random crashes,so sometimes it can take long until it crashes,sometimes about 15 mins..

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.