Sign in to follow this  
Followers 0
mac495

Well I see not much has changed

11 posts in this topic

Auto updater gives me a "playarc not valid" or something error...

You know I just resubbed from about a year off, and if the frikken auto update hangs,can't wait to see what the game runs like......

Well I guess I'm glad that my harddrive still works.....

Somethings never change

Share this post


Link to post
Share on other sites

Regardles of what these fanboys might tell you, the game is still borked even after doing full install, full unistall, full install repeatedly. Granted its not the playarc file anymore, its just the bloody piece of **** won't launch. And I'm not the only one having this issue. I can see why they make you pay before you can start to patch :rolleyes:

Share this post


Link to post
Share on other sites
Regardles of what these fanboys might tell you' date=' the game is still borked even after doing full install, full unistall, full install repeatedly. Granted its not the playarc file anymore, its just the bloody piece of **** won't launch. And I'm not the only one having this issue. I can see why they make you pay before you can start to patch :rolleyes:[/quote']

they probalby still have the free trials...

you could have used one of those and patched for free to see if it worked on your system

Share this post


Link to post
Share on other sites

You can't patch any version of the game prior to the current playgate we now have.

Do a full uninstall and download and install the full version of the current patch.

If that doesn't work then it's something on your end.

Share this post


Link to post
Share on other sites
Regardles of what these fanboys might tell you' date=' the game is still borked even after doing full install, full unistall, full install repeatedly. Granted its not the playarc file anymore, its just the bloody piece of **** won't launch. And I'm not the only one having this issue. I can see why they make you pay before you can start to patch :rolleyes:[/quote']

Most players can launch the game with no problem. If the game doesn't launch for you, one of the following is probably at fault:

1. Your drivers are out of date. Update your video and sound drivers to the most recent release (use the Catalyst 9.7 drivers if you have an ATI video card).

2. Your hardware doesn't meet the recommended system specs.

Share this post


Link to post
Share on other sites
Regardles of what these fanboys might tell you' date=' the game is still borked even after doing full install, full unistall, full install repeatedly. Granted its not the playarc file anymore, its just the bloody piece of **** won't launch. And I'm not the only one having this issue. I can see why they make you pay before you can start to patch :rolleyes:[/quote']

They don't make you pay before you can patch. You can download the full exe right on the web page under "Getting Started".

Share this post


Link to post
Share on other sites
Regardles of what these fanboys might tell you' date=' the game is still borked even after doing full install, full unistall, full install repeatedly. Granted its not the playarc file anymore, its just the bloody piece of **** won't launch. And I'm not the only one having this issue. I can see why they make you pay before you can start to patch :rolleyes:[/quote']

Well considering everyone else can launch the game just fine, do you suppose it might be something your end? :rolleyes:

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.