Sign in to follow this  
Followers 0
stalg

FPS Fix... my framerate went from 10-25 to 40-100!

36 posts in this topic

In a separate thread, Munchkin mentioned that accidentally running the game in the wrong compatibility mode dropped his fps.

Fix:

Right-click on the game's .exe-icon, select Properties, select Compatibility, and make sure you are not running Compatibilty for the incorrect operating system. (or deselect compatibility completely and see what happens).

Thanks Munchkin, You saved my playability! :D

This fix made my FPS go from unplayable 8-25fps to 40-100fps!

I was running Vista compatibility mode on Windows 7...lol.

CRS should sticky this fix!!!!

S!

Share this post


Link to post
Share on other sites

A controlled test reveals that there is absolutely no difference.

Also how could there be any? There is no significant difference in performance between the CRTs in the first place. And then the CRT contributes only to a tiny fraction of a frame time.

Edited by jaeger

Share this post


Link to post
Share on other sites

A controlled test? With what?

Having the game set to vista sp2 compatibility hurt my performance a bunch, so I brought it up when I noticed that I almost doubled my framerates after removing it. Then another player experience the same thing.

Hows that for a controlled test?

Share this post


Link to post
Share on other sites
A controlled test? With what?
Identical test scenes.
Having the game set to vista sp2 compatibility hurt my performance a bunch, so I brought it up when I noticed that I almost doubled my framerates after removing it. Then another player experience the same thing.

Hows that for a controlled test?

The problem is that you cannot make comparisons online because the scenes differ so much.

And regarding your impressions: http://en.wikipedia.org/wiki/Placebo

Sorry, but the problem is that the mass of "tweaks" that people are trying area potential cause for problems. So things like this have to be proven with measurements before it can be advised to others.

Share this post


Link to post
Share on other sites

Well, I don't know about your test.

I'm referring to offline testing to begin with. Same places, same settings. Only difference is the compatibility setting.

But I don't know, perhaps I was dreaming?

Share this post


Link to post
Share on other sites

Well thats my theory also.

I removed compatibility mode and ran both playgate and ww2.exe as admin.

I had been testing in various scenarios and my fps was low but my graphics card never really went above 30% of use. It seemed bottlenecked. I had already took vsync off with no real difference

I changed this and my GPU now often runs at 60% +. My fps seems to be up a bit and things are running better.

I have a memory / bad allocation error when running my Asus Sound card under hardware mdoe. Every day since sunday it failed to not crash on me until I made these changes and are now about 30 hours in and a fair few missions with no such problem.

It makes little sense that this has anything to do with the two issues above but.........

It seems to be the case.

Share this post


Link to post
Share on other sites
Well, I don't know about your test.

I'm referring to offline testing to begin with. Same places, same settings. Only difference is the compatibility setting.

But I don't know, perhaps I was dreaming?

Yes. Definitely.

The CRTs do not differ in performance and the CRT has almost no impact on the games frame time.

It is simply not possible.

Share this post


Link to post
Share on other sites
Yes. Definitely.

The CRTs do not differ in performance and the CRT has almost no impact on the games frame time.

It is simply not possible.

Well, then I don't know how the heck I suddenly got a lot higher framerates in offline testing by removing the settings in the exes.

I know I did, possible or not. I have no explanation as to what causes it.

Share this post


Link to post
Share on other sites
A controlled test reveals that there is absolutely no difference.

Also how could there be any? There is no significant difference in performance between the CRTs in the first place. And then the CRT contributes only to a tiny fraction of a frame time.

Jaeger,

All I know is that I have been playing the game since 1.31 release with 7-25fps everywhere I went. Any battle in towns were under 25fps every time. My fps never got above 35.

I changed the compatibility mode from "Vista compatibility" to "no compatibility" on my Windows 7 system and instantly got 40+ fps even in towns with heavy action, and up to 100fps.

I made no other changes to my system of the game settings.

I'm a long-time player, and I know how to compare system performance fairly well. This was no slight improvement...it was a radical change for the better.

S!

Share this post


Link to post
Share on other sites
Jaeger,

All I know is that I have been playing the game since 1.31 release with 7-25fps everywhere I went. Any battle in towns were under 25fps every time. My fps never got above 35.

I changed the compatibility mode from "Vista compatibility" to "no compatibility" on my Windows 7 system and instantly got 40+ fps even in towns with heavy action, and up to 100fps.

I made no other changes to my system of the game settings.

I'm a long-time player, and I know how to compare system performance fairly well. This was no slight improvement...it was a radical change for the better.

S!

Sorry to break it to you

You dreamt it

Share this post


Link to post
Share on other sites
Sorry to break it to you

You dreamt it

Well if that's the case is was a good dream... a Really, Really good dream :D

Share this post


Link to post
Share on other sites
Well thats my theory also.

I removed compatibility mode and ran both playgate and ww2.exe as admin.

I had been testing in various scenarios and my fps was low but my graphics card never really went above 30% of use. It seemed bottlenecked. I had already took vsync off with no real difference

I changed this and my GPU now often runs at 60% +. My fps seems to be up a bit and things are running better.

I have a memory / bad allocation error when running my Asus Sound card under hardware mdoe. Every day since sunday it failed to not crash on me until I made these changes and are now about 30 hours in and a fair few missions with no such problem.

It makes little sense that this has anything to do with the two issues above but.........

It seems to be the case.

I'm gonna try this out as well, what the hell, can't hurt nothing. Besides, i've seen & read quite a few of Badger77 posts, and usually the man knows what he's talking about, so if he's done it & noticed a difference i'm gonna take the mans word & try it myself. Again, what can it hurt to just try it out & see, mite be worth it & then again mite not???

Edited by gman13

Share this post


Link to post
Share on other sites
In a separate thread, Munchkin mentioned that accidentally running the game in the wrong compatibility mode dropped his fps.

Fix:

Right-click on the game's .exe-icon, select Properties, select Compatibility, and make sure you are not running Compatibilty for the incorrect operating system. (or deselect compatibility completely and see what happens).

Thanks Munchkin, You saved my playability! :D

This fix made my FPS go from unplayable 8-25fps to 40-100fps!

I was running Vista compatibility mode on Windows 7...lol.

CRS should sticky this fix!!!!

S!

You are running windows service pack 2 for Vista?

Share this post


Link to post
Share on other sites
Does everyone use Win7-64?

Yes I do, and I have a brand new system with plenty of power and my fps should be higher I thought.

That said, I was told to run the game in vista sp2 and run as admin.

So what do I do now?

Share this post


Link to post
Share on other sites

1.30 you needed to run in compatibility mode. 1.31 you don't so switch if off for the two CRS exe files in your directory. They are playgate and wwiiol I believe. Also you don't have to run as admin either. It should just work like all your other programs.

Share this post


Link to post
Share on other sites

Thanks Gman - Yeah FPS hasn't made huge difference but it does feel better and for a fact is using up more of my GPU now.

The main reason it has helped me is with an odd crash I was getting which is somehow due to my Asus Xonar D2X when selecting hardware. I couldn't spawn more than 1 - 3 times without crashing.

Now I've spawned many more times over a 30 hr period without one crash.

This was before the new patch.

I also played the new patch last night a little without any issues.

As you say it cannot hurt and I think everyone should take compatibility off on Windows 7 64 bit (and 32) as it's not required anymore.

All I can say is I did crash now I don't.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.