• Announcements

    • HEAVY265

      Attention Soldiers Operation Fury Needs you!   02/20/2020

      Attention All Soldiers, Operation Fury needs you.  You need to choose a side and sign up.  
      For more intel on Operation Fury Please click HERE Please go to Special Event Forum (here), And sign up for allied or axis.
      This will be a CRS Lead event on both sides.  Xoom will be heading up the axis side and Heavy265 will be heading up the Allied side. This will be for bragging rights.
      Why are we asking players to sign up you ask. We are trying for a role play experience.   We want this to be a true realistic event.  
      So get up and sign up and let's make this the best event ever!!!!!!!!!!
      Give me your war cry, grrrrrrrrrrrrr
      Heavy265 **out**
Sign in to follow this  
Followers 0
chinchy

Bad FPS in big battles!

9 posts in this topic

So I have A decent system and have absolutely no idea why I get fps lag in this game here are my specs. (If I need to change something to make it run better i will)

intel® Core2 Quad CPU Q9300 @2.5GHz 2.50GHz

Ram 8.00GB DDR3

64bit Vista

Radeon HD 5770

Any thoughts on the matter? Is it possible to make the game run multi core?

Edited by sweenie

Share this post


Link to post
Share on other sites

Better systems than yours will start to slow down in huge battles once it gets to the final AB push with loads going on, smoke bombs and 100+ people.

How bad is bad ??

I slow down to about 21 - 22 fps and that gets really sluggish and not that nice to play. 25 fps and above is fine and still smooth.

Of course first thing to make sure is you have latest chipset drivers for your mobo and latest drivers for card. Thats a good start.

Share this post


Link to post
Share on other sites

I have all the latest updates for my cards and hardware and I drop to 15fps on most town battles I find it quite annoying I made sure none of my hardware was a bottle neck and they arn't there basically all at the same level. So I cant really fix anything there I was just wondering why I can run normal games throw 400 bots into a server I made and have no lag issues at all but a game with... Sub Par graphics I get more than 50 people on my screen and i drop to about 15fps and to me that feels unplayable. :/

Share this post


Link to post
Share on other sites

Suggest looking at your settings for shadows, and all the visual extras and visibility limit. Start low and work up to what you like and still have FPS

A reduction in heavy battles is normal for game as other poster suggested, it's just finding a rate that is acceptable with visual level you don't mind living with also.

Share this post


Link to post
Share on other sites

It seems as if big battle FPS is worse with the latest patch (1.31.5) than before. Offline FPS is still about the same (a bit over 50 in .benchremagen), but I hit 15 FPS and below in almost every fight now, whereas in the previous patch (1.31.4) that just happened when things were really hectic.

Share this post


Link to post
Share on other sites

bumping your processor speed up past 3.0Ghz would help a lot. I'm running at 3.7Ghz at the moment (Phenom II X4 955) and can hardly complain about my fps. but i wouldn't recommend doing that unless you know what your doing. I've got a 5770 as well. (1011Mhz/1275Mhz)

The game is multi-core but not in the way you think. it'll only use 1/4 of your processing speed at any given time, bring up performance monitor in 7 and you'll see on a quad core it'll peak at 25% average usage. So a increase in your clock speed will boost performance extremely.

Bascially the game is creating its own bottle neck with the lack of true multi core capability, all new games are multi core enabled, as well as most older ones going back into the dual core days (2005~06?) and i think CRS has said they are "working on it" but who knows.

Really does hurt performance though, I'll dip into the 28's in big battles when i know if i had all my processing capability i'd probably wouldn't dip under 40 at all.

Share this post


Link to post
Share on other sites

If the game could be made truly multithreading and fully make use of all cores I'd scrap this quad core of mine and get a 12 core opteron instead. At least the sexa core Phenom.. The performance should shoot through the roof, even with a quad.

To that, added support for multiple GPU's and OpenCL for Physics and then this game would become a whole different cookie to play around with! )

Share this post


Link to post
Share on other sites

Like Indo said, bump up your cpu speed

make sure

-shadows are set to low

-radial clutter density & radius are set low

Share this post


Link to post
Share on other sites
It seems as if big battle FPS is worse with the latest patch (1.31.5) than before. Offline FPS is still about the same (a bit over 50 in .benchremagen)' date=' but I hit 15 FPS and below in almost every fight now, whereas in the previous patch (1.31.4) that just happened when things were [i']really hectic.

It seems this way for me as well, was doing better b4 previous patch, now in the bigger battles it seems as if i'm a lil more sluggish, where as i never seemed to expierience this prior to last patch, odd????

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.