• Announcements

    • CHIMM

      Operation Burning Skies   09/17/2019

      All pilots scramble!  Strap yourself in for this months Community event - Operation Burning Skies! This Sunday, September 22, 11 am – 5 pm server time. In honor of XOOM and friends showcasing WWII Online at the Oregon International  Air Show – our forces too will battle for superiority in Operation Burning Skies. High Commands are on high alert to rally their forces to victory! Lift off, and see a whole new world of WWII Online… Fearless bomber pilots make the skies rain down fire – our daring fighter pilots are in pursuit of their prey- as western Europe erupts in war on the ground below! Rally your squads, rally your buddies - Combined arms are back!  …Under Burning Skies! SALUTE!
Sign in to follow this  
Followers 0
AHWULF

Anyone have problems with game recognizing joystick?

34 posts in this topic

Either:

(1) every time you launch game the joystick doesn't appear in the menu in the launcher settings.

or

(2) if you go AFK for a while you come back and the joystick seems to be disconnected.

Share this post


Link to post
Share on other sites

Everytime I enter the game I have to "detect controllers" b4 it recognizes my JS. Been like that for a very long time. I have a Thrustmaster twist stick...

Geez that sounds so bad.

Share this post


Link to post
Share on other sites

Only problem I have noticed is first time I use the joystick it always pulls right continuously. Once I spawn out and back in the problem goes away.

Share this post


Link to post
Share on other sites

I have the same issue. need to "detect controllers" each time I start the game.

Model Name: iMac

Model Identifier: iMac11,1

Processor Name: Intel Core i5

Processor Speed: 2.66 GHz

Number Of Processors: 1

Total Number Of Cores: 4

L2 Cache (per core): 256 KB

L3 Cache: 8 MB

Memory: 4 GB

Share this post


Link to post
Share on other sites

First time I heard of detect controllers from sparre today, next time let me know :-)

Are you both on 10.6? (delems issue is probably unrelated).

Share this post


Link to post
Share on other sites

Rick's original code for the joystick was in the 10.4 days, that code is now deprecated under 10.6 (but still works since we compile against 10.5). I'm hoping its not that.

Share this post


Link to post
Share on other sites

OK for those having to find the controller before launching. Do this:

run /Applications/Utilities/Terminal

enter: defaults find joy1

save the output

enter: defaults read com.playnet.ww2ol

save the output

now do:

defaults delete com.playnet.ww2ol

then

defaults delete com.playnet.ww2ol-beta

then launch the game, pick your controller, spawn in once, then despawn and exit the game (do not use command-Q)

in terminal: defaults read com.playnet.ww2ol

save the output

then launch the game, pick your controller if necessary, spawn in once, then despawn and exit the game (do not use command-Q)

in terminal: defaults read com.playnet.ww2ol

save the output

now email me all the outputs at ahwulf at playnet.com

Since I can't duplicate the problem, I'm hoping this will help. My guess is its reading the joystick ID from one place and writing it to different place.

Share this post


Link to post
Share on other sites
First time I heard of detect controllers from sparre today, next time let me know :-)

Are you both on 10.6? (delems issue is probably unrelated).

OS 10.6.4

Model Name: iMac

Model Identifier: iMac11,1

Processor Name: Intel Core i7

Processor Speed: 2.8 GHz

Number Of Processors: 1

Total Number Of Cores: 4

L2 Cache (per core): 256 KB

L3 Cache: 8 MB

Memory: 8 GB

Processor Interconnect Speed: 4.8 GT/s

Boot ROM Version: IM111.0034.B02

SMC Version (system): 1.54f36

Serial Number (system): QP0121DE5RU

Hardware UUID: 290BB093-468A-56BA-9EE6-D4ADD1ED817A

Share this post


Link to post
Share on other sites

I got the first issue back again today Ahwulf.

Couldn't "detect" the controls when spawned in. Had to despawn, detect the controls, and then spawn in to get the JS to work.

A real pain in the butt when Spawn delay is in effect. :(

Share this post


Link to post
Share on other sites

I realized I have no idea what Detect Controllers does, so I've asked RAMP to point me to what code is being called there. I've never used that button.

Edited by AHWULF

Share this post


Link to post
Share on other sites

OK I now know what code is being called. It's a little bizarre - needs serious head scratching to understand why it works at all.

Share this post


Link to post
Share on other sites

From what I can see Detect Controllers should do nothing on Mac. Yet it does. What I get paid doesn't pay for the Aleve lol.

Share this post


Link to post
Share on other sites

I've noticed that when, total speculation based on a few instances, I have my mission set as Geel, my stick gets delayed. Has happened twice so far.

Share this post


Link to post
Share on other sites

The last few days been worse then ever.

From time to time hasn't it even help to "detect the controls". Only solution then is to restart the game and then detect the controls to get the JS to work.

Share this post


Link to post
Share on other sites

Still no clue why this happens. One thing I am not sure about - when you run the launcher and go to settings, does the joystick appear in the menu? If it appears then when you get into the game does it not work and you have to detect?

Share this post


Link to post
Share on other sites

every once in a while, no pattern I can find, the game switches to "No stick".

I go Keymapper and put is on Stick.

It may be possible my stick was not connected and it defaulted to "no stick". Will try one day.

Share this post


Link to post
Share on other sites

When I updated to 1.32.2.255 the updater would not let me update the WWIIOL app in my applications folder. I downloaded the full installer and installed in my home directory as recommended by the installer. Since then I have not been able to get my stick properly calibrated. I use the calibration utility but when I log into the game the stick sits at rest slightly right. No matter where I position the parameter sliders moving the stick to the right makes a smooth transition, but once I go past about 15 degrees to the left the stick jumps to full left aileron.

Model Name: iMac

Model Identifier: iMac8,1

Processor Name: Intel Core 2 Duo

Processor Speed: 2.66 GHz

Number Of Processors: 1

Total Number Of Cores: 2

L2 Cache: 6 MB

Memory: 2 GB

OSX 10.5.8

Saitek X52

Edited by shy

Share this post


Link to post
Share on other sites

run /Applications/Utilities/Terminal

now enter:

defaults find com.playnet

copy the result and send it to me

you should be able to enter

defaults delete com.playnet.ww2ol

then enter

defaults delete com.playnet.ww2ol-beta

to clear out the defaults for the joystick

another thing is download

http://alphaomega.software.free.fr/joystickandgamepadtester/Joystick%20And%20Gamepad%20Tester.html

and make sure your joystick values look OK

It's possible that you will need to log in with an admin password account in order to clear out the defaults for the old app. If you are using a non-admin account (which is why you had to install in your user directory) then you can't modify the defaults (which would explain why you can't change the values). Once you can remove the old defaults, you should be able to create them with your non-admin account and be OK.

I intend shortly to eliminate the defaults stuff (another vestige from the past) and just use a prefs file.

Edited by AHWULF

Share this post


Link to post
Share on other sites

I would up de-selecting my joystick and rudders and reversing the order and calibrating. Nothing changed. I de-selected them again and put them back in the original order and now they seem to be working.

Share this post


Link to post
Share on other sites

I have a Saitek Evo and it doesn't work with planes or tanks for turning, hat switch views or x/y z axes. Throttle doesn't work or get recognized

PUt in a ticket, not response from HQ. I tested the stick on joystick tester and all buttons and stick and throttle register.

Kind of impossible to use planes in WWII online

Share this post


Link to post
Share on other sites

Got an saitec evo also, the game will not find it.

I have put it in stick mode for the airoplanes, and i have made the game try to recognise the stikk. Still it will not work.

Have also tried to turn off the saitec software, did not hjelp.

It works fine i other games and in Windows.

I use win 7 64 bit if thats is important.

If i Cant Get it to work will in the trial i wil probably not buy the game

Share this post


Link to post
Share on other sites
First time I heard of detect controllers from sparre today, next time let me know :-)

Are you both on 10.6? (delems issue is probably unrelated).

I am on 10.10.5 and when ever I go to save my settings my game crashes

down to desktop--The people that I bought my computer from researched

this and they have a cure for pc but no cure for mac--I can not play the game as i can't save my settings in any thing--no fun at all almost feel like asking for a refund--really frustrating.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.