Sign in to follow this  
Followers 0
sargefry

Sound Issue, please help!

13 posts in this topic

Gents,

Haven't played since '05 or so. Decided to come back and I cannot get my sound to work properly. the birds, running, guns, etc. all sound fine but the tank engines almost blow my speakers they are so loud and distorted. I have a Creative X-Fi and could really use some advice. I have tried all 3 sound options (Primary, X-Fi Speakers and X-Fi SPDIF) to no avail.

Thanks,

Sarge

Share this post


Link to post
Share on other sites

Add the game in creative alchemy .. it helped for me.

Just enter the pad like this C:\Program Files (x86)\CRS\Battleground Europe

Edited by kalegek

Share this post


Link to post
Share on other sites
Add the game in creative alchemy .. it helped for me.

Just enter the pad like this C:\Program Files (x86)\CRS\Battleground Europe

Dont get it! Could you please explain more. Since 1.33 my creative sounds terrible

Share this post


Link to post
Share on other sites
Dont get it! Could you please explain more. Since 1.33 my creative sounds terrible

First install creative alchemy.

Then startup alchemy

Add this game to the game list with your install path .. That`s it.

Share this post


Link to post
Share on other sites
First install creative alchemy.

Then startup alchemy

Add this game to the game list with your install path .. That`s it.

I did this, and initially it worked "somewhat", although i was still getting some distortion when spawning in at AB with a panzer or atg (but then after a min or two it would subside). Game worked initially after installing the correct version for my soundblaster audigy 4, but when i booted up puter later in the evening to play ww2online i got a runtime error (something about CRT-could not inialize) my game wouldn't load. So after doing some reading up & researching about this come to realize that to fix this was not gonna seemingly be an easy task. So long story short, i uninstalled alchemy & all was well once again.

Share this post


Link to post
Share on other sites
First install creative alchemy.

Then startup alchemy

Add this game to the game list with your install path .. That`s it.

OK, read little about this program. It is for VISTA only user as far as I can see. I am still on XP 32 bit here.

Share this post


Link to post
Share on other sites
First install creative alchemy.

Then startup alchemy

Add this game to the game list with your install path .. That`s it.

OK, i'm desperate to properly fix & get my overall TOTAL sounds working again. Now i have spent the last cpl hrs using the search feature & reading up on the sound problems & "reported fixes" (since 1.33's inception) & have tried EVERYONE OF THEM to no avail. Now heres the problem, i have sound out of my logitech G35 headset but i have been suffering (JUST LIKE ALOT OF OTHER PEOPLE) to the point where i'm hearing sounds "but not all of them". Now 1st & foremost, my surround sound headset works FLAWLESSLY WITH ANY OTHER GAME "except ww2online". Examples: no ei footsteps when there right next to you, no sap charge audio when charges are placed, when driving a tank outta a AB it's extremely load & full of bass (very distorsted) This has all been going on since 1.33 when they changed the audio engine. Now another question, i did try this creative alchemy program once before (as you can prob tell from my previous post) & it didn't seem to work for me? Now my question is, do you not only place your install/game path directory to "Use Game Path" BUT do you also have to tick on the box to "Install Into Subfolder" ALSO??? Maybe i did something wrong the first time???

Share this post


Link to post
Share on other sites
OK' date=' i'm desperate to properly fix & get my overall TOTAL sounds working again. Now i have spent the last cpl hrs using the search feature & reading up on the sound problems & "reported fixes" (since 1.33's inception) & have tried EVERYONE OF THEM to no avail. Now heres the problem, i have sound out of my logitech G35 headset but i have been suffering (JUST LIKE ALOT OF OTHER PEOPLE) to the point where i'm hearing sounds "but not all of them". Now 1st & foremost, my surround sound headset works FLAWLESSLY WITH ANY OTHER GAME "except ww2online". Examples: no ei footsteps when there right next to you, no sap charge audio when charges are placed, when driving a tank outta a AB it's extremely load & full of bass (very distorsted) This has all been going on since 1.33 when they changed the audio engine. Now another question, i did try this creative alchemy program once before (as you can prob tell from my previous post) & it didn't seem to work for me? Now my question is, do you not only place your install/game path directory to "Use Game Path" BUT do you also have to tick on the box to "Install Into Subfolder" ALSO??? Maybe i did something wrong the first time???[/quote']

32 sound maximum.

other games usually won't spit out more then 24 "voices" simultaneously unless it has extended features or other wise specifies hardware audio can be used, then it'll render out the maximum voices your hardware supports. Which on your G35 is 32 voices (its usb, and has its own audio card built in if i'm thinking of the headset your using, also has a bunch of buttons on the side)

So when more then 32 shoot at once, or run or tanks planes blah blah blah, stuff starts to not get rendered and you won't hear your rifle pop or SMG shoot, or you'll miss that infantry running in.

5.1 headset with the quadruple 1/8th inch audio jacks are the way to go, because they use the hardwares sound card, and not a cheaper internal audio card.

Share this post


Link to post
Share on other sites

last patch completely screwed my audios...

I think the change they made to the audio engine isnt working well with everything at all.

Personally, I have an integrated card, always had superb audios untill now :#

Share this post


Link to post
Share on other sites
32 sound maximum.

other games usually won't spit out more then 24 "voices" simultaneously unless it has extended features or other wise specifies hardware audio can be used, then it'll render out the maximum voices your hardware supports. Which on your G35 is 32 voices (its usb, and has its own audio card built in if i'm thinking of the headset your using, also has a bunch of buttons on the side)

So when more then 32 shoot at once, or run or tanks planes blah blah blah, stuff starts to not get rendered and you won't hear your rifle pop or SMG shoot, or you'll miss that infantry running in.

5.1 headset with the quadruple 1/8th inch audio jacks are the way to go, because they use the hardwares sound card, and not a cheaper internal audio card.

Well again, my sounds were A: Fine until 1.33 was introduced & B: My sounds are fine with any other game (and i play alot of em, mostly shooters) so you tell me??? Wonder if i uninstall the G35's software & try to set the headset up to run off my soundblaster audigy 4???

Share this post


Link to post
Share on other sites
Well again' date=' my sounds were A: Fine until 1.33 was introduced & B: My sounds are fine with any other game (and i play alot of em, mostly shooters) so you tell me??? Wonder if i uninstall the G35's software & try to set the headset up to run off my soundblaster audigy 4???[/quote']

my audios sort of borked to since 1.33 i know they switched audio engines.

but

Won't work since the headset uses its own Audio processor, and not another one.

Its basically a headset with a Realtek AC 97 engine/codec in it.

I'll get exactly the same issue your having if i use my Realtek HD onboard audio instead of my Azuentec-Prelude

Realtek HD = 32 maximum voices (non HD is 16 voices)

While the prelude can muster up a massive 128+128 voices thanks to its dual audio engines and integrated 64MB DDR memory. and i'll never miss a pistol pop or axis footstep.

my realtek plays other games just fine as well, but they are (the games) usually on a 24 voice limit and have "priorities" on what you'll hear first. so you don't get those blank spots in your sound like you would in ww2ol

play l4d2 and you'll hear zombie voices cut out whenever someone says "grabbin pills!!" or "shotgun here!!" but unlike ww2ol, it won't cut "grabbin pills!" off to render out zombie horde sounds.

it sucks i know it does, but i'd think your only solution is a new headset unless the G35 has the quaruple 1/8th headphone jacks and a pass through option

Depending on your sound blaster, the SE version supports 64 sounds, LS version 32 sounds and the platinum(pro) supporting 128 voices

Edited by indo420

Share this post


Link to post
Share on other sites

The bionic ears fix broke the game for me. Cannot hear where even the closest tank is since every is in stereo and at the same amplitude.

Strange thing though, when I fly, the engine sound is very low and if I go max throttle, the engine actually goes silent.

My subscription come up in a few days and until the sound issue gets fixed I will not be re-subscribing.

Edited by denisd

Share this post


Link to post
Share on other sites

same here without 3d positional audio the game just isnt the same for ground troops. it was and still is a very important feature and needs to be fixed

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.