Sign in to follow this  
Followers 0
marcus33

1.34 requires 10.6 ??

6 posts in this topic

get a windows :D

Only thing that would solve would be me being used to have headaches backing up stuff and installing countless updates ;)

Share this post


Link to post
Share on other sites

Mostly graphics stuff in the OS changing. At least that's what I gathered from Wulf's post.

And windoze crashes, mac's don't. So suck it suggs! muahaha

Share this post


Link to post
Share on other sites

Yes we had to use an opengl feature that is not implemented in 10.5 and there is no way around it. Generally support for OSs is limited to the current one and the prior one.

If we could we would switch to pure opengl 3.x which is only supported on 10.7 but that's not happening due to China requirements. Apple's opengl implementation has always be behind the times (you can get opengl 4.2 now on PCs with most video cards) due to it being used everywhere in the UI (whereas on Windows it's only for gaming/3d not the OS). The newer opengl versions let the application take better advantage of the video hardware. So in this case we were lucky this one feature we needed was in 10.6, on PCs it's been around for a long time.

I wish I could get a link to Apple's demo of opengl 3.x support in Lion, what on the 10.6 opengl got 2fps and took thousands of api calls was done at 60fps in one call (showing Saturn like planet surrounded by a ring made up of 100,000's of small tumbling rocks).

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.