Sign in to follow this  
Followers 0
ness

Want higher FPS? NVIDIA users check in.

41 posts in this topic

Thanks for this tip!

before:

69

30

21

after

72

30

21

put AA to 8x

65-71

36-38

23-24

I tried all other AA setting 8x was best for me. no overclocking gtx470 icore7 something or other GHZ 6gigs of fancy ram sabretooth mobo with flashing lights 3x 24 samsung 24" displays

Edited by Whiplash

Share this post


Link to post
Share on other sites

I did document each individual setting, and what FPS change I got, I just didnt bother to add it to the thread as it would be less helpful and more confusing. When I get home, I'll throw it all together, and also run some more tests with a single card, and if time permits, ill even run some of the tests with an 8800gt if I can find it. Turns out the gtx260 I was going to also test has a dead fan.

Share this post


Link to post
Share on other sites

After 4 hours of testing and confirming settings, this is what I got. SLI disabled.

I put the in game settings to BALANCED for these tests.

I had 3 baseline framerate settings. .benchremagen, .benchinfantry and .benchvehicles.

My numbers were 93fps, 47fps, and 26fps respectively.

I noticed that while testing, depending on the setting I chose, my framerate numbers would fluctuate to a consistent group. The fluctuating numbers came in 2 groups other than my baseline framerate, one of which was 95fps, 55fps, 26fps, and the other group was 91, 41, 25. So let's call these loss, sustain, and gain.

loss: 91, 41, 25

sustain: 93,47,26

gain: 95,55,26

For all of these tests, I kept everything at the default driver preferred settings, and adjusted each setting 1 by 1, UNLESS they required some other function to be enabled.

==================

ANISOTROPIC FILTERING

==================

Global - sustain

Off - sustain

2x - gain

4x - gain

8x - loss

16x - gain

Winner: 16x

============================

ANTIALIASING - GAMMA CORRECTION

============================

Global - sustain

Off - sustain, but with a 1fps loss after .benchinfantry

On - sustain

Winner: On

=================

ANTIALIASING - MODE

=================

This directly controls the Antialiasing Setting, so use Override. Enhance mode gave me a loss in performance.

Winner: Override

===================

ANTIALIASING - SETTING

===================

Global - sustain

2x - slight gain

4x - gain

8x CSAA - sustain

8x - loss

16x CSAA - gain

16xQ CSAA - loss

32x CSAA - sustain

Winner: 16xCSAA, however I put 2x on my guide out of concern that people may not have cards as fast as mine.

========================

ANTIALIASING - TRANSPARENCY

========================

None of these made any change at all as far as framerate goes. Some form of AA has to be selected in order for this to do anything. This should only really be visible when looking at tree leaves and tank treads. Anything above Multisample makes the entire screen look like blurry ass, so I HIGHLY do not recommend 2x or higher.

Winner: Multisample, because it doesnt blur the screen, and it doesnt reduce framerate.

==========

CUDA - GPUs

==========

No difference.

Winner: whatever

=========================

MAXIMUM PRE-RENDERED FRAMES

=========================

0 - gain

everything else is a sustain. Need to update page 1 and recommend 0.

Winner: 0

=================================

MULTI-DISPLAY/MIXED-GPU ACCELERATION

=================================

no difference.

Winner: poop.

=====================

POWER MANAGEMENT MODE

=====================

no difference.

Winner: maximum performance just because.

=============================================

TEXTURE FILTERING - ANISOTROPIC SAMPLE OPTIMIZATION

=============================================

no difference in framerate

Winner: Off just because

================================

TEXTURE FILTERING - NEGATIVE LOD BIAS

================================

Allow - sustain

Clamp - like 1 fps loss, but it prevents the ground from looking warp-ish when im running

Winner: clamp

======================

TEXTURE FILTERING QUALITY

======================

No difference at all in framerate

Winner: High Quality, free of charge!

====================================

TEXTURE FILTERING - TRILINEAR OPTIMIZATION

====================================

Off - loss

On - sustain

Winner: On

=================

Threaded Optimization

=================

Auto - sustain

Off - sustain

On - loss

Winner: Off

==============

TRIPLE BUFFERING

==============

No change here.

Winner: Off. Don't use vsync anyway

============

VERTICAL SYNC

============

Force Off - Sustain

On - big loss

Winner: Force Off.

So that does it. Time to sleep forever.

Edited by ness

Share this post


Link to post
Share on other sites
Thanks for this tip!

before:

69

30

21

after

72

30

21

put AA to 8x

65-71

36-38

23-24

I tried all other AA setting 8x was best for me. no overclocking gtx470 icore7 something or other GHZ 6gigs of fancy ram sabretooth mobo with flashing lights 3x 24 samsung 24" displays

Yea, you have to tax your system or it actually runs slower! Usually if you have higher AA or AF settings, the FPS drops in other games. In this game, you have to set the settings higher!

Share this post


Link to post
Share on other sites

Worked great for my 550 TI. Now I'm getting the 100 FPS and even 40 FPS in heavy urban I would expect out of my rig. Thanks!

Share this post


Link to post
Share on other sites

Great post, I gained 10-15% on a quad core, I7, nvidia geforce 555m, thanks. I also figured out how to run the game lol. My GPU kept resetting to my pos low end built in card.

Share this post


Link to post
Share on other sites

My frames seem to stick at 30 in a contested town, or either 60 FPS if I look into the sky. Is that just how the game handles VSYNC? I haven't experienced the same in other games, usually it'll give me whatever FPS it's capable of displaying instead of just switching between 30 and 60 FPS.

Running an i7 2700k @ 4.8 and GTX 580's SLI.

Share this post


Link to post
Share on other sites
My frames seem to stick at 30 in a contested town, or either 60 FPS if I look into the sky. Is that just how the game handles VSYNC? I haven't experienced the same in other games, usually it'll give me whatever FPS it's capable of displaying instead of just switching between 30 and 60 FPS.

Running an i7 2700k @ 4.8 and GTX 580's SLI.

I took VSYNC off and didn't notice any tears. I don't think its needed.

Share this post


Link to post
Share on other sites
I took VSYNC off and didn't notice any tears. I don't think its needed.

I'm thinking it depends on your monitor as to tearing. I don't see tearing with it off either.

Share this post


Link to post
Share on other sites
I'm thinking it depends on your monitor as to tearing. I don't see tearing with it off either.

Or maybe some of the other options??? Frame run ahead type setting? Either way, VSYNC, for me, is not needed. Though, with it on, past 60 FPS it's just bragging rights anyway.

Share this post


Link to post
Share on other sites

FPS over 60 doesn't matter, however VSYNC does lower the overall average FPS in this game. I recently just added 12g of Corsair Vengeance and overclocked it a bit. I'm gonna re-run these tests when I get home to see if tighter timings have any impact, but I've also gotten newer drivers since then.

Share this post


Link to post
Share on other sites

As a follow up, tighter memory timings or memory at a higher frequency have no bearing on FPS in offline tests. Also it seems that with the latest patch the ww2.exe profile from my nvidia control panel has disappeared, so I had to re-add it and reconfigure the settings per page 1 to get my FPS back to optimal performance. Not sure if others will need to do this as well.

Share this post


Link to post
Share on other sites

Sorry, but how can i set AA to work in online mode? Doesn't work with the Nvidia control panel for me, only with ww2.exe offline.

Share this post


Link to post
Share on other sites
Sorry' date=' but how can i set AA to work in online mode? Doesn't work with the Nvidia control panel for me, only with ww2.exe offline.[/quote']

Wow, good call. Most of the testing I did was offline, and I never noticed AA wasnt working since I run the game at 1080p. I dropped it down to 1280x720 and you are absolutely right.

This makes me wonder a few things..

1. why AA doesnt work in the ww2.exe profile unless global is forced on

and

2. what else isn't working online?

AAnvidiabug.png

Thanks for catching that, gonna update this guide.

Share this post


Link to post
Share on other sites
Wow, good call. Most of the testing I did was offline, and I never noticed AA wasnt working since I run the game at 1080p. I dropped it down to 1280x720 and you are absolutely right.

This makes me wonder a few things..

1. why AA doesnt work in the ww2.exe profile unless global is forced on

and

2. what else isn't working online?

AAnvidiabug.png

Thanks for catching that, gonna update this guide.

Got i to work online, use 4x AA, global settings. And run Playgate as admin.

Share this post


Link to post
Share on other sites

ive tryed those nvidia settings and the was zero difference in frame rates.

72

19

14

and this is with a fairly meaty system.

INTEL CORE I7 2600K 3.4Ghz

GIGABYTE GA-Z68AP-D3 MOBO

4GB ram

geforce GTX 560ti 2GB Video card

creative xfi extreme sound card

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.