Sign in to follow this  
Followers 0
jon8798

Problem with Logitech Extreme 3D Pro Joystick

27 posts in this topic

Thanks to Sniper62 for this one - it now works.

I opened the "Configure USB Game Controllers" programme and selected advanced settings. Then selected the Extreme 3d pro as preferred controller for 'older programmes' - and it works. Also running it in XP compatibility mode, so I wonder if it is a combination of the two that makes it work or just the first fix? I'll try and remember to turn off compatibility mode next time I start up and see if it still works. For now, I'm so excited that I'm going to go and get a hurricane shot down eleventy times.

Same problem. Joystick working then not working. The 'above fix' sorted it out. Thanks Fellas.

Share this post


Link to post
Share on other sites
Then selected the Extreme 3d pro as preferred controller for 'older programmes' - and it works.

Worked for me too! Thanks

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.