Sign in to follow this  
Followers 0
snowykoeld

it crashes when i try to play

24 posts in this topic

just downloaded it on my new laptop

when i try to spawn in anywhere in anything, the game crashes. EVERY TIME!!!

what do i do?

Share this post


Link to post
Share on other sites

Your laptop is likely simply unable to play it. WWIIOL is a fairly demanding game on CPUs and GPUs, and most laptops dont even have an independent GPUs, they are instead integrated. Most games don't even support integrated GPUs, as there are so many of them and their performance is so abysmal. Another potential problem is the amount of RAM your computer has, it is probably insufficient and unable to handle the amount of memory needed to run the game when spawned. Lastly, again the CPU may be insufficient.

What do you have specifically?

Share this post


Link to post
Share on other sites
Your laptop is likely simply unable to play it. WWIIOL is a fairly demanding game on CPUs and GPUs, and most laptops dont even have an independent GPUs, they are instead integrated. Most games don't even support integrated GPUs, as there are so many of them and their performance is so abysmal. Another potential problem is the amount of RAM your computer has, it is probably insufficient and unable to handle the amount of memory needed to run the game when spawned. Lastly, again the CPU may be insufficient.

What do you have specifically?

really? well that sucks

i have a Dell Inspiron 15R second generation

just got it a few days before Christmas

Share this post


Link to post
Share on other sites

Yup, that one has an i3 and an integrated card, dont know about RAM as that you can choose yourself easily, but that is irrelevant when it doesnt even have a good GPU. That really isn't a very good laptop nowadays anyways, not for gaming. It will work well for all office tools and web, but not graphics design and gaming.

Share this post


Link to post
Share on other sites

Depends on whether its a bare bones dell or not.

If it has a dedicated vid card then you need to set switchable grafics to High.

If it has a nvidia gfx card you should be able to set the card for the game but if it has a ati or amd card then you may not have any luck (wifes i5 laptop with amd vid card is a nogo for this game as it won't enable the amd card for BE).

Edited by OldZeke

Share this post


Link to post
Share on other sites
really? well that sucks

i have a Dell Inspiron 15R second generation

just got it a few days before Christmas

As said, if you only have integrated graphics, then you will almost certainly not be able to play :(

If you do also have a dedicated gfx card, but it is AMD not Nvidia, have a look in your BIOS to see if you can turn off the integrated one. If it is nvidia, have a look in the sticky up top and there are instructions with how to fix: http://forums.battlegroundeurope.com/showthread.php?t=373903

There is a post on here about purchasing and installing a dedicated gfx to a laptop, but it is pretty a difficult operation.

Let us know if we can help further ...

Share this post


Link to post
Share on other sites
Depends on whether its a bare bones dell or not.

If it has a dedicated vid card then you need to set switchable grafics to High.

If it has a nvidia gfx card you should be able to set the card for the game but if it has a ati or amd card then you may not have any luck (wifes i5 laptop with amd vid card is a nogo for this game as it won't enable the amd card for BE).

I have i5 laptop with amd vid card, and I got it to work - but it took some time. And now it runs the game like a charm.

I knew that I had to set the dedicated vid card as the standard in settings.exe, but I could only choose the onboard intel card. And I had no idea how to disable the on board vid card.

But I succeeded in the end and this is how:

I downloaded Catalyst Control Center (CCC) from the AMD.com homepage. This gives you the ability to open the CCC when you right-click on your desktop.

Now when in the CCC go to the tab called "power" and select the setting where you choose the vid card manually and not "automatic based on the program needs" - which is the standard.

With this done I had disabled the on board card, and could now select the AMD card in settings.exe and everything was fine :) I hope this can help.

This is a pic of the CCC if needed. It is in Danish (I am sorry) but it should give you the feel as where to go: http://i999.photobucket.com/albums/af118/teufeldk/CCC.png

Edited by teufeldk

Share this post


Link to post
Share on other sites
I have i5 laptop with amd vid card, and I got it to work - but it took some time. And now it runs the game like a charm.

I knew that I had to set the dedicated vid card as the standard in settings.exe, but I could only choose the onboard intel card. And I had no idea how to disable the on board vid card.

But I succeeded in the end and this is how:

I downloaded Catalyst Control Center (CCC) from the AMD.com homepage. This gives you the ability to open the CCC when you right-click on your desktop.

Now when in the CCC go to the tab called "power" and select the setting where you choose the vid card manually and not "automatic based on the program needs" - which is the standard.

With this done I had disabled the on board card, and could now select the AMD card in settings.exe and everything was fine :) I hope this can help.

This is a pic of the CCC if needed. It is in Danish (I am sorry) but it should give you the feel as where to go: http://i999.photobucket.com/albums/af118/teufeldk/CCC.png

Thanks for posting this, will help us out as it is a common issue :)

STICKY Hick, please

Share this post


Link to post
Share on other sites

I just got a brand new toshiba lab top for christmas and the game crashes when i try to spawn. As you were saying is the toshiba a good labtop to play this on ?

Edited by noman153

Share this post


Link to post
Share on other sites
I just got a brand new toshiba lab top for christmas and the game crashes when i try to spawn. As you were saying is the toshiba a good labtop to play this on ?

If you only have an integrated graphics chip, then you will have issues (if it will work at all) whichever laptop you buy.

Can you post your DXDIAG results (for the DISPLAY tab)?

(See this: http://forums.battlegroundeurope.com/showthread.php?t=368976 for instructions, if you don't know how)

Share this post


Link to post
Share on other sites

Heres the thing though my old computer, two years ago, i had this game and it worked fine. After that I deleted it and a few months later I redownloaded it and it crashed before it could load. Now on my new cpu it crashes when i spawn. Do you know why this happene and Im not sure what graphics card it is but I will find out.

Share this post


Link to post
Share on other sites

If you are playing on a laptop (I am myself) you need to set the dedicated graphic card as the default in setting.exe, found in your BE folder.

To make sure you computer have a dedicated graphic card (other than the on board) go check your Device Manage. Start --> Control Panel --> Device manager. You should see something like this (sorry it is in Danish):

http://i999.photobucket.com/albums/a...shndtering.png

As you can see I have both an onboard intel graph card, and a dedicated AMD Radeon card.

If you have a dedicated card go set it as the default card in settings.exe found in your BE folder - then you should be good to go. If you are not able to pick your dedicated card in settings.exe then write again.

Share this post


Link to post
Share on other sites
If you are playing on a laptop (I am myself) you need to set the dedicated graphic card as the default in setting.exe, found in your BE folder.

To make sure you computer have a dedicated graphic card (other than the on board) go check your Device Manage. Start --> Control Panel --> Device manager. You should see something like this (sorry it is in Danish):

http://i999.photobucket.com/albums/a...shndtering.png

As you can see I have both an onboard intel graph card, and a dedicated AMD Radeon card.

If you have a dedicated card go set it as the default card in settings.exe found in your BE folder - then you should be good to go. If you are not able to pick your dedicated card in settings.exe then write again.

i cannot see the option only the intergrated 1 :L

Share this post


Link to post
Share on other sites
i cannot see the option only the intergrated 1 :L

As far as ?I know (I have NVIDIA, not ATI) if you cannot see the option, then you do not have a dedcated gfx card, only the integrated Intel one (maybe an ATi user will say otherwise?)

What is the make and model number of your PC? - I'll see if I can find it and specs online

Share this post


Link to post
Share on other sites

Thanks for the details, now you can fix it. You are not the only person with this HP issue.

Many thanks to Random-Internet-Person-Number364 for this fix...

http://ubuntuforums.org/showpost.php?p=11195922&postcount=11, if you want to read the entire topic - Note that they are trying to disable 3D graphics to run ubuntu ... but the process will work in reverse.

What you need to do is UPDATE YOUR BIOS

1. The Page for the ATi BIOS is HERE: http://forum.notebookreview.com/hp-pavilion-notebooks/595505-updated-hp-pavilion-bios-releases.html

2. Find your MODEL Number and download the file (Make absolutely certain you pick the correct model)

3. Run it (while in Windows) and follow the instructions

4. Shutdown and Restart your laptop

When it's done, you should be able to switch card in Windows, when you have, launch Battleground Europe Settings and you will be able to select it.

Then have fun :)

Edited by branko

Share this post


Link to post
Share on other sites
Thanks for the details, now you can fix it. You are not the only person with this HP issue.

Many thanks to Random-Internet-Person-Number364 for this fix...

http://ubuntuforums.org/showpost.php?p=11195922&postcount=11, if you want to read the entire topic - Note that they are trying to disable 3D graphics to run ubuntu ... but the process will work in reverse.

What you need to do is UPDATE YOUR BIOS

1. The Page for the ATi BIOS is HERE: http://forum.notebookreview.com/hp-pavilion-notebooks/595505-updated-hp-pavilion-bios-releases.html

2. Find your MODEL Number and download the file (Make absolutely certain you pick the correct model)

3. Run it (while in Windows) and follow the instructions

4. Shutdown and Restart your laptop

When it's done, you should be able to switch card in Windows, when you have, launch Battleground Europe Settings and you will be able to select it.

Then have fun :)

Thanks very much for reply i will give it ago

Share this post


Link to post
Share on other sites

If you select it in CCC and then restart your laptop, does the ATi remain selected (in CCC)?

If it does, after the restart ... can you now select it in BGE Settings?

(Let me know ... Don't give up yet ... You have a card that will work ... I'll figure something out)

Share this post


Link to post
Share on other sites
Bad news :L i have done it all but in ccc theres not the right tab as its been updated i do it the new way but stiil no option in the settings stupid ati i dont know why the gme wont pick it up

ok i have finally done it thanks for help

Share this post


Link to post
Share on other sites
ok i have finally done it thanks for help

:)

If you still have problems post ...

... but here is the nuclear option: http://www.wikihow.com/Disable-the-Onboard-Graphics-and-Install-a-New-Graphics-Card-in-Your-HP-Pavilion-6630

Just do to STEP 5 then RESTART laptop

What that will do is disable the Onboard gfx chip working ... So hopefully you don't need it. But it's there if you do.

Hope you enjoy the game :)

Edited by branko

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.