• Announcements

    • HEAVY265

      Attention Soldiers Operation Fury Needs you!   02/20/2020

      Attention All Soldiers, Operation Fury needs you.  You need to choose a side and sign up.  
      For more intel on Operation Fury Please click HERE Please go to Special Event Forum (here), And sign up for allied or axis.
      This will be a CRS Lead event on both sides.  Xoom will be heading up the axis side and Heavy265 will be heading up the Allied side. This will be for bragging rights.
      Why are we asking players to sign up you ask. We are trying for a role play experience.   We want this to be a true realistic event.  
      So get up and sign up and let's make this the best event ever!!!!!!!!!!
      Give me your war cry, grrrrrrrrrrrrr
      Heavy265 **out**
Sign in to follow this  
Followers 0
degrono13

low fps with sli gtx 570

15 posts in this topic

so im running the game and, out of battle im getting round 20-30 fps, and then in battle im getting like 10-20 fps and its scitchy in big battles.

whats going on here i have two high end performance cards, and im getting like no fps? can some 1 help please.

Share this post


Link to post
Share on other sites

ok so i disabled sli, to see if it would make any difference and its still the same. i dont understand cuz even just 1 of these cards should have great fps??

Share this post


Link to post
Share on other sites

Can you post your processor and RAM specs?

WWIIOL is not gfx card dependant, it's more about your CPU and RAM than the gfx. A much lower end card will do the job if your processor and ram are all good.

ALSO: Are your Nvidia Drivers the latest version? That will also help.

Once that is okayed, then you can mess about with your setup, helpfully provided by ness, here: http://forums.battlegroundeurope.com/showthread.php?t=381068

Cheers.

Share this post


Link to post
Share on other sites

i have 4 gig of g.skill sniper ram, and a amd phennom II X6 1100T processor. yeah my gfx card driver is up to date

Share this post


Link to post
Share on other sites

Sometimes it's the basics, what other applications do you have running in the background?

Share this post


Link to post
Share on other sites

card and resolution saved in game settings.

shadows or water reflection turned down or off in preferences?

have you gone into your card setting s and set to different levels of performance and quality

sometimes with the faster cards they run better with everything turned up.

Share this post


Link to post
Share on other sites
so im running the game and, out of battle im getting round 20-30 fps, and then in battle im getting like 10-20 fps and its scitchy in big battles.

whats going on here i have two high end performance cards, and im getting like no fps? can some 1 help please.

Defragment your computer if you have not in a while. Also I strongly suggest using like a game booster, it sounds like it is either a driver issue or too many applications.

Share this post


Link to post
Share on other sites
i have 4 gig of g.skill sniper ram' date=' and a amd phennom II X6 1100T processor. yeah my gfx card driver is up to date[/quote']

Then you should be all good to go.

Some people have reported unexpectedly low performance with the high end cards.

So ness did a write up of how to get more out of one with WWIIOL.

Try following through this and let us know how you get on:

http://forums.battlegroundeurope.com/showthread.php?t=381068

Cheers

Share this post


Link to post
Share on other sites

i followed the link u gave me and did everything thats shown on that manage 3d settings, so far my fps has gone up to 60, and in battle 30, im waiting for a big battle with lots of players around to see if the slow stuttering type of thing happends, but so far so good, thx for the help guys

Share this post


Link to post
Share on other sites

ok, so im still getting problems when in a bigger battle, when lots of player, tanks around etc. i tried exiting all programs, still getting slower performance in the big battles?

Share this post


Link to post
Share on other sites

hmm must of been the setting i had in game, i clicked on best quality and went into the same big battle, and its great no more slow performace, then i also seen the option best performance in the setting and i tried that, and its even better, sitting on 60+ fps in big battles :D

Share this post


Link to post
Share on other sites

This game is 100% cpu hungry. You honestly won't see much of a difference in framerate from a gtx 260 to a gtx 580. Overclock that phennom II X6 1100T, and do NOT run the game in highest settings, because the game engine is not capable of running those settings efficiently (anyone raise your hand if you run the game maxed and get >60fps at all times).

http://www.tomshardware.com/forum/260672-29-complete-guide-overclock-phenom-0ghz

Be sure you know what you are doing, or at least read up on overclocking before you try that.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.