Sign in to follow this  
Followers 0
igo

7970 issue

19 posts in this topic

fps are predictably low. i don't even want to talk about it

5th ranked video card on market

only average fps

BF3 on ultra everything with constant 60+

Share this post


Link to post
Share on other sites

BE doesnt know what to do with all the power afaik

your card is better than mine but i bet your extra FPS is from the better CPU and BUS speed.

Share this post


Link to post
Share on other sites

Dunno what you are talking about.

I went from 5870 to 7870, lowest FPS [looking at treelines and forests] nearly doubled.

Mind you, I'm running at 5760 x 1200. I need the GPU horsepower.

I'm betting if I was running a single screen, I'd have seen very little difference.

Share this post


Link to post
Share on other sites
Dunno what you are talking about.

I went from 5870 to 7870, lowest FPS [looking at treelines and forests] nearly doubled.

Mind you, I'm running at 5760 x 1200. I need the GPU horsepower.

I'm betting if I was running a single screen, I'd have seen very little difference.

i have the same card and resolution as you and trust me the cpu makes FAR more difference than the gpu in this game

also 12.2 and 12.4 drivers cause the blocky trees 12.3 works best for me

Share this post


Link to post
Share on other sites

Bar i know your fustration with this, but believe me i have had the same issues with 99% of the new games out there. Some drivers work, some chipsets dont work... example Shogun 2 i beta fixed the problems with it for the company.

graphics was the biggest problem, because games like that demanded alot, but we still bottlenecked on drivers.

Share this post


Link to post
Share on other sites
It uses 2' date=' since 1.29 or so.[/quote']

I checked my cores while running the game, it bottlenecks still and all cores are open on my system.

1 person likes this

Share this post


Link to post
Share on other sites

How do I get the 12.3 driver and what do i do with it when I get it ?

im a mac user so I have no idea about this stuff

Finally got a better PC at home and the game looks crap on it , the trees and blocky and the grass is black

need a hand to fix it or I will through the pc out the window

and keep playing on my old mac laptop

ruck

Edited by ruckrova
the trees and blocky and the grass is black

Share this post


Link to post
Share on other sites
How do I get the 12.3 driver and what do i do with it when I get it ?

im a mac user so I have no idea about this stuff

Finally got a better PC at home and the game looks crap on it , the trees and blocky and the grass is black

need a hand to fix it or I will through the pc out the window

and keep playing on my old mac laptop

ruck

64 bit Win 7/vista driver suite here.

You simply run it. If you have an existing install of catalyst drivers, you might want to uninstall them first. If you have a brand new Windows install, it's could be using default windows drivers.

Share this post


Link to post
Share on other sites

I have been having this same issues and have tried several of the solutions posted here but I still haven't had any luck.

I have downgraded to the 12.3 driver

downloaded directx and open gl

changed all the in game settings

still no luck......any ideas?

Share this post


Link to post
Share on other sites

I just bought a new computer and have an amd raedon 7770. Having the same problems as described. Im not to computer savy, can you help me and tell me how to specifically unistall my driver? and reload. i dont know if i even i have an existing unstall of catalyst drivers. Thanks

Share this post


Link to post
Share on other sites
I just bought a new computer and have an amd raedon 7770. Having the same problems as described. Im not to computer savy' date=' can you help me and tell me how to specifically unistall my driver? and reload. i dont know if i even i have an existing unstall of catalyst drivers. Thanks[/quote']

I'm running v12.6 of Catalyst Control Center ( CCC ).

You should see an icon on the bottom rhs of your screen for it (odd looking thing but look for a red dot). Right click on that and click on "catalyst control center".

You should see some choices on the left when it opens.

Click on "information".

Then click on "software updates"

It should show you which driver version you are running. Mine is at V12.6

FYI - I am running a 5750 without these problems so it may be there are issues with the 79xx, 77xx, 78xx etc series and these drivers. Several people have had trouble lately and I'm not sure if they found a solution yet.

You can click on check for updates to see if another one is available for you but to be honest it may not solve your problem. You may in fact have to roll the drivers back to an earlier version.

I wish I could help more but this is all the info I have.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.