Sign in to follow this  
Followers 0
klaus

No Audio after patch

34 posts in this topic

I DLed directx 9.0c from the web after patch and no sound in game and i now have sound in game again !

this seemed to work for me. Didn't look like it was doing much, but audio is now on.

Share this post


Link to post
Share on other sites

Why DX9c?

everytime you reinstall Windows - after youre all done, you will go ahead and download dxwebsetup.exe and let it run and install missing, older DX files - just because you have dx11.1 doesnt mean you are all set, far from it...

You are NOT replacing DX11.1 - you are adding older dx files some older software needs to run properly

Until Windows comes w a complete set of all DX files running dxwebsetup after a fresh install is always recommended - then you wouldnt have to hassle around now w no sound and such

Share this post


Link to post
Share on other sites

Mine is now working. Seems all of the other DX links weren't downloading the right files but if you check out this thread:

http://forums.battlegroundeurope.com/showthread.php?p=6850662&posted=1#post6850662

You will see that OHM updated the link to one that downloads all old DX files and this at least worked for me. I didn't have to reinstall the game again, just rebooted after the DX install and then went into WWII settings app to set sound selection before running game.

Share this post


Link to post
Share on other sites
Same here mate.. we got to some how delete dx11 and reinstall dx9 by the looks of it.. but why and how!

Make sure you get the right DX link & try again

Share this post


Link to post
Share on other sites
Out of curiosity why is it installing DirectX over again is even suggested. If I have a working version of DirectX 11.1 for Windows7 it seems to me the idea of installing it again is liable to only break things than fix them. I can only assume that the built-in version of DirectX in the game is v11 - but is this true? Is it an older version? I suspect this is just a big red herring and DirectX has nothing to do with this problem as I had 11.1 with the old game version too.

It's probably related to how Steam games install core files other than the game, such as C++ Redistributables or files related to Direct X. The C4 Engine for example does this. Check out this link on the C4 Engine demo page.

http://www.terathon.com/download-win.php

http://www.microsoft.com/en-us/download/details.aspx?id=35

This demo requires the June 2010 release of DirectX for XAudio2 and XInput support.

This has nothing to do with the 9, 10, or 11 in the version of DirectX you have installed already.

If you’re not absolutely sure that your version of DirectX includes this, please update at the following location.

Share this post


Link to post
Share on other sites
I downloaded windows direct x end -user runtime web installer' date=', it worked[/quote']

It works

Share this post


Link to post
Share on other sites

Wish I would have checked here in the forums for my no sound issue 2 weeks ago . LOL

New system brand new install of Win7 and had no idea why no sound .

The link for the Direct X worked and I am finally back in business .

SMG

Share this post


Link to post
Share on other sites
Mine is now working. Seems all of the other DX links weren't downloading the right files but if you check out this thread:

http://forums.battlegroundeurope.com/showthread.php?p=6850662&posted=1#post6850662

You will see that OHM updated the link to one that downloads all old DX files and this at least worked for me. I didn't have to reinstall the game again, just rebooted after the DX install and then went into WWII settings app to set sound selection before running game.

solved.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.