• Announcements

    • HEAVY265

      Attention Soldiers Operation Fury Needs you!   02/20/2020

      Attention All Soldiers, Operation Fury needs you.  You need to choose a side and sign up.  
      For more intel on Operation Fury Please click HERE Please go to Special Event Forum (here), And sign up for allied or axis.
      This will be a CRS Lead event on both sides.  Xoom will be heading up the axis side and Heavy265 will be heading up the Allied side. This will be for bragging rights.
      Why are we asking players to sign up you ask. We are trying for a role play experience.   We want this to be a true realistic event.  
      So get up and sign up and let's make this the best event ever!!!!!!!!!!
      Give me your war cry, grrrrrrrrrrrrr
      Heavy265 **out**
Sign in to follow this  
Followers 0
revskip

Game crashes to desktop

25 posts in this topic

I have downloaded the game with the current patch and followed directions to delete old game first. I log into game and the map screen appears and then the crash to desktop. Any ideas? I have uninstalled game 2 times and reinstalled it. Thanks.

Share this post


Link to post
Share on other sites

I have exactly the same problem... Have tried 4-5 times now, both with and without DirectX. Game crashes back to desktop after Battleground Europe startscreen... Anyone with any idea on what the problem might be?

Thanks in advance

Share this post


Link to post
Share on other sites

Same problem.

I plan to do a full uninstall today and download the whole package from the main website.

I even search out any extra files that uninstall leaves behind.

Share this post


Link to post
Share on other sites

Same problem, did you guys apply the manual ati fix, its only thing i can think of at the moment. Will try some stuff out.

Share this post


Link to post
Share on other sites

Did full uninstall using CCleaner and downloaded full install from main website, tried this a couple of times. But that doesn´t work either... Still crashes to desktop.

Share this post


Link to post
Share on other sites

same problem, my config Amd E350 1.6ghz with graphic card Hd 6310 and 8 go Ram. i tried with other directx and look for update my pilote graphic

Share this post


Link to post
Share on other sites

1st make sure game is set for same resolution as desktop.

Are you all running duel graphic laptops? If so make sure you go into your duel graphics settings and set the game to performance.

Share this post


Link to post
Share on other sites

I got the same. Everything worked fine till the update. when logged in and pressing button play i get 1 second loading screen without warning CTD

Share this post


Link to post
Share on other sites

message from cc cleaner:Application Paths Issue C:\Program Files (x86)\CRS\Battleground Europe\Playgate.exe HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

hep meh

Share this post


Link to post
Share on other sites
Did you re-apply the 4 gig patch?

I have this problem also. Did total reinstall still CTD on opening splash screen. Interestingly though, I applied 4g patch and now it still CTD's but brings up the close application window rather than going directly to desktop.

I would like to play. Would be nice to find a fix for this. Perhaps a 64bit problem? Are others with problem 64bit?

Share this post


Link to post
Share on other sites
Update your ati drivers fixed it for me.

Thought I was up to date... Clearly I wasn't. Updated ATI drivers also worked for me. Thanks DM. If you see me out there, I owe you a tow!

Share this post


Link to post
Share on other sites
Thought I was up to date... Clearly I wasn't. Updated ATI drivers also worked for me. Thanks DM. If you see me out there' date=' I owe you a tow![/quote']

Check them drivers guys i thought i was up to date as well.

latest is 14.501.1003

Share this post


Link to post
Share on other sites
Check them drivers guys i thought i was up to date as well.

latest is 14.501.1003

The check for update on device manager is telling me I'm up to date but still crashing.

Share this post


Link to post
Share on other sites
The check for update on device manager is telling me I'm up to date but still crashing.

Hey Matt, right click on your desktop and bring up the Catalyst Control Centre. Click on the information tab at the bottom left, then confirm that the version is 14.501.1003-141120a-177998C. If not, hit the software update at the bottom of that tab. This fixed it for me thx to DM.

Share this post


Link to post
Share on other sites
The check for update on device manager is telling me I'm up to date but still crashing.
  1. If you ATI open AMD catalyst control center via start menu

  2. Then click information bottom left corner

  3. Then software update

  4. Then click heck for updates now

Share this post


Link to post
Share on other sites
I have this problem also. Did total reinstall still CTD on opening splash screen. Interestingly though, I applied 4g patch and now it still CTD's but brings up the close application window rather than going directly to desktop.

I would like to play. Would be nice to find a fix for this. Perhaps a 64bit problem? Are others with problem 64bit?

Mine is a 64 bit with no issues. I did rerun the 4 gig patch when I installed though.

Share this post


Link to post
Share on other sites
Mine is a 64 bit with no issues. I did rerun the 4 gig patch when I installed though.

The crash flags were upped in this patch (4gig patch) so no need to use the 4gig patch now.

Share this post


Link to post
Share on other sites

Well...finally got the game running (did ATI driver update and downloaded DirectX9), but now i get no more than 0-6 FPS...

I´ve got a lot of good advice from you guys (Cheers!), on how to improve my FPS. So will look into some of those...

But must say that i´m not very skilled with a PC, so i´m bringing in some "professional" help tomorrow. Hopefully he can optimize my system, so i will still be able to noob around in Battleground Europe... :)

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.