• Announcements

    • HEAVY265

      New Forum Lead!   11/17/2019

      It's with great pleasure to announce B2K as the new Forum Lead.   I am very confident he will be good for the forums, he has great ideas and direction for the future of the forums.
      Good luck sir and GOD speed.
Sign in to follow this  
Followers 0
SCKING

Joystick Issues

4 posts in this topic

I have been having a lot of problems in game lately with my X52 Pro. I was wondering if anyone has been having any issues? I am using MacOS 10.12.2. My main issues seem to be calibration when spawning in. Usually takes me a few times (and sometimes a loss of a plane or two) spawning in until it seems to work itself out. There is absolutely no indication that my trims are off (UI display shows my trims centered). Yesterday was pretty bad because not only was I not able to fly the first couple flights without full down aileron trim and having to push the stick forward in order to stop climbing, every once in a while without pressing any buttons, my flaps would start making noise (yet not show any change in the UI or in the cockpit) and also would fire the primary weapon without pressing the button (does indicate loss of rounds and can see them shooting). I run the X52 Pro in windows and don't seem to have any issues so I am pretty sure the stick itself is in good shape. Whether the issue is with MacOS itself or WWII Online itself causing the issue, I don't know and am just putting this out there to see if anyone else is having the problem or may have some ideas as to why I am having the problem.   

Share this post


Link to post
Share on other sites

This is an old post but it seems I have come up with a fix (or at least its been working without having to re spawn a million times).. 

@OldZeke @WAVER25

Didn't realize there is an external joystick setting on the MacOS version of the game.

When you open the application and it asks for your username and password, there is a Settings button to the left. Click that settings button.

joystick1.png

 

On the menu that comes up make sure you choose your joystick that you are using and then calibrate it. The calibration seems to be holding after doing that.

 

joystick2.png

 

That should fix the calibration issue as it has with my setup.

 

 

1 person likes this

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.