• Announcements

    • HEAVY265

      Attention Soldiers Operation Fury Needs you!   02/20/2020

      Attention All Soldiers, Operation Fury needs you.  You need to choose a side and sign up.  
      For more intel on Operation Fury Please click HERE Please go to Special Event Forum (here), And sign up for allied or axis.
      This will be a CRS Lead event on both sides.  Xoom will be heading up the axis side and Heavy265 will be heading up the Allied side. This will be for bragging rights.
      Why are we asking players to sign up you ask. We are trying for a role play experience.   We want this to be a true realistic event.  
      So get up and sign up and let's make this the best event ever!!!!!!!!!!
      Give me your war cry, grrrrrrrrrrrrr
      Heavy265 **out**
Sign in to follow this  
Followers 0
narg

Game takes literally 20 minutes to startup

13 posts in this topic

It used to take 5 tops.  Why does it take so long now?  My computer is better than ever (it's a brand new gaming laptop), and the start up time is unacceptable in its current state.

Share this post


Link to post
Share on other sites

Silly suggestion.. but have you tried deleting and then installing the game again? <---------- it is what I get told to do every time a patch breaks it for me.

Share this post


Link to post
Share on other sites
1 minute ago, schweize said:

Silly suggestion.. but have you tried deleting and then installing the game again? <---------- it is what I get told to do every time a patch breaks it for me.

It's not a silly suggestion, but I have just recently done a fresh install.

I have no problems running games that are resource hogs.  I am wondering if there's some sort of cap on the resources the game is permitted to use, because once the startup completed, the entire thing was snails pace.  Mouse moved jerkily across the screen, clicks didn't register for 30 seconds...

If that's the case, I need help fixing the problem.

Share this post


Link to post
Share on other sites

What are the specs of the computer you are playing with?

Jerky mouse in program sounds like it could be your graphic card or a processor bottleneck 

Share this post


Link to post
Share on other sites
27 minutes ago, schweize said:

What are the specs of the computer you are playing with?

Jerky mouse in program sounds like it could be your graphic card or a processor bottleneck 

I have a geforce GTX 1060, definitely not graphics card lol.

I'm thinking there might be some cap the system has placed on the resources it can draw from the processor.  I can run pretty much any new game on max quality graphics, with no stutter issues.

 

Share this post


Link to post
Share on other sites

-What processor do you have?
-Have you done any benchmarks on your system?
-Have you tried running the game as an "administrator"?
-which version of windows do you use?

Regardless of who manages to sort you out, you will need to provide more information if you want help....

It does seem a bit odd that you can run "other" games on max settings and have issues with wwiionline, although, I have known games to have issues with certain computer builds.... a prime example would be arma2, it just had certain combinations that the game hated... 

Share this post


Link to post
Share on other sites

Please try updating you video drivers if you have a NVidia graphics card.... it seems the lasted Win 10 does not like the old drivers n

1 person likes this

Share this post


Link to post
Share on other sites

I have a lenovo laptop with nvidia 960m i7 processor and after the last patch I had the same problems. I read in one of the forum posts the last win update had used a later vid driver and this was causing battlefield to hang at the launch screen. Went to Nvidia dvr update and grabbed latest dvr problem solved .

Share this post


Link to post
Share on other sites
1 hour ago, OHM said:

Please try updating you video drivers if you have a NVidia graphics card.... it seems the lasted Win 10 does not like the old drivers n

worked, thanks

1 person likes this

Share this post


Link to post
Share on other sites

Having this same issue, I updated my graphics card drives and still have the insanely slow loading times and when it finally launches it drags pretty hard.

 

Ill check again tomorrow and 100% ensure my drivers are up to date.

I have spent about 4 hours trying to get in game... I imagine brand new players will not be as patient when encountering these issues.

Share this post


Link to post
Share on other sites

You need to make sure the game is using your Nvidia card and not the Intel Integrated graphics

Share this post


Link to post
Share on other sites

I got a new monitor yesterday going from 2560x1080 to 3440x1440 resolution. Odd i don't have updates on and the 2560x1080 has worked fine for sometime. when I hooked up the new monitor the load time took forever or it would hang up and freeze on the loading screen. Updated the Nvidia driver and it fixed it.

Make sure all the resolutions and refresh rates match in the game settings and control panel. That has caused me issues in the past.

Edited by vader147

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.