WarPony

Billing

21 posts in this topic

Been playing this game a long time. Never had a issue with billing, always used auto pay thru my bank. I tryed to re- resister after getting notice my sub has expired. Won't work. I'm done playing till they get there billing figured out.

Been a hero builder all this time and never missed a payment...…...now this...…….s u c k s

1 person likes this

Share this post


Link to post
Share on other sites

This billing issue, by no fault of the Rats, is going to hurt the game.  

Edited by bmw

Share this post


Link to post
Share on other sites

already has.. not trouble we wanted to deal with.. thankfully I think dev is making good progress on the new billing system and we are seeing light at the end of the tunnel 

1 person likes this

Share this post


Link to post
Share on other sites

Well now I am getting this crap,, don't ever force me go to paypal , they are my enemy , stolen lot of my money from my account , so if they cant use what I ve been using well then I guess it time to hang up.:mad:

Share this post


Link to post
Share on other sites
27 minutes ago, texasjay said:

Well now I am getting this crap,, don't ever force me go to paypal , they are my enemy , stolen lot of my money from my account , so if they cant use what I ve been using well then I guess it time to hang up.:mad:

The new billing system is online as of yesterday. 

https://www.wwiionline.com/support-bulletins/accounts-billing/now-accepting-cards-for-payment

1 person likes this

Share this post


Link to post
Share on other sites

ok my apologize , something wonky on this site , getting error but now I fix the billing ,It been upgrade....glad I didn't have to use paypal , but my game is not active yet :rolleyes:

Share this post


Link to post
Share on other sites

I just submitted a ticket. It looks as though I'm being double-billed because I updated for recurring credit card payment. I hope this is answered very, very, quickly. 

Xoom- thanks for the quick response.

Edited by gavalink
1 person likes this

Share this post


Link to post
Share on other sites
35 minutes ago, themouse said:

can somebody FIX  "Thecat"   it's saying inactive  

Looks like Xoom got it about 10 minutes ago

Share this post


Link to post
Share on other sites

Hey guys, we're trying to respond as quickly as we can. The #1 way to get it resolved is to submit a support ticket here:

Submit a support request

When you update your billing method it will transact and that will give us the green light to configure your account. Have confidence though, we are on the ball.

Share this post


Link to post
Share on other sites

Just updated Billing (MAC) ...

Ty so much for your efforts, its been rough I'm sure..

I figure Xoom and crew have been workin triple time to get this done..

Good on you all...

Ty again...

Cheers Monty

Share this post


Link to post
Share on other sites

Is there any particular reason both my accounts say:

"Billing Method :  Offline Billing never expires via PayPal"

 

when I've already switched back to using the WWIIOL site for payment?  Some sort of bug?

 
Edited by phoenix

Share this post


Link to post
Share on other sites
3 hours ago, phoenix said:

Is there any particular reason both my accounts say:

"Billing Method :  Offline Billing never expires via PayPal"

 

when I've already switched back to using the WWIIOL site for payment?  Some sort of bug?

 

Offline Billing is no longer a thing. I just checked your account and you should be due for payment, but your account status is in an active state, which is very concerning for me. It should've went to Grace mode after no monies were collected on the 20th, your routine billing date.

Share this post


Link to post
Share on other sites
   
 

My secondary account billed today ( $12.99 for WBS promotion)... but the primary is still weird.

 

November 14, 2019: Invalid Transaction

The transaction reqiested does not exist, or you do not have the appropriate permissions to view the transaction.

 

But my credit card does show a transaction on November 15th for $14.99 ... somehow I missed that.  I guess everything is good?  Except it still shows the:

" Offline Billing never expires via PayPal " at the bottom.

   
   
Edited by phoenix

Share this post


Link to post
Share on other sites
5 hours ago, phoenix said:
   
 

My secondary account billed today ( $12.99 for WBS promotion)... but the primary is still weird.

 

November 14, 2019: Invalid Transaction

The transaction reqiested does not exist, or you do not have the appropriate permissions to view the transaction.

 

But my credit card does show a transaction on November 15th for $14.99 ... somehow I missed that.  I guess everything is good?  Except it still shows the:

" Offline Billing never expires via PayPal " at the bottom.

   
   

And now my secondary account is in "Grace" period, despite it showing up on my credit card statement this morning.  I've already updated my billing method multiple times since the point in time that Cybersource decided to screw us.

Edited by phoenix

Share this post


Link to post
Share on other sites

Updated my support ticket earlier.   Kinda wondering how many people are having the same problem I am.  Beginning to think you guys should find a lawyer, pro-bono, to sue Cybersource for this mess.

Share this post


Link to post
Share on other sites

@phoenix i fixed you up and replied to your ticket FYI

To answer your question--->

4 hours ago, phoenix said:

Kinda wondering how many people are having the same problem I am

"don't ask":angry:

1 person likes this

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.