• Announcements

    • HEAVY265

      Attention Soldiers Operation Fury Needs you!   02/20/2020

      Attention All Soldiers, Operation Fury needs you.  You need to choose a side and sign up.  
      For more intel on Operation Fury Please click HERE Please go to Special Event Forum (here), And sign up for allied or axis.
      This will be a CRS Lead event on both sides.  Xoom will be heading up the axis side and Heavy265 will be heading up the Allied side. This will be for bragging rights.
      Why are we asking players to sign up you ask. We are trying for a role play experience.   We want this to be a true realistic event.  
      So get up and sign up and let's make this the best event ever!!!!!!!!!!
      Give me your war cry, grrrrrrrrrrrrr
      Heavy265 **out**
ian77

Payment Problem

43 posts in this topic

Well, can include me into this fiasco now also. Says inactive and not payed since Oct, when in actuality I've paid both Nov and Dec, which my date is the 26th and is only a few days ago.

My account was changed in Oct, as suggested by CRS, to Paypal with recurring payments, account showed that and payment has been made that way. But now it shows as if this never happened. I even made sure the other night that the setup was intact, but I had to do it again, said I was on grace period, and was indicated that all was good. I was actually expecting to be charged again as has happened to others, but didn't. Instead, I'm locked out of game on a day off after having payed for my sub as normal on my end. 

 

Ticket has been submitted and hope can be resolved very soon.

 

Very frustrated and ticked off,

Mike

Share this post


Link to post
Share on other sites

@blkfalcon You're back online/active.

So here's what we're doing meanwhile, each morning @CHIMM is handling renewable transactions BY HAND to give them access. I asked him to start doing this a few days ago to proactively resolve things going forward. @PITTPETE meanwhile is doing a bang-up (albeit very frustrating) job of handling all of the incoming tickets. These will shore up soon with what Chimm is doing and we'll go back to normal operations.

Then, automation going forward, we have our development team working on resolving the links that need to be established between our billing/account system and the processors API that is causing this fuss. All of these things are happening now and will get smoother.

With the holidays officially completed, and us starting the New Year, most of our team is now back and back to a functional status. 

1 person likes this

Share this post


Link to post
Share on other sites

Thanks Xoom, all three working again, still got red lines in legit equipment, but at least I can get logged in once more. :)

 

S! Ian  

Share this post


Link to post
Share on other sites

I cant play the game either. Payment updated and it wont bill and activate my account. Sent a ticket and got a reply of " thanks for the heads up" what the hell does that mean?

Share this post


Link to post
Share on other sites

As long as you have sent a ticket , it will get looked after as soon as Support can get to it.

Share this post


Link to post
Share on other sites
15 hours ago, daywalkr said:

I cant play the game either. Payment updated and it wont bill and activate my account. Sent a ticket and got a reply of " thanks for the heads up" what the hell does that mean?

Heres your support ticket

c3e1a2e8ff27346d9db8c53796ef2b0a.png

Share this post


Link to post
Share on other sites
On 1/1/2020 at 6:36 PM, XOOM said:

@blkfalcon You're back online/active.

So here's what we're doing meanwhile, each morning @CHIMM is handling renewable transactions BY HAND to give them access. I asked him to start doing this a few days ago to proactively resolve things going forward. @PITTPETE meanwhile is doing a bang-up (albeit very frustrating) job of handling all of the incoming tickets. These will shore up soon with what Chimm is doing and we'll go back to normal operations.

Then, automation going forward, we have our development team working on resolving the links that need to be established between our billing/account system and the processors API that is causing this fuss. All of these things are happening now and will get smoother.

With the holidays officially completed, and us starting the New Year, most of our team is now back and back to a functional status. 

My last payment was on Jan. 7, and still my account became inactive today.

Share this post


Link to post
Share on other sites

Yoav, please put in a support ticket if you haven't already and it will get sorted out.. Thanks

Share this post


Link to post
Share on other sites

Same here. Just tried to re-sub and cant.  Ticket submitted.

Share this post


Link to post
Share on other sites
22 hours ago, bmw said:

Same here. Just tried to re-sub and cant.  Ticket submitted.

This is bmw...........i have a new computer so now i cannot even login to the forums. I put in a ticket and got a message back on how to do the billing but it was a dead link to zen desk???

 

Share this post


Link to post
Share on other sites

Helpdesk is offline ATM

Hopefully its up soon

For the time being post username here and the problem you're having

I can check 

 

Share this post


Link to post
Share on other sites
20 minutes ago, PITTPETE said:

Helpdesk is offline ATM

Hopefully its up soon

For the time being post username here and the problem you're having

I can check 

 

bmw1966

updated payment information and hit the button to pay and nothing happens.....stays on the same page that tells me to update and pay

Share this post


Link to post
Share on other sites

I'm having the exact same issue as Sequel2.

Billing info updated (it never changed) and hit enter.  No transaction occurs.

Thanks in advance.

NorCal

Share this post


Link to post
Share on other sites
19 hours ago, PITTPETE said:

All set now bud

Thanks...Im back in business.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.