rmack1

Unable to upgrade

24 posts in this topic

Every time I try to buy an upgrade, I get this 'Crikey, something happened we didn't expect' message informing me the purchase didn't go through.

 

I've submitted a report, but haven't heard anything for a few days now.

 

I suspect the problem might have something to do with the fact that I have an old account I haven't played on in many years.  I bet something is too similar to that old account, and it's raising red flags somehow.

 

Is there any other way I can get help with this?  A number I can call?  

Share this post


Link to post
Share on other sites

Was it a report or Support ticket ?. Support will get back to you quickly, as accounts are important . 

 

Share this post


Link to post
Share on other sites
22 hours ago, rmack1 said:

Every time I try to buy an upgrade, I get this 'Crikey, something happened we didn't expect' message informing me the purchase didn't go through.

 

I've submitted a report, but haven't heard anything for a few days now.

 

I suspect the problem might have something to do with the fact that I have an old account I haven't played on in many years.  I bet something is too similar to that old account, and it's raising red flags somehow.

 

Is there any other way I can get help with this?  A number I can call?  

My secondary account is like this atm - all "crikey" messages.  I unsubscribed it rather than deal with it atm.  This account is Hero anyway, so it's not as if I really need my secondary right now.  Anyway, I dunno if you're up-to-date on events, but the short answer is Cybersource back in September changed their billing API with no warning and it screwed over CRS and a number of other companies. (CRS has used them from 2001 I think).  CRS has been scrambling since then, manually fixing accounts both before and after they switched over to a new billing method, which is still getting the problems ironed out of it.

Share this post


Link to post
Share on other sites

OK, is there anything I can do about it?

 

I'm not sure of the details of my original account.  I know the email address, and that email is still active.

 

No one has contacted me yet about my support ticket.  It would seem someone wanted to give them money would be a priority.

Share this post


Link to post
Share on other sites

It is Rmack1 . I have told CRS and it is getting looked into .We have had issues with the new billing system and it has been done manually. 

Sorry for any delay in the process .

 

Share this post


Link to post
Share on other sites

Thank you so much.  I have a new X 56 HOTAS Saitek joystick and throttle that I want to try out in this game.

Share this post


Link to post
Share on other sites

I tried to log in and it said my email or password was wrong.  I tried it a couple of times to no avail.  I tried the forgot my password link and put in my current email.  I know it's  a registered email as I still have the signing up emails from playnet CRS, but no response.

Share this post


Link to post
Share on other sites
10 hours ago, rmack1 said:

I tried to log in and it said my email or password was wrong.  I tried it a couple of times to no avail.  I tried the forgot my password link and put in my current email.  I know it's  a registered email as I still have the signing up emails from playnet CRS, but no response.

I think I had the same issue with the Zendesk link that you did -  in fact I had forgotten I had set up a support account -  but I definitely have a separate password from my Playnet account  ( I didn't feel comfortable using identical login info) , since this looks like a support service that CRS buys from them.  So you'll have to register or submit without signing in like you already did. 

Edited by phoenix

Share this post


Link to post
Share on other sites

Well, I got an email saying they had found my old account, and asking if I wanted it activated.  Said I'd get two months free for my troubles.  I answered back and said yes, do that.

 

This was a couple days ago, and still my old account is not activated.  I hope it's gotten to today.

Share this post


Link to post
Share on other sites

It seems things are still buggy, guys.

 

I tried to access the training server, and I got in, but all units were red and unavailable.  Said my subscription wasn't enough to access, which is strange, because a free to play would let you practice with some stuff.

 

I was able to fly in the British AF.  Sort of.  I tried to check my joystick programming in the campaign.  I crashed one bomber before I fixed several axis of my stick and throttle from being backwards.  So, I figured I'd wait for my account to be fixed and play infantry.

 

I was suppose to have a premium subscription, but I couldn't access many of the weapons.

 

If I need to just go get a subscription, just let me know. 

Edited by rmack1

Share this post


Link to post
Share on other sites

I just tested the Training server and all unit are available .

With infantry there are a few that are red and unavailable as they are for Steam players . Nothing different just a quantity of units reserved for them .

 

Edited by tr6al

Share this post


Link to post
Share on other sites

I checked several times.  I couldn't spawn anything on the training server.

 

PittPete activated my old account and deleted my new ones.  Fixed the campaign server, but training is still all red to my account.  Which is real odd, because even a free to play account can practice with some weapons, I thought.

Share this post


Link to post
Share on other sites

Thanks, PP.

I still don't completely understand the difference with Steam wwii online.  Is it ok to spawn using Steam, or do I have to buy the game through them?  No problem if I have to, I just want to not mess things up any further.

 

The training server not letting me spawn anything is a mystery to me.

Share this post


Link to post
Share on other sites

There are 2 ways to play , one is through Steam that you pay for via Steam while the other is through this website. Steam account will not let you play through what we call the Live server . You need an account on one or the other and Play through that access .

If you have paid for a premium account , you need to run the game from your computer , if you have paid through Steam , you need to play through the Steam application . The training server sees you the same way .

 

Edited by tr6al

Share this post


Link to post
Share on other sites

Thank you.  I run other games through Steam, but this one through an old time premium account.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.