Sign in to follow this  
Followers 0
bloo

Nvidia 9x.xx drivers + Dual Core processor and FPS

80 posts in this topic

If you've running recent Nvidia video card drivers on a dual-core processor system and getting poor framerates, there are a couple of changes that should help your performance a lot.

Disable Water Reflections. The drivers don't like them at all.

Disable OpenGL Threading. This is enabled by default. To disable this:

Control Panel ->

NVIDIA Control Panel ->

3D Settings ->

View (on the top bar of the window) ->

Change the "Standard" to "Advanced" ->

You will then get a new icon called "3D Settings management", click it ->

Disable the tab called "OpenGL threading"

Thanks to Stubbles, Gnasche, Ziporama and Konstant for this.

Share this post


Link to post
Share on other sites

Recommend this be stickied, Bloo.

This could account for quite a bit of the people complaining about bad FPS recently; problem seems to be in the newer drivers, not really in the patches you guys are putting out.

Share this post


Link to post
Share on other sites

It's a shame I don't have that tab at all... thus disabling my ability to turn it off :(

I actually thought this would be a breakthrough until I found that the option wasnt even there. :(

I'll try and find another way.

Share this post


Link to post
Share on other sites
It's a shame I don't have that tab at all... thus disabling my ability to turn it off :(

I actually thought this would be a breakthrough until I found that the option wasnt even there. :(

I'll try and find another way.

The options IS definitely there in the latest drivers, 91.47

Share this post


Link to post
Share on other sites

Ok, maybe it doesnt show up for people without dual core processors and hyper threaded processors, but I have a P4 3.0ghz with Hyper Threading, and I don't see the option to turn it off at all.

I have seen a screenshot that someone took showing the option, and there was also a little check box down in their panel that said something like "advanced"

Anyway...here is a screenshot of what I am seeing.

screenfx3.th.jpg

When I look at the help file, I look at the "manage 3d settings section, and there is also no mention of the OpenGL threading option in there either.

I believe that if I can get this option to appear, I might actually be able to play the game with better fps, I'm getting very sick of the bad performance...even on the extreme lowest of all lowest settings possible for the game...including 640x480 resolution...which is ridiculous.

Oh...I tried using the Nvidia 91.47 driver, then I tried the beta driver 92.91 and it's still not there...I do have a hyper threaded cpu, so this option should be showing for me... :S

EDIT:

I've been searching on google for a way to find out how to edit this function if it's not appearing in the control panel.

Scroll down this thread and there is a registry hack thing you can do to turn it off in your registry.

http://forums.nvidia.com/lofiversion/index.php?t9875.html

Share this post


Link to post
Share on other sites

Ok, I think I got it working by doing a reg edit hack. Here is the link

http://ucguides.savagehelp.com/Quake4/FAQ_DualCore.htm#INTEL

That is if you DO HAVE a DUAL CORE system or HYPER THREADED system.

I don't have a dual core Intel, but I just did that last bit that says Dual core Intel, I have a hyperthreaded Intel processor.

When I tested this, I jumped into the game and jacked everything up to maximum, and was getting decent fps out in the open with not much going on..so there was definately an increase...however, as soon as I got into battle...hehe, well, it went straight back down to under the teens.

I still wasnt happy of course...so I turned off post processing and normal mapping...which gave me a much smoother performance, averaging about 29-30 in the open, not much going on, but..once again, as soon as I got into battle, my fps went flying down again :(

So, I'm going to turn down my settings some more...unfortunately I have to do it, but...ahwell, if I get a smooth frame rate, I'll be happier.

I'm still not entirely sure if this did much for my FPS or not since I havent really been tracking my fps, and I didn't compare my FPS before, to what I have now..so for all i know, the opengl setting hasnt even changed to off.

I do think it has been turned off, but I think my system can do better than that tiny performance increase.

Others are getting huge performance increases in games like City of Heroes, from 10-20 fps to 40-60...so surely i should be getting more performance.

Anyway...i'm just letting you know that I think it worked.

Share this post


Link to post
Share on other sites

Just an FYI:

Upon further investigation, it appears this setting may also be labelled "Threaded optimization".

Share this post


Link to post
Share on other sites

UPDATE:

After playing with this setting disabled for a few days now, I've concluded that I simply don't notice any FPS difference either way. Probably not harmful to disable it, but I am not sure if this tweak actually works (at least for me).

Share this post


Link to post
Share on other sites

I think it's mainly for dual-core cpu's.

I run a Core2Duo, so the option shows up for me. It most certainly helps when I disable it. It yielded about a 20% increase in performance. This, along with disabling V-Synch in the WWIIOL config boosted my framerate signifigantly. The Vsync is odd in this game. It actually hurts my performance a lot. I was sitting around 25-30fps when it was enabled. After disabling it, I went up to 50-70fps. Even in the heaviest fighting now, I only drop to 40fps.

Share this post


Link to post
Share on other sites

I have a brand new Amd Anthlon with a Dual Core Processor, and an Nvidia GeForce 7600 GT. This really helped me. My fps went from about 7 to 90-100.

Share this post


Link to post
Share on other sites
I think it's mainly for dual-core cpu's.

I run a Core2Duo, so the option shows up for me. It most certainly helps when I disable it. It yielded about a 20% increase in performance. This, along with disabling V-Synch in the WWIIOL config boosted my framerate signifigantly. The Vsync is odd in this game. It actually hurts my performance a lot. I was sitting around 25-30fps when it was enabled. After disabling it, I went up to 50-70fps. Even in the heaviest fighting now, I only drop to 40fps.

I have a dual-core CPU; a Core 2 Duo, just like you.

Like I said, I honestly see no difference whatsoever when this option is off or on. I have a single card, do you have SLI? Maybe that has something to do with it....

V-Sync always decreases performance and can decrease it either significantly or not too significantly depending on the game.

There is however a more fundamental problem with enabling VSync, and that is it can significantly reduce your overall framerate, often dropping your FPS to exactly 50% of the refresh rate.

http://www.tweakguides.com/Graphics_9.html

Share this post


Link to post
Share on other sites

I have a 7950GX2 card. So yeah, it's SLI.

Vertical sync is supposed to lock your gameplay to the monitor's refresh rate. It should NOT be dunking your framerate by 40+fps. Worst case scenario, it should drop you to 30fps at most, in the worst situation. But in WWIIOL, it would drop me down to 15fps and sometimes less. That indicates something is wrong.

Share this post


Link to post
Share on other sites
Specially with a 7950. If i buy something with for 500 dollars i expect it to run PERFECTLY!

You know what they say though - you're likely to bleed when standing on the cutting edge.

Share this post


Link to post
Share on other sites

i have a dual intel and i just tried this fix because the new drivers caused a FPS drop

the fx did not work - now instead of getting 30 FPS i get 14 FPS

Share this post


Link to post
Share on other sites

Has anyone tried setting the affinity to just one cpu, this may help as well. To do this, load up the game, Alt-tab out of the game while it is running. Pres ctrl-alt-del and go to processes. Right click on the wwiionlin exe and select affinity and uncheck one processor. This has worked for a number of other games on dual core processors.

H

Share this post


Link to post
Share on other sites
I have a 7950GX2 card. So yeah, it's SLI.

Vertical sync is supposed to lock your gameplay to the monitor's refresh rate. It should NOT be dunking your framerate by 40+fps. Worst case scenario, it should drop you to 30fps at most, in the worst situation. But in WWIIOL, it would drop me down to 15fps and sometimes less. That indicates something is wrong.

Nope.

Vertical sync absolutely *can* dunk your framerate by 40+ fps; in fact it can cut your FPS in HALF or even more.

I don't think you actually read the article I linked to. V-sync does MORE than just "locking your gameplay to the monitor's refresh rate".

http://www.tweakguides.com/Graphics_9.html

And anyway SLI has inferior performance in WWIIOL, many people seem to report this. Not sure exactly how the 7950GX2 works in that respect, but you might be screwed.

Share this post


Link to post
Share on other sites

Absolute success for me.

Example: offline practice, Allied SMG.

Threaded Optimization on: 14 FPS - 60FPS.

Threaded Optimization OFF: 80FPS - 200FPS (the higher being if you stare at the ground, in both these cases).

Another setting that helped me: I have two monitors, and I set the Hardware Acceleration setting to Single display performance mode rather than Multiple. That boosted FPS a bit for me too.

I have Vsync turned off, and am using the SSE2 Netcode 2 executable.

IN-GAME report: went from 8FPS - 25FPS max to 60FPS-80FPS in a crowded town. AWESOME!

My system:

AMD Opteron 170 (think X2 4000+) oc'd to 2.5Ghz from 2.0Ghz, Dual Core

2GB PC3200 @ 417Mhz, 2-3-3-7

BFG 6800 Ultra 256MB AGP not oc'd

XP Pro

Using the Nvidia 93.71 Drivers (latest on Nvidia site as of 12/20/06).

Share this post


Link to post
Share on other sites

THANK YOU :D

I have just gone back to my average before 1.24, im now back at average of 75 to 125fps through big and small towns this has definatly helped considering my old averages were between 25 and 55 depending on the day.

I have V-Sync Off, Water Shaders Off and have Netcode2 installed.

My System

Amd 3800 Dual Core

Asus A8N-SLI-Premium

2GB Corsair XMS-Matched

BFG 7900GT OC PCI-E

Share this post


Link to post
Share on other sites

I´ve got me a new machine:

E6700 Core2,

7950GT Video-card

Intel D975 XBX Board

2 GB Ram

I figured out, that when I start TS before the game, I have poor frames too, but when I launch TS after the game is up, then my frames never goes under 40 - usually I play with ~ 70 to 90 fps.

This was happened also before the new patch (1.25.0)was out.

Share this post


Link to post
Share on other sites
I have V-Sync Off, Water Shaders Off and have Netcode2 installed.

These and water reflection, can make a huge difference.

I don't see any real reason to have V-sync on in any case, so I always disable it in the drivers. Netcode2 is usually a good idea.

Share this post


Link to post
Share on other sites
I´ve got me a new machine:

E6700 Core2,

7950GT Video-card

Intel D975 XBX Board

2 GB Ram

I figured out, that when I start TS before the game, I have poor frames too, but when I launch TS after the game is up, then my frames never goes under 40 - usually I play with ~ 70 to 90 fps.

This was happened also before the new patch (1.25.0)was out.

I found exactly the same thing when we were on TS (thx I thought I was going mad :rolleyes:) but now that were on Ventrilo the FPS has increased again with even clearer comms. For a while I was running both while the Vent server was being tested for errors and doing it this way casued zero loss of any CPU or GPU performance ''it actually made FPS higher when 1st logging in''.

Share this post


Link to post
Share on other sites

Is anyone that implemented this fix running XP SP1?

I am still on SP1, and wondering how this is affecting me.

Share this post


Link to post
Share on other sites
Is anyone that implemented this fix running XP SP1?

I am still on SP1, and wondering how this is affecting me.

You should really consider upgrading to SP2. There are some serious security risks with SP1 that were fixed with SP2. If/when you do upgrade to SP2, you will need to update your video, sound and motherboard drivers.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.