Sign in to follow this  
Followers 0
GOPHUR

1.25 Installation - Please Read!

62 posts in this topic

The 1.25 release of WWIIOL will bring some changes for our Macintosh users. Please read this thread and post any questions you have in our Community Support Forum for the Mac.

Installing 1.25

1.25 will be a full install only for the Mac. The install will download as a .dmg disk mounted image and inside that will be contained a .pkg installation file. Pretty standard fare for the Mac.

This installation will be made to your Applications Folder. It will be an application titled World War ][ Online.

1.25 will not install in your Playnet folder in your Applications folder. We no longer use the Playnet folder and this can be safely removed from your computer in the future.

Running 1.25

in order to run 1.25 you will need to launch the application by double clicking its icon in much the same way you would launch any other OSX application. You can drag it to your Dock for easy access as well.

When you launch 1.25 you will be presented with a new window that is our new launcher for the Mac. From here you can elect to play online or off line or visit the training server. you can also change settings and enter your user name and password all on this one page.

Intel

1.25 has our first iteration of support for Intel Macs as well as PPC Macs all in one application package. You won't need to select anything at all to run this on an Intel Mac. You should be aware though that this translation still has some rough edges where our infantry animations are concerned. We are working with our partners to get these fixed up and will be upgrading our entire product (Win,IntelMac and PPC) to the new animation system at the first of the year and this should resolve any odd animations or infantry issues you might see such as the incredible technicolor K98K.

Preferences

Note that many of the game settings have been moved into the game and are now located on a preferences tab. Depending on your system some of these might not be available. For instance the language setting is not available on the Macintosh as we use your system settings there.

If you have any questions please post them in the this forum and we will be happy to assist you as we move into the new age of gaming on the Mac!

Share this post


Link to post
Share on other sites

Installed Full, 1.25.

Continual crashing, 5 times in a row, needed me to hold my power button, locked in crash.

My system:

Machine Name: Power Mac G5

Machine Model: PowerMac7,2

CPU Type: PowerPC 970 (2.2)

Number Of CPUs: 2

CPU Speed: 1.8 GHz

L2 Cache (per CPU): 512 KB

Memory: 2 GB

Bus Speed: 900 MHz

Boot ROM Version: 5.1.5f0

It defaulted me to the distorted screen, I fixed that to no avail (looked better). My rifle showed up three times as "rainbow" colors, mostly purples and blues. I can not play for longer than one minute without crashing. Last crash actually CTD'd, which is nice. Tried settings to Middle, not Best quality, so maybe thats why it played a full minute.

Can anyone help?

--------- others starting to complain about this ----------------

Share this post


Link to post
Share on other sites

I cannot figure out how to install it. I did download it! But It still has the playnet folder. does anyone have a screenshot so that i can figure this out? i deleted the playnet folder because i found WW][online in the main folder. But whenever click on it, it just quit the very second it opens.:mad: Im not satisfied.

Share this post


Link to post
Share on other sites
I cannot figure out how to install it. I did download it! But It still has the playnet folder. does anyone have a screenshot so that i can figure this out? i deleted the playnet folder because i found WW][online in the main folder. But whenever click on it' date= it just quit the very second it opens.:mad: Im not satisfied.

After DLing 1.25 you should have got a prompt to install the game, with a series of standard windows (where to install, license agreement, etc). After that, you should see the WWIIOL app in your applications folder. The installer does not remove the old Playnet folder.

Share this post


Link to post
Share on other sites

I think I might be screwed because I don't have Tiger. I only have 10.3.9 Is anyone else trying to run it on this OS?

Share this post


Link to post
Share on other sites

yes me! but when i go to the install page i "dl'ed" it. i installed it. but i deleted my playnet folder b4 i ever installed it. When it was done it made a new playnet folder..

Share this post


Link to post
Share on other sites

I installed 1.25, tried it unsuccessfully, and found the following in the console log:

dyld: /Applications/World War ][ Online.app/Contents/MacOS/World War ][ Online can't open library: /System/Library/Frameworks/OpenAL.framework/Versions/A/OpenAL (No such file or directory, errno = 2).

Is this because I am still using 10.3.9?

Share this post


Link to post
Share on other sites

1) Don't delete the Playnet folder before you DL 1.25.

2) You need 10.4 -- Tiger -- as far as I can tell, to play 1.25.

Share this post


Link to post
Share on other sites
1) Don't delete the Playnet folder before you DL 1.25.

2) You need 10.4 -- Tiger -- as far as I can tell, to play 1.25.

1: You should be able to delete the Playnet folder (save your screeshots if you want them!)

2: And yes, due to the new sound and video improvments you DO need 10.4.X

3: on a side note it's a known issue about the K98 rifle color

4: Some mac reload animations are totally botched, known issue

5: Be patient! This is HUGE update that was cranked out in very little time and is the first mac Unibin. There are known issues, and the Rats will be quick to fix them.

Share this post


Link to post
Share on other sites

I have downloaded the full mac version that goes well but when i launch game and it goes to auto patch it will download ok but at the end of install it says "nothing to install" Can anyone help me.

I'm OS 10.4. I've been playing now for over 4 years. Yikes!!

Thanks, Mark (sid41)

Share this post


Link to post
Share on other sites

Macpro 2 gigs, 2.6 x 2 etc

Greetings fellow disgruntled people.

Downloaded 1.25.2 (17.6 megs showing in apps folder).

Double clicked on app and nothing happens.

Are we destined to christmas without WWii online ? That would not be good.

Bodach (formerly denisgra)

Happy christmas Cyc and Sam

Share this post


Link to post
Share on other sites

As in Sid41's case, I downloaded the full Mac enchilada and tried the update.

The message read - you cannot continue, there is nothing to install.

I'm running 10.4.8 btw

Bodach

Share this post


Link to post
Share on other sites

I tried playing offline and all the new additions seem to be in place (17 pounder - nice one !). There are a few visual anomalies as previously described.

There seems to be a bug in the download patch or its interface with your new use of the traditional Mac installation software.

Good luck with a speedy fix.

May Santa visit you twice.

Bodach

Share this post


Link to post
Share on other sites
Macpro 2 gigs, 2.6 x 2 etc

Greetings fellow disgruntled people.

Downloaded 1.25.2 (17.6 megs showing in apps folder).

Double clicked on app and nothing happens.

Are we destined to christmas without WWii online ? That would not be good.

Bodach (formerly denisgra)

Happy christmas Cyc and Sam

1. Download the full 300+MB 1.25.0 install.

2. Install it.

3. Attempt to Play Online - You will go through 2 updates (1.25.1 and 1.25.2)

Share this post


Link to post
Share on other sites
As in Sid41's case, I downloaded the full Mac enchilada and tried the update.

The message read - you cannot continue, there is nothing to install.

I'm running 10.4.8 btw

Bodach

Just a suggestion: Delete everything and try to reinstall. Play OFF-Line. And then try to play on-line and go through the 2 updates.

GL.

Share this post


Link to post
Share on other sites

Powermac g5 dual 2.0 4 gig ram, 10.4.8 all updates os and battleground. I have not been able to complete 1 mission without getting a ctd, or hard machine freeze. I was not able to play for 1 than 3 minutes thursday eve, but this am after the 2 new patches i was able to play a lot longer, just before i freeze the game starts to hesitate then just when it seems to get back to normal speed, bam ctd. I don't want to sound like a #$%@ but this happens everytime we get a patch. I cringe when I log on and see an update, I wonder what will happen, will the patch refuse to load, will I ctd, will my trees be like I just took a hit of acid. I would rather see you guys take your time and get it right than rush. Nothing is more frustrating than to work all day wanting to kill everyone you see then to get home and not be able to kill virtually. I have to go now, I have a dog to beat. BTW my dog hates it when you release patches too.

Share this post


Link to post
Share on other sites

Thanks for input Grendel - however - no joy - did as you suggested including deletes of old stuff.

I got the same result - ie the message that reads.....

you cannot continue, there is nothing to install.

BBL

S! Bodach

Share this post


Link to post
Share on other sites

Forget the regular Mac install - it is not seeing the .dmg on the desktop. Double click the .dmg file instead and it will go about its business as intended.

The game would not get past login on startup so I aborted and retarted the game. Then it was fine. Played for 45 mins or so, no crashes, no weirdness, nice fps (finally).

Getting 18 fps - wow !

Bodach S!

Share this post


Link to post
Share on other sites

The installer won't ask you to authenticate if you are not an admin user and you try to install to the Applications folder. You can either log in as a user with admin privileges, or install the game into your home directory.

Share this post


Link to post
Share on other sites
Forget the regular Mac install - it is not seeing the .dmg on the desktop. Double click the .dmg file instead and it will go about its business as intended.

The game would not get past login on startup so I aborted and retarted the game. Then it was fine. Played for 45 mins or so, no crashes, no weirdness, nice fps (finally).

Getting 18 fps - wow !

Bodach S!

Hey Denis, good to see you got in! Happy holidays!

Share this post


Link to post
Share on other sites

Anybody also have the following problem. Downloaded third patch. When I go to play, screnn goes all black and nothing happens.

Share this post


Link to post
Share on other sites

Dowloaded 1.25 and the 2 new patches - actually played once.

Tried to log in last night and had to download new patch which has essentially locked me out of game play - freezes on log in and eventually locks my whole system.

G5

os 10.4.8

2 x 250 GB

8 GB RAM

Share this post


Link to post
Share on other sites

Don't forget if something doesn't work or load on osx always do a permissions check from diskutility located in the utilities folder in your applications folder, if you have never moved it, it should be there.

Share this post


Link to post
Share on other sites

Hello, I downloaded the full install as directed. When the new screen lauched and I login, I keep getting "game is out of date" and patch downloads. this happens everytime I login. Unlike before, after the download the patch is not verified and I am not entered into the game. Uhggg.

Help

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.