Sign in to follow this  
Followers 0
Guest Sharatan

Trouble starting game with Vista

45 posts in this topic

I have recently installed Vista Business Edition onto my computer and am having trouble booting up the game.

At first It would crash to Desktop almost right away. I searched around a bit and tried turning off sse2. That got it so the loading bar will now make it to the very end and then crashing to desktop.

Anyone know of any fix for this or can vista just not run the game?

Share this post


Link to post
Share on other sites

Some people have managed to get the game working under Vista, but that OS is not officially supported yet.

The most common problem running under Vista has been the availability of bug-free drivers. You might be able to narrow down the source of the problem by turning off the game sound. To turn off the sound, find the file named wwiiol.xml in your Battleground Europe > Data folder. Open that file with Notepad and find the line that says . Changing the value from "true" to "false" will turn off sounds. If you don't see that line in the xml file, it should work if you copy and paste from this thread and change the value to "false".

Share this post


Link to post
Share on other sites

I tried turning off sound but it didn't make any difference. I'm really at a loss at what could be causing this :/

Share this post


Link to post
Share on other sites

I'm about to purchase Vista ultimate but will most likely be dual-booting it with my current xp setup. The rats had stated that they will try to get it working with Vista, but I'm sure they have other priorities. Is the firewall blocking the application?

Share this post


Link to post
Share on other sites

To get it to run in vista x64 ultimate, dont do the 32bit compatability method, and dont use sse2 (big no-no) make sure u get the latest directx also, and drivers for video card, sound and motherboards. I had to edit the wwii settings file a few times in trial and error to get it to run so if your still having probs tell me where its stopping on the loading bar and what the outcome of the prob is ill try help more.

Share this post


Link to post
Share on other sites

Zeffer, can u help me get the game working with vista?

My bar loads until the end (but it takes 10 minutes) and it took 30-60s on win xip and then crashes to desktop.

What should i to? I have Compatibility mode and run as adm checked.

Thx mate.

Share this post


Link to post
Share on other sites

There are still not functional drivers released to vista for many cards.

Make sure that all drivers are up to date but even so for example creative has only released crappy beta drivers.

Share this post


Link to post
Share on other sites

Ya, i have messed around a bit to no avail. It is consistently crashing to desktop at "Initializing Objects" right near the end of loading though. I have all of my drivers installed though so i am pretty sure its not that.

Share this post


Link to post
Share on other sites
Ya' date=' i have messed around a bit to no avail. It is consistently crashing to desktop at "Initializing Objects" right near the end of loading though. I have all of my drivers installed though so i am pretty sure its not that.[/quote']

I have the same problem.

Share this post


Link to post
Share on other sites

If your not using a seperate sound card for gaming (big resource hog for onboard audio), Then try disabling the onboard audio and see if the game boots.

I can't remember where but I've read somewhere about a problem with AC97 and Vista.

Share this post


Link to post
Share on other sites

SEE is disabled.

Would i get better FPS if i had a creative soundcard instead of using onboard sound?

EDIT: I cant disable sound on settings. it only allow me to choose btw primary sound and nvidia one. Crashes using both configs.

Share this post


Link to post
Share on other sites

no no...we mean disable the sound card in windows or even better in the bios. At the moment most ppl having problems in vista are having sound issues - once it is turned off the game works fine.

Share this post


Link to post
Share on other sites

I have tried disabling both sound (btw i don't use onboard sound, I use Creative SB Audigy 2) and SSE. When i first started it would CTD right away, then i disabled SSE and I am at where I am now: Crashing at the end while "Initializing Objects", while turning sound off/on doesn't make any difference.

Share this post


Link to post
Share on other sites

I've still only seen 2 ppl state they got it running (half arsed perfomance apparently).

I double checked and SB still has beta drivers only (released 1/12/07) up on their site and the more it looks, sound (onboard and card) are still a big iffy for Vista.

Realtek apparently has released some new drivers from what I hear on 1/24/07 for those with onboard audio. http://www.realtek.com.tw/default.aspx

Junglebr, you said earlier in thread that you didn't use a audigy so I assume your using an onboard resource hog and might want to check into that realtek sight if that's what you have I guess. Not sure what else to suggest to you.

Zeffer was one of the folks I've seen. Can't find a thread where the other person got it working.

Share this post


Link to post
Share on other sites

I've been using Vista ultimate on a dual boot system and run the game on both Vista and xp pro. The problem in Vista are the beta sound blaster drivers. I see a marked fps drop of 5 -15 when using sound with these drivers vs sound disabled. The fps with sound disabled is the same as playing in xp pro with sound enabled. I'm sure the next sound blaster drivers will fix this problem. Other than that I'm not having any problems with vista. I suggest using a good sound card to take that load off of the CPU. And with Vista you should bump the RAM to 2 gig as it's a bit of a memory hog. Best of luck.

Share this post


Link to post
Share on other sites

You cannot disable sounds in "settings" but you can disable sound friom the Personna or the Brigade screen. Bring up the map and click on the settings tab (think it is still called settings).

Click on Sound System and select disable.

Fair warning though: I tried all those tricks while beta testing Vista. After three weeks of frustration I surrendered and crawled back to good old WinXP with hat in hand.

Share this post


Link to post
Share on other sites

Personally IMHO this has not much to do with VISTA itself.

I have normal XP but I have exactly the same problem where I will wait for ages while the game loads "Initialitzing objects" and then CTD while all other games work perfect.

I have a new dual core 6400 and a new 7900GT and I just do not know what to do. I made a huge thread two weeks ago here and no one could help me.

From reading here it seems my problem looks very similarly to others and it seems we are all a bit lost on how to fix this common problem.

Share this post


Link to post
Share on other sites

Ok, i fixed 1 problem, but i got another one.

The game wasnt loading because i use an ATI card (X800XT) and there was NO opengl support until yesterday (ati released new drivers). But when it load screen is gone it opens that page telling me there is no pool. The annoying thing is that i CANT move my mouse on the game and cant click OK. lol. Anyone know what this might be?

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.