Jump to content
Welcome to the virtual battlefield, Guest!

World War II Online is a Massively Multiplayer Online First Person Shooter based in Western Europe between 1939 and 1943. Through land, sea, and air combat using a ultra-realistic game engine, combined with a strategic layer, in the largest game world ever created - We offer the best WWII simulation experience around.

Mac Version 1.34.10 Reports


TGUNR
 Share

Recommended Posts

====

What's the path for the folder?

====

The cfml directory is in /Users/yourusername/Library/Preferences/ww2ol, however, for OS 10.10.1 the 'Library' directory is hidden and you have to hold a key down to see it - then you can move files there.

====

*** But, I have a white screen when I alt tab out, can't get back to game?

====

Found the solution here - in the readme file; have to change screen resolutions and then go back to game.

Link to comment
Share on other sites

  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

  • ZEBBEEE

    4

  • dog3

    8

  • Kyotee

    5

  • delems

    11

Top Posters In This Topic

  • CORNERED RAT

I have problems with the collision model. When I climb stairs or on a roof I can not always move forward and have to juggle between standing positions , sitting or lying . Also in a depot I will pass through the floor as soon as the building is under enemy fire (explosions).

Anyone else having this on Mac ?

Link to comment
Share on other sites

====

I have problems with the collision model.....

====

That sounds like the offset bug - everyone gets it when you spawn in a number of times at a busy town. The fix is to restart or often you can just go to a town far far far away from where you are and spawn into the game world as something there. Then go back to where you were.

I usually go the the E side of the map and spawn a LW rifle or to the N side of the map and spawn a KM rifle.

Link to comment
Share on other sites

Two items here.

First, when at the brigade tab where you expand division detail - the little '+' boxes no longer show when expanded. So, makes it hard to tell where to click. They do show when collapsed.

Second, twice, on what I think are longer missions, I lose my own weapon sounds but can hear everything else. So, when I fire my rifle - silence. Not sure how repeatable, only noticed it two times so far, but something to watch for and I'll try and keep tabs on it too.

Link to comment
Share on other sites

I can get my joystick working but not my Pedals.

CH Products Fighterstick and Ch Products pedals.

iMac Info:

iMac (27-inch, Late 2013)

MAC OS: 10.10.1 (14B25))

Processor: 3.4 GHz Intel Core i5

Memory: 8 GB RAM

Graphics: NVIDIA GeForce GTX 775M 2 GB

Link to comment
Share on other sites

I can get my joystick working but not my Pedals.

CH Products Fighterstick and Ch Products pedals.

iMac Info:

iMac (27-inch, Late 2013)

MAC OS: 10.10.1 (14B25))

Processor: 3.4 GHz Intel Core i5

Memory: 8 GB RAM

Graphics: NVIDIA GeForce GTX 775M 2 GB

How did you fix the trigger mapped to ESCAPE key problem??? And also lets NOT forget the mapping of joystick buttons to Fn keys, that might create all sorts of other problems.

Link to comment
Share on other sites

  • CORNERED RAT

On Mac I still can't launch Playgate twice to run 2 accounts (I can't with the 1.34.9 neither)

However I can if I now use the two Playgate : I launch one account in 1.34.10 and one in 1.34.9. Pretty weird to hear different sounds for the same event though but at least that work.

Link to comment
Share on other sites

====

What's the path for the folder?

====

The cfml directory is in /Users/yourusername/Library/Preferences/ww2ol, however, for OS 10.10.1 the 'Library' directory is hidden and you have to hold a key down to see it - then you can move files there.

====

*** But, I have a white screen when I alt tab out, can't get back to game?

====

Found the solution here - in the readme file; have to change screen resolutions and then go back to game.

ah...and the magic key holding is?

:D

Link to comment
Share on other sites

lol - I forgot already, think it is option key, maybe the command key. One of those, I just searched apple forums to find it.

Found it, hold the option(alt) key down while going to finder menu after selecting your username in finder.

Link to comment
Share on other sites

This is a very poor way for me to track issues Dave. Eeek. Sounds like some serious issues with the mac.

Here's my list:

- Joystick mapping

- Only supported OSX10.9+

- Lots of little misc issues that I'm unsure about.

Link to comment
Share on other sites

This is a very poor way for me to track issues Dave. Eeek. Sounds like some serious issues with the mac.

Here's my list:

- Joystick mapping

- Only supported OSX10.9+

- Lots of little misc issues that I'm unsure about.

add:

-waypoint labels

Link to comment
Share on other sites

Hi evry1

There is a problem when you minimise the game or hiding the app (command H) the game froze and show white screen

this also happen in the old version but with out the white screen

Also stamina drain so fast, not sure if that is a new feature but its definitely different from 1.34.9 version and its annoying :mad:

Edited by ksa43
Link to comment
Share on other sites

  • CORNERED RAT
Hi evry1

There is a problem when you minimise the game or hiding the app (command H) the game froze and show white screen

this also happen in the old version but with out the white screen

Also stamina drain so fast, not sure if that is a new feature but its definitely different from 1.34.9 version and its annoying :mad:

Read the...readme, n00b :rolleyes:

1. Stamina reduced for heavy weapons.

2. White screen is a known bug and easily fixed :

1.34.10.9 Release Notes

Command-Tab causes white screen

If you command tab out of the game you will encounter a white screen. The game is still running and if you want to get the screen back without relaunching there is a workaround until we get it fixed. The basic solution is to change your screen resolution and the screen will reappear. Two ways to do this:

1. Open your System Preferences, select Display, change resolution, change it back to original. Now click in the game window and nothing else, you should be back in the game.

2. Download and install Display Menu at http://displaymenu.milchimgemuesefach.de/ features.html#retina and use it to switch resolutions.

Link to comment
Share on other sites

Thx zebbeee however I'm not noob and I would not read the readme because I never did :D

2nd the computer sleeps during the game ... I know I can turn the sleep feature off but this never happend on the old version, any help?

Link to comment
Share on other sites

With the new campaign about to start, was the joystick-fire-button-mapping-to-escape problem ever resolved?

s!

Link to comment
Share on other sites

Not yet. That's why we didn't release though AHWULF said there was a simple fix like setting something in the keymapper and restarting. Dunno bout that.

I'll ask.

Link to comment
Share on other sites

Not yet. That's why we didn't release though AHWULF said there was a simple fix like setting something in the keymapper and restarting. Dunno bout that.

I'll ask.

"keymapper" seems to map joystick keys to function keys. Neither the keymapper nor direct editting of the cfml files works for me.

Link to comment
Share on other sites

"keymapper" seems to map joystick keys to function keys. Neither the keymapper nor direct editting of the cfml files works for me.

Still not resolved. There still is a problem with the Mac update recognizing the Joystick/pedals.

After I upgraded to OS 10.10.1 the old MAC client was not recognizing the joystick/pedals either.

Link to comment
Share on other sites

Still not resolved. There still is a problem with the Mac update recognizing the Joystick/pedals.

After I upgraded to OS 10.10.1 the old MAC client was not recognizing the joystick/pedals either.

Hmmm... I'm on a MacPro with Yosemite and never had problem with old client. Old client recognizes CH Products fighterstick/pedals/throttles fine. New client has problems but old client works fine for me.

config: MacPro5,1 (Mid 2010), 10.10.1 (14B25), ATI Radeon HD 5870 1024 MB

USB info from "system report":

CH FIGHTERSTICK USB:

Product ID: 0x00f3

Vendor ID: 0x068e

Version: 0.00

Speed: Up to 1.5 Mb/sec

Manufacturer: CH PRODUCTS

CH PRO THROTTLE USB:

Product ID: 0x00f1

Vendor ID: 0x068e

Version: 0.00

Speed: Up to 1.5 Mb/sec

Manufacturer: CH PRODUCTS

CH PRO PEDALS USB:

Product ID: 0x00f2

Vendor ID: 0x068e

Version: 0.00

Speed: Up to 1.5 Mb/sec

Manufacturer: CH PRODUCTS

Link to comment
Share on other sites

Ok,I have my stupid head on at the moment,I went to download the new version,but every time i get 134.9 ver dmg?.

where do i get the new version.............damn...not even drinking yet!!

Edited by zerstorer
Link to comment
Share on other sites

Ok,I have my stupid head on at the moment,I went to download the new version,but every time i get 134.9 ver dmg?.

where do i get the new version.............damn...not even drinking yet!!

Link to comment
Share on other sites

Problem:

Logitech extreme 3d pro will not map correctly when setting up airplanes in the latest mac beta.

Joystick 1 button always activates “esc” key.

Other buttons key to the function keys.

Attempts to rectify the situation:

Hit Pram, reconfigured js many times….no affect.

1. Uninstalled game, installed old version….preferences worked.

2. Uninstalled old version, installed new version.

3. Found all hidden files in library for system and user, preference. Replaced all preferences with older version preferences.

4. Checked all air related cfml files for proper syntax, i.e. that js button one was keyed to primary trigger.

None of this changed the situation.

Attempt 2

partial success.

Instead of using the js on joystick 1 in settings I assigned the joystick to joystick 2 and recalibrate.

The results:

I could key map all buttons on the joystick properly…i.e. primary firing trigger to joystick 2 button 1.

All button’s could be mapped. they being changed from joystick 1 to joystick 2 in the key mapper.

HOWEVER, the yaw, pitch etc…could not be set this way. they remained assigned to joystick 1 and could not be changed.

In summary:

In preferences using the joystick 1 assignment for the logitech js would allow normal stick assignment for movement but no proper key mapping, default trigger activated “esc” key always.

In preferences using the joystick 2 assignment for the logitech js this would allow proper key mapping for joystick buttons but the navigation functions for the stick remained greyed out and in active.

I tried having the js work while assigned to both js 1 and js 2 in preferences but it just defaulted to the state of js 2.

I have no idea if this information will help but perhaps there’s something weird with my computer, the new beta.

All works fine on the previous game versions.

Link to comment
Share on other sites

I tried the old client today, it works fine.

That's under the latest OS X update.

Edited by dragoz
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.

×
×
  • Create New...