Jump to content
Welcome to the virtual battlefield, Guest!

World War II Online is a Massively Multiplayer Online First Person Shooter based in Western Europe between 1939 and 1943. Through land, sea, and air combat using a ultra-realistic game engine, combined with a strategic layer, in the largest game world ever created - We offer the best WWII simulation experience around.

unable to fire


papagaeio
 Share

Recommended Posts

This has been on and off for a while, but 4 times today in a short space of time.
Stepping out into a road to perfectly line up rifle sights on opel... click... nothing. and nothing again until I go to map or go prone or make some gesture of changing what i am trying to do.
Just now - waiting for an ei who I hear coming into my building. Perfectly lined up as he walks in the door and... nothing... I get killed after a second when he realises I'm even there.
Also running to efms with a satchel and just refusing to place it until I lie down for a bit, or look at my map.
It happens too often (and to be fair, almost every rifle shot missed is too much when you're aiming) and is genuinely too frustrating for me to play on after a couple of times in a row.

It feels a bit like the old "stuck in prone" situation where the key (fire/change position) is not registering at all for some time, until it logs that you've gone back to trying that key (fire/change position).
 

Link to comment
Share on other sites

Mingus had that issue in his 109s as soon as a EA got into gun view nothing out of solution again gun fired fine. 

Unfortunately I think we lost Mingus and he left the game due to that issue and no help.

Link to comment
Share on other sites

i relaod all my weapns 1st  thing  do to this..  it hapens with riftles also btw 

Link to comment
Share on other sites

  • CORNERED RAT

Our grandkids usualy stay with us on the weekends. Our granddaughter rushed into the living room one evening "there's a wasp in my room". She is allergic to wasp venom so this was serious. I get the swatter and go to kill the wasp but no wasp can be found. I don't doubt that there is a wasp in the room but it's landed somewhere and although I seemingly swat and shake every picture on the wall and the curtains and blinds....no wasp. I go back to watching TV and in a bit she's back "the wasp is flying around the ceiling fan" I go to kill the wasp, no wasp. Eventually, after another incident or 2 I finally do meet the wasp and dispatch him. 

Until I could see the wasp, I couldn't do anything about it. I did not doubt the it was in that room but I had no way of making it appear because I couldn't find it.

I have no doubt this "can't fire" bug is a real thing. To my knowledge none of us (CRS) have experienced it. Without a replication method it's like shooting in the dark without anything to go on other than it's out there somewhere.

 

Link to comment
Share on other sites

Worked with Mingus on this problem of his and after deleting  the game, deleting the directories, He went and installed it on a different Drive, Drive D.

After installing it on a different drive, it fixed the problem.

 

Link to comment
Share on other sites

  • CORNERED RAT
6 minutes ago, Rws said:

Worked with Mingus on this problem of his and after deleting  the game, deleting the directories, He went and installed it on a different Drive, Drive D.

After installing it on a different drive, it fixed the problem.

 

Ok, that's more than we've had to date. Not sure why using a different drive would affect it but it's info. I don't mention different drives to doubt, just that I have various dev versions scattered across 2 ssds and a old style HD and couldn't replicate it. 

 

I'll add this info to the ticket

 

Link to comment
Share on other sites

may have been an old cfml file or something that didn't get over written on big updates. Guess a guess.

Link to comment
Share on other sites

  • CORNERED RAT
1 minute ago, Rws said:

may have been an old cfml file or something that didn't get over written on big updates. Guess a guess.

The only update that ever touched the folder cfmls live in was the one that changes the directory from "documents/battleground Europe" to "documents/wwiiOnline"

And until you OK it to copy that battle ground Europe folder and recreate it as wwiionline it uses the former. But we've never overwritten cfml files.

Link to comment
Share on other sites

  • CORNERED RAT

Just kinda thinking out loud here.....

Those having this issue, all on windows 10?

I'm wondering if a win10 xbox feature maybe conflicting or something. Just trying to dig for some sort of clue

 

Link to comment
Share on other sites

  • CORNERED RAT

Those having this issue, when you last installed did you select/check the box to update the visual studio stuff? There are 3 check boxes on the installer, visual studio/directx/desktop shortcut.

Link to comment
Share on other sites

This bug drove me nuts. Yes, RWS gave me the pointer to install elsewhere. I did that.  But at the same time, I did go into windows ( as per a tutorial for another VR flight sim to turn of some windows functions to make windows work better for that game. I turned off all the XBox BS) I dunno what did it. But I havent had the problem since.  That being said, I only had this problem in the air in planes, (Both axis and allied) and it only wouldnt fire the moment the enemy was in the sight and the trigger pull could only result in a hit.) If i pulled trigger a milisecond before or after, guns would fire.   I dont know why or how it was fixed. but I havent had it happen again.

Link to comment
Share on other sites

  • CORNERED RAT

The win 10 xbox stuff is what I'm kinda curious about. When nvidia 1st came out with shadowplay it wouldn't work with the xbox recorder enabled.

That's more info :)

 

Link to comment
Share on other sites

2 hours ago, mingus said:

This bug drove me nuts. Yes, RWS gave me the pointer to install elsewhere. I did that.  But at the same time, I did go into windows ( as per a tutorial for another VR flight sim to turn of some windows functions to make windows work better for that game. I turned off all the XBox BS) I dunno what did it. But I havent had the problem since.  That being said, I only had this problem in the air in planes, (Both axis and allied) and it only wouldnt fire the moment the enemy was in the sight and the trigger pull could only result in a hit.) If i pulled trigger a milisecond before or after, guns would fire.   I dont know why or how it was fixed. but I havent had it happen again.

I to had this problem of no fire when in the gun site, ive built a new PC, have still got it a couple time but not near as often as I used to, it is frustrating as soon as the target entered gunsite guns would stop shooting and once out of the site would start firing again I thought it was a side biased thing...lol (windows 10 nvidia card) so we can mabye start tracking it down.

Link to comment
Share on other sites

On 5/14/2020 at 4:08 AM, papagaeio said:

This has been on and off for a while, but 4 times today in a short space of time.
Stepping out into a road to perfectly line up rifle sights on opel... click... nothing. and nothing again until I go to map or go prone or make some gesture of changing what i am trying to do.
Just now - waiting for an ei who I hear coming into my building. Perfectly lined up as he walks in the door and... nothing... I get killed after a second when he realises I'm even there.
Also running to efms with a satchel and just refusing to place it until I lie down for a bit, or look at my map.
It happens too often (and to be fair, almost every rifle shot missed is too much when you're aiming) and is genuinely too frustrating for me to play on after a couple of times in a row.

It feels a bit like the old "stuck in prone" situation where the key (fire/change position) is not registering at all for some time, until it logs that you've gone back to trying that key (fire/change position).
 

Stupidly annoying and frustrating. Needs fixing and resolution-along with the other bugs (as mentioned)

Link to comment
Share on other sites

Maybe it has to do with Windows 10 and the Xbox program that could record your game play.  After all what's the one thing one does want to record in a battle Sim game are the kills . 

Just throwing it out there. How does one turn off all that Xbox stuff anyhow?

Link to comment
Share on other sites

I'm on Windows 10, but no Xbox recording (it's given as an option and I have no desire to record anything. Saying that - I probably should).
Its a really pronounced issue. Clearly not connected to the mouse. And it's the "fire" command as a whole, as it happens with grenades, satchels, rifle.
Interestingly - not with AA or ATG. But those 3 are all I play.
Sometimes switching weapons doesn't even fix it so it may even be a set amount of time I am unable to fire.

I can't offer much more info on it at the moment (though it hasn't happened for 2 days) but I felt it worth mentioning, of course.

Link to comment
Share on other sites

On 5/20/2020 at 8:17 AM, mingus said:

This bug drove me nuts. Yes, RWS gave me the pointer to install elsewhere. I did that.  But at the same time, I did go into windows ( as per a tutorial for another VR flight sim to turn of some windows functions to make windows work better for that game. I turned off all the XBox BS) I dunno what did it. But I havent had the problem since.  That being said, I only had this problem in the air in planes, (Both axis and allied) and it only wouldnt fire the moment the enemy was in the sight and the trigger pull could only result in a hit.) If i pulled trigger a milisecond before or after, guns would fire.   I dont know why or how it was fixed. but I havent had it happen again.

Now you say that - I am convinced it only happens to my rifle when I have the target bang in my sights. 
Not sure how that transfers to nades or satchels - as satchels can't be placed in air, and I'd not know if my nade was going to do damage.
But for the rifle - It does always seem to be one of those "oh COME ON.... NOW????" moments when I'm in a milisecond window of getting a kill.

Link to comment
Share on other sites

I think its to do with prone/stand/crouch mechanics because it usually happens not long after one of those, like going under a murderhole for example.
And i've had it with grenades too where the grenade throw,s but on a delay and he throws under arm, usually ending up in killing or hurting your own guy.

Edited by saffroli
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...