Jump to content
Welcome to the virtual battlefield, Guest!

World War II Online is a Massively Multiplayer Online First Person Shooter based in Western Europe between 1939 and 1943. Through land, sea, and air combat using a ultra-realistic game engine, combined with a strategic layer, in the largest game world ever created - We offer the best WWII simulation experience around.

Gun fire / Grenade throw stops working


Recommended Posts

So I'm in Spa helping defend the Spa-Verviers CP. Under heavy attack. I'm beretta smg, and I've killed a couple of EI and barely managed not to be killed, after several minutes. I'm upstairs. EI enters the building and I try to throw a nade (like I did a minute or so before). But it won't throw. Switch back to gun and realize to my horror it won't shoot. 

Switch back to nade, won't throw. Go to map and then quickly flip back, just to try to 'reset' things (the EI is upstairs w/ me now but doesn't see me). Try to shoot and nothing happens. Switch to nade nothing happens. Movement and everything else working fine. WE STILL HOLD THE DEPOT. It's still our CP and I can't shoot at anyone (I realize that shouldn't matter anyway, but this at least rules out some sort of bug that would mistakenly have me in a depot that had switched hands. In fact I was in the CP, and it hadn't switched hands anyway). A second EI runs upstairs. He doesn't see me either(!), incredibly. I finally just despawn cuz I cant shoot or do anything offensive. 

We lose the CP, our spawnable, immediately after that and the town soon thereafter. 

What is/are the possible reason(s) for this glitch? I was so disgusted, I logged right after. Huge bummer when you're doing what you're supposed to do and something like that happens. 


Edited by hillstorm
Link to comment
Share on other sites

I still get that. Usually when I am right on target. Lining up a shot on an opel driver or ei. 
Just nothing happens. the mouse button doesn't register. 
Sometimes i only have to shoot a round up into the air, then I can shoot at a target again.
It almost ALWAYS happens with satchels as well. If i get to an efms with rifle satch. Just can't place it. I stand there waving it about in the air. Sometimes going prone and up again fixes it.

Also with grenades. HE not SMK. So it seems linked to something thinking I am not allowed to cause damage.

As I say - with rifle it seems to only happen when I am confident I am going to get a hit. Target fully in sights. And nothing... it's so frustrating.

  • Like 1
Link to comment
Share on other sites

8 hours ago, undercova said:

Prone and get up again. Fixed it for me.

Had this bug for months every now and then.


Hmm that's right. Now that you mention it, I was plagued by this for a long time too, but it’s been a while and I forgot about the remedy. I thought it was to switch weapons, but obviously that isn’t it (so I was thinking it was  a new/different bug). In this case, I was already prone - but probably if I'd stood up, it would have released my weapon. That's the one thing I didn't try ... because EI was on the other side of the room and hadn’t seen me yet. However, I likely also would have died immediately, we were in a blown CP with ET pouring on the MG fire so I was staying down. Not to mention the EI in front of me and one about to join him from downstairs. 

This was happening to me a lot in the past and hadn't happened in a while. I've even changed computers since the last time it happened, and I hoped it was behind me. Guess not, and I guess it's not linked to a bug that's particular to a computer. 

Very important to fix because it can be a particularly fatal bug. When you need your gun to shoot, you’re often in a vulnerable or compromised position. 

Edited by hillstorm
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...