Jump to content
Welcome to the virtual battlefield, Guest!

World War II Online is a Massively Multiplayer Online First Person Shooter based in Western Europe between 1939 and 1943. Through land, sea, and air combat using a ultra-realistic game engine, combined with a strategic layer, in the largest game world ever created - We offer the best WWII simulation experience around.

Feedback - Lowered fps in 1.33


Fabao
 Share

Recommended Posts

Hi Ahwulf,

Again , thanks for your reply.

I cant comment personally on whether these issues happened in Beta as I did not participate , but here is some more info.

One member of our squad done a test tonight by gradually switching off components of the HUD and measuring FPS improvements , first chat then map so on so forth until nothing was on the screen.

From what I can gather on TS he had an initial improvement of 9 FPS with one component off then another improvement of up to 20 FPS with everything off.

So then I tried the following to quickly measure FPS 'spikes' , I switched off all HUD displays waited about 5 seconds then flicked them back on and quickly tried to notice the FPS.

What occurred was an initial FPS of sub 20 with everything on to a spike of over 100 FPS just after the HUD was brought back , this then settled back to the now normal FPS of 20 and lower.

I tried this on a few occasions to measure if indeed this was a pattern and it would seem that FPS is significantly improved , whether this is the main issue though is up to you guys :)

This test was conducted by a very quiet FB with no AF or other players in view.

Both of us have Intel processors.

Having the HUD off while in game though is by far not an ideal situation and probably a game killer for a lot of squad play.

Thanks again.

Edited by expatpom
Link to comment
Share on other sites

  • Replies 194
  • Created
  • Last Reply

Top Posters In This Topic

  • GOPHUR

    18

  • AHWULF

    30

  • geckopow

    11

  • expatpom

    12

Must admit since 1.33 I've found the game almost unplayable with fps of 2 in most battles- even out of town I'm only getting 15-17 max. Yes I'm not on the worlds best computer but I never had these problems with 1.32

Link to comment
Share on other sites

I have noticed once i get fps jerking if i turn off the entire hud it becomes semi playable' date=' there is a noticeable difference though.[/quote'] Same here, HUD on major FPS decrease, but when I turn off everything ''Y'' is make a extreme noticeable difference, which allows it to become playable, well from my point of view anyways, it works!
Link to comment
Share on other sites

Measuring FPS by flicking the HUD back on is probably not useful as you won't see the FPS from before the HUD was on.

FRAPS is probably the only way to see FPS with the HUD off.

What's odd is I never see any difference. There must be some common thread among HUD FPS victims.

Link to comment
Share on other sites

  • CORNERED RAT

I've checked with everything set for preformance, vid settings no aa/anistropic and game shaders off to everything on vid and game wise.

All the difference I see between screen elements on vrs off is 1 fps difference reguardless of game or vid settings useing fraps to show fps.

I got no idea what they doin to get a dift result.

Link to comment
Share on other sites

On my iMac i measured the ms time for having the hud and map up

Offline

HUD 25ms

No HUD 24ms

HUD + Map 26ms

thus the cost of the HUD is around 1ms per frame, the map is 0.5-2ms more depending on the zoom and where you are

this is on an i5 2.8Gz ATI Radeon HD 5750 OSX

there *has* to be some common factor for those with frame rate loss

Link to comment
Share on other sites

Hi There,

Thanks again for your reply.

The FPS increase was achieved through pressing 'Y' so all screen displays apart from the game goes off.

I reckon I might be able to screenshot the FPS difference before and just after it comes back to show you the FPS difference as it does show the FPS improvement momentarily before reverting back to the slideshow FPS :)

Link to comment
Share on other sites

  • CORNERED RAT
Hi There,

Thanks again for your reply.

The FPS increase was achieved through pressing 'Y' so all screen displays apart from the game goes off.

I reckon I might be able to screenshot the FPS difference before and just after it comes back to show you the FPS difference as it does show the FPS improvement momentarily before reverting back to the slideshow FPS :)

I think what you are seeing is more a slight bug with the ingame fps tool.

I suspect that toggling it off then on via y key is causing it to show a false spike in the reading.

A surer test would be to use Fraps to record fps while toggling the y key.

http://www.fraps.com/download.php Free 2.2meg D/L for the trial version.

You only need to start fraps, then when you load BE fraps will start displaying your fps.

Link to comment
Share on other sites

Agree with OldZeke. You have no way of knowing what your hud off fps is without using an outside tool unless of course you are turning them off in preferences and not using the toggle.

Link to comment
Share on other sites

Well turning off HuD for me does help with stutters and frames, noticeably. Its so tangible i dont need an fps counter to tell. About 10-20 frames steady, more when flying.

Link to comment
Share on other sites

Hi There,

Thanks again for your reply.

The FPS increase was achieved through pressing 'Y' so all screen displays apart from the game goes off.

I reckon I might be able to screenshot the FPS difference before and just after it comes back to show you the FPS difference as it does show the FPS improvement momentarily before reverting back to the slideshow FPS :)

This.

Link to comment
Share on other sites

Using Fraps, in Champlon looking west in town, during a battle.

MAP and HUD on = 31fps

HUD on, MAP off = 40fps

HUD off, map off = 63fps

HUD off, map on = 38fps

Strange bag of results, but hud and map seem to be having quite a impact on my performance.

AMD pheonom quad 3ghz

Nvidia GTx460

4gb ram

xifi soundcard

win 7 64bit

EDIT: Also, loading game takes a lot longer for me now too, with 1.33, expected fucntionality?

Edited by geckopow
some more info
Link to comment
Share on other sites

Xp home 32 bit

Athlon 64 single core clocked at 2.8ghz

2 GB DDR 400

Nvidia gtx 465 1 gb

Audigy 2 ZS sound card

I got a fps hit with 1.33, definitely helps to turn off HUD.

Link to comment
Share on other sites

Anyone see this kind of drop on Intel? Or is it just AMD people?

Mine is an i5.

Link to comment
Share on other sites

Both the other squad member who done the tests and myself run Intel Ahwulf.

I detailed in an earlier posts his and mine improvements with the map/hud/chat off of the screen its nice to see others have also the same FPS improvements.

Confirms I am not going mad also eh :D

Edited by expatpom
Link to comment
Share on other sites

Still there *has* to be a common something between those who get the issue and those who don't. My i5 (Mac) has no drop of any kind with HUD or map. Neither did my Quad Core 2 Duo PC with it's crappy video card.

Very confusing problem since there seems no reason why some get it and some don't. But there has to be a reason unless you are all haunted by some kind of gremlin.

Link to comment
Share on other sites

Still there *has* to be a common something between those who get the issue and those who don't. My i5 (Mac) has no drop of any kind with HUD or map. Neither did my Quad Core 2 Duo PC with it's crappy video card.

Very confusing problem since there seems no reason why some get it and some don't. But there has to be a reason unless you are all haunted by some kind of gremlin.

Could it be ping based? Seems like people in Texas never have stinkin game issues. Also i know the non hud related fps hit is due to some of the lower end graphics options are gone and ragdoll being mandatory.

Link to comment
Share on other sites

Hi all,

My ping from here NY is a steady 50-60 , pretty much the same area (tad higher) for the other chap who done the test who is in Scotland.

Just as an add on , we have another squad member who is in Arizona and his FPS dropped from a stonking 170 to average 90 FPS.

And yes.....our hearts bleed for him on TS when he mentions this.

As for gremlins then it would appear all of our squad (13th) has them with the FPS drop so its not isolated nor geographic centric.

Cheers

Edited by expatpom
Link to comment
Share on other sites

i know your doing your best and this game is awesome but its been 2 weeks+ i havnt been able to play now. im not a rich man and subs is running out

Link to comment
Share on other sites

Hi all,

My ping from here NY is a steady 50-60 , pretty much the same area (tad higher) for the other chap who done the test who is in Scotland.

Just as an add on , we have another squad member who is in Arizona and his FPS dropped from a stonking 170 to average 90 FPS.

And yes.....our hearts bleed for him on TS when he mentions this.

As for gremlins then it would appear all of our squad (13th) has them with the FPS drop so its not isolated nor geographic centric.

Cheers

So it's not ping which is not surprising. Could it be cpu affinity being set? If you force the game to one core only it would mess up the map.

Link to comment
Share on other sites

  • CORNERED RAT

Found a way to trigger the 10fps less with screen elements off (y key).

I use a plantronics gamecom headset, DSP headset with inline sound card.

It is also set in windows as my default sound card.

If I have the headset selected in the games preferances then only 1 or 2 fps difference toggling y key.

If I set the games preferances to "primary" the sound still comes through me headset but I see a 10 fps difference toggling Y key.

With headset selected I get the same fps with huds on as I get with huds off if set to primary in preferances.

Link to comment
Share on other sites

Hi ahwulf,

Nothing to do with setting force setting the CPU mate I'm afraid we both have not done that.

This issue isn't isolated mate its nearly the whole playerbase so not due to AMD or Intel processors either its the whole shooting match , you could probably do a straw poll in game on FPS loss and get a resounding yes feedback.

At the moment we have a few players on our squad who are unable to even play the game due to FPS degradation and waiting around for another patch.

Its something to do with 1.33 but its isolating the issue that's the pain in the posterior.

Even on the training server this afternoon for a squad match we had reduced FPS throughout the players.

Enough with venting though...just its getting tiring.

CHeers

Link to comment
Share on other sites

I am trying to understand the map/hud fps issue. I guess we need a separate post for that one.

The other FPS issues are related to infantry and possibly physics but they are unrelated to the UI issue.

Link to comment
Share on other sites

In 1.33, i have checked the cpu performance, not looking good!

AMD Phenom 2 quad 3ghz, overall performance 23-25%????

First core runs at approx 70-75%???

EDIT: Why would it not be running the CPU at max?

Edited by geckopow
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.



×
×
  • Create New...